Xenial update to v4.4.41 stable release

Bug #1655041 reported by Tim Gardner on 2017-01-09
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The v4.4.41 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches from the v4.4.41 stable release shall be applied:

ssb: Fix error routine when fallback SPROM fails
rtlwifi: Fix enter/exit power_save
cfg80211/mac80211: fix BSS leaks when abandoning assoc attempts
ath9k: Really fix LED polarity for some Mini PCI AR9220 MB92 cards.
mmc: sdhci: Fix recovery from tuning timeout
regulator: stw481x-vmmc: fix ages old enable error
timekeeping_Force_unsigned_clocksource_to_nanoseconds_conversion
clk: bcm2835: Avoid overwriting the div info when disabling a pll_div clk
thermal: hwmon: Properly report critical temperature in sysfs
staging: comedi: ni_mio_common: fix M Series ni_ai_insn_read() data mask
staging: comedi: ni_mio_common: fix E series ni_ai_insn_read() data
ACPI / video: Add force_native quirk for Dell XPS 17 L702X
ACPI / video: Add force_native quirk for HP Pavilion dv6
drm/nouveau/kms: lvds panel strap moved again on maxwell
drm/nouveau/bios: require checksum to match for fast acpi shadow method
drm/nouveau/ltc: protect clearing of comptags with mutex
drm/nouveau/fifo/gf100-: protect channel preempt with subdev mutex
drm/nouveau/i2c/gk110b,gm10x: use the correct implementation
drm/radeon: Also call cursor_move_locked when the cursor size changes
drm/radeon: Hide the HW cursor while it's out of bounds
drm/radeon: add additional pci revision to dpm workaround
drm/gma500: Add compat ioctl
drivers/gpu/drm/ast: Fix infinite loop if read fails
mei: request async autosuspend at the end of enumeration
block: protect iterate_bdevs() against concurrent close
vt: fix Scroll Lock LED trigger name
scsi: megaraid_sas: For SRIOV enabled firmware, ensure VF driver waits for 30secs before reset
scsi: megaraid_sas: Do not set MPI2_TYPE_CUDA for JBOD FP path for FW which does not support JBOD sequence map
scsi: zfcp: fix use-after-"free" in FC ingress path after TMF
scsi: zfcp: do not trace pure benign residual HBA responses at default level
scsi: zfcp: fix rport unblock race with LUN recovery
scsi: avoid a permanent stop of the scsi device's request queue
ARC: mm: arc700: Don't assume 2 colours for aliasing VIPT dcache
firmware: fix usermode helper fallback loading
s390/vmlogrdr: fix IUCV buffer allocation
sc16is7xx: Drop bogus use of IRQF_ONESHOT
md/raid5: limit request size according to implementation limits
KVM: PPC: Book3S HV: Save/restore XER in checkpointed register state
KVM: PPC: Book3S HV: Don't lose hardware R/C bit updates in H_PROTECT
kvm: nVMX: Allow L1 to intercept software exceptions (#BP and #OF)
platform/x86: asus-nb-wmi.c: Add X45U quirk
fgraph: Handle a case where a tracer ignores set_graph_notrace
IB/mad: Fix an array index check
IPoIB: Avoid reading an uninitialized member variable
IB/multicast: Check ib_find_pkey() return value
IB/cma: Fix a race condition in iboe_addr_get_sgid()
media: solo6x10: fix lockup by avoiding delayed register write
Input: drv260x - fix input device's parent assignment
PCI: Check for PME in targeted sleep state
libceph: verify authorize reply on connect
nfs_write_end(): fix handling of short copies
powerpc/ps3: Fix system hang with GCC 5 builds
powerpc: Convert cmp to cmpd in idle enter sequence
kconfig/nconf: Fix hang when editing symbol with a long prompt
sg_write()/bsg_write() is not fit to be called under KERNEL_DS
net: mvpp2: fix dma unmapping of TX buffers for fragments
Linux 4.4.41

The following commit was skipped as it was already applied to master-next:

ftrace/x86_32: Set ftrace_stub to weak to prevent gcc from using short jumps to it

Tim Gardner (timg-tpi) on 2017-01-09
tags: added: kernel-stable-tracking-bug
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Xenial):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Luis Henriques (henrix) on 2017-01-20
description: updated
Changed in linux (Ubuntu Xenial):
status: Confirmed → Fix Committed
Breno Leitão (breno-leitao) wrote :

Hello,

Any idea when the kernel with this fix will be made available?

Thanks

Tim Gardner (timg-tpi) wrote :

v4.4.41 through v4.4.44 will be released with Ubuntu-4.4.0-63.84.

Launchpad Janitor (janitor) wrote :
Download full text (23.0 KiB)

This bug was fixed in the package linux - 4.4.0-63.84

---------------
linux (4.4.0-63.84) xenial; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1660704

  * Backport Dirty COW patch to prevent wineserver freeze (LP: #1658270)
    - SAUCE: mm: Respect FOLL_FORCE/FOLL_COW for thp

  * Kdump through NMI SMP and single core not working on Ubuntu16.10
    (LP: #1630924)
    - x86/hyperv: Handle unknown NMIs on one CPU when unknown_nmi_panic
    - SAUCE: hv: don't reset hv_context.tsc_page on crash

  * [regression 4.8.0-14 -> 4.8.0-17] keyboard and touchscreen lost on Acer
    Chromebook R11 (LP: #1630238)
    - [Config] CONFIG_PINCTRL_CHERRYVIEW=y

  * Call trace when testing fstat stressor on ppc64el with virtual keyboard and
    mouse present (LP: #1652132)
    - SAUCE: HID: usbhid: Quirk a AMI virtual mouse and keyboard with ALWAYS_POLL

  * VLAN SR-IOV regression for IXGBE driver (LP: #1658491)
    - ixgbe: Force VLNCTRL.VFE to be set in all VMDq paths

  * "Out of memory" errors after upgrade to 4.4.0-59 (LP: #1655842)
    - mm, page_alloc: convert alloc_flags to unsigned
    - mm, compaction: change COMPACT_ constants into enum
    - mm, compaction: distinguish COMPACT_DEFERRED from COMPACT_SKIPPED
    - mm, compaction: simplify __alloc_pages_direct_compact feedback interface
    - mm, compaction: distinguish between full and partial COMPACT_COMPLETE
    - mm, compaction: abstract compaction feedback to helpers
    - mm, oom: protect !costly allocations some more
    - mm: consider compaction feedback also for costly allocation
    - mm, oom, compaction: prevent from should_compact_retry looping for ever for
      costly orders
    - mm, oom: protect !costly allocations some more for !CONFIG_COMPACTION
    - mm, oom: prevent premature OOM killer invocation for high order request

  * Backport 3 patches to fix bugs with AIX clients using IBMVSCSI Target Driver
    (LP: #1657194)
    - SAUCE: ibmvscsis: Fix max transfer length
    - SAUCE: ibmvscsis: fix sleeping in interrupt context
    - SAUCE: ibmvscsis: Fix srp_transfer_data fail return code

  * NVMe: adapter is missing after abnormal shutdown followed by quick reboot,
    quirk needed (LP: #1656913)
    - nvme: apply DELAY_BEFORE_CHK_RDY quirk at probe time too

  * Ubuntu 16.10 KVM SRIOV: if enable sriov while ping flood is running ping
    will stop working (LP: #1625318)
    - PCI: Do any VF BAR updates before enabling the BARs
    - PCI: Ignore BAR updates on virtual functions
    - PCI: Update BARs using property bits appropriate for type
    - PCI: Separate VF BAR updates from standard BAR updates
    - PCI: Don't update VF BARs while VF memory space is enabled
    - PCI: Remove pci_resource_bar() and pci_iov_resource_bar()
    - PCI: Decouple IORESOURCE_ROM_ENABLE and PCI_ROM_ADDRESS_ENABLE
    - PCI: Add comments about ROM BAR updating

  * Linux rtc self test fails in a VM under xenial (LP: #1649718)
    - kvm: x86: Convert ioapic->rtc_status.dest_map to a struct
    - kvm: x86: Track irq vectors in ioapic->rtc_status.dest_map
    - kvm: x86: Check dest_map->vector to match eoi signals for rtc

  * Xenial update to v4.4.44 stable releas...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers