Xenial update to v4.4.40 stable release

Bug #1654602 reported by Tim Gardner on 2017-01-06
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The v4.4.40 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches from the v4.4.40 stable release shall be applied:

btrfs: limit async_work allocation and worker func duration
Btrfs: fix tree search logic when replaying directory entry deletes
btrfs: store and load values of stripes_min/stripes_max in balance status item
Btrfs: fix qgroup rescan worker initialization
USB: serial: option: add support for Telit LE922A PIDs 0x1040, 0x1041
USB: serial: option: add dlink dwm-158
USB: serial: kl5kusb105: fix open error path
USB: cdc-acm: add device id for GW Instek AFG-125
usb: hub: Fix auto-remount of safely removed or ejected USB-3 devices
usb: gadget: f_uac2: fix error handling at afunc_bind
usb: gadget: composite: correctly initialize ep->maxpacket
USB: UHCI: report non-PME wakeup signalling for Intel hardware
ALSA: usb-audio: Add QuickCam Communicate Deluxe/S7500 to volume_control_quirks
ALSA: hiface: Fix M2Tech hiFace driver sampling rate change
ALSA: hda/ca0132 - Add quirk for Alienware 15 R2 2016
ALSA: hda - ignore the assoc and seq when comparing pin configurations
ALSA: hda - fix headset-mic problem on a Dell laptop
ALSA: hda - Gate the mic jack on HP Z1 Gen3 AiO
ALSA: hda: when comparing pin configurations, ignore assoc in addition to seq
clk: ti: omap36xx: Work around sprz319 advisory 2.1
Btrfs: fix memory leak in reading btree blocks
Btrfs: bail out if block group has different mixed flag
Btrfs: return gracefully from balance if fs tree is corrupted
Btrfs: don't leak reloc root nodes on error
Btrfs: fix memory leak in do_walk_down
Btrfs: don't BUG() during drop snapshot
btrfs: make file clone aware of fatal signals
block_dev: don't test bdev->bd_contains when it is not stable
ptrace: Capture the ptracer's creds not PT_PTRACE_CAP
crypto: caam - fix AEAD givenc descriptors
ext4: fix mballoc breakage with 64k block size
ext4: fix stack memory corruption with 64k block size
ext4: use more strict checks for inodes_per_block on mount
ext4: fix in-superblock mount options processing
ext4: add sanity checking to count_overhead()
ext4: reject inodes with negative size
ext4: return -ENOMEM instead of success
ext4: do not perform data journaling when data is encrypted
f2fs: set ->owner for debugfs status file's file_operations
loop: return proper error from loop_queue_rq()
mm/vmscan.c: set correct defer count for shrinker
fs: exec: apply CLOEXEC before changing dumpable task flags
exec: Ensure mm->user_ns contains the execed files
usb: gadget: composite: always set ep->mult to a sensible value
blk-mq: Do not invoke .queue_rq() for a stopped queue
dm flakey: return -EINVAL on interval bounds error in flakey_ctr()
dm crypt: mark key as invalid until properly loaded
dm space map metadata: fix 'struct sm_metadata' leak on failed create
ASoC: intel: Fix crash at suspend/resume without card registration
CIFS: Fix a possible memory corruption during reconnect
CIFS: Fix missing nls unload in smb2_reconnect()
CIFS: Fix a possible memory corruption in push locks
kernel/watchdog: use nmi registers snapshot in hardlockup handler
kernel/debug/debug_core.c: more properly delay for secondary CPUs
tpm xen: Remove bogus tpm_chip_unregister
xen/gntdev: Use VM_MIXEDMAP instead of VM_IO to avoid NUMA balancing
arm/xen: Use alloc_percpu rather than __alloc_percpu
xfs: set AGI buffer type in xlog_recover_clear_agi_bucket
driver core: fix race between creating/querying glue dir and its cleanup
ppp: defer netns reference release for ppp channel
Linux 4.4.40

Tim Gardner (timg-tpi) on 2017-01-06
tags: added: kernel-stable-tracking-bug
description: updated
Luis Henriques (henrix) on 2017-01-06
Changed in linux (Ubuntu Xenial):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (10.8 KiB)

This bug was fixed in the package linux - 4.4.0-62.83

---------------
linux (4.4.0-62.83) xenial; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1657430

  * Backport DP MST fixes to i915 (LP: #1657353)
    - SAUCE: i915_bpo: Fix DP link rate math
    - SAUCE: i915_bpo: Validate mode against max. link data rate for DP MST

  * Ubuntu xenial - 4.4.0-59-generic i3 I/O performance issue (LP: #1657281)
    - blk-mq: really fix plug list flushing for nomerge queues

linux (4.4.0-61.82) xenial; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1656810

  * Xen MSI setup code incorrectly re-uses cached pirq (LP: #1656381)
    - SAUCE: xen: do not re-use pirq number cached in pci device msi msg data

  * nvme drive probe failure (LP: #1626894)
    - nvme: revert NVMe: only setup MSIX once

linux (4.4.0-60.81) xenial; urgency=low

  [ John Donnelly ]

  * Release Tracking Bug
    - LP: #1656084

  * Couldn't emulate instruction 0x7813427c (LP: #1634129)
    - KVM: PPC: Book3S PR: Fix illegal opcode emulation

  * perf: 24x7: Eliminate domain name suffix in event names (LP: #1560482)
    - powerpc/perf/hv-24x7: Fix usage with chip events.
    - powerpc/perf/hv-24x7: Display change in counter values
    - powerpc/perf/hv-24x7: Display domain indices in sysfs
    - powerpc/perf/24x7: Eliminate domain suffix in event names

  * i386 ftrace tests hang on ADT testing (LP: #1655040)
    - ftrace/x86_32: Set ftrace_stub to weak to prevent gcc from using short jumps
      to it

  * VMX module autoloading if available (LP: #1651322)
    - powerpc: Add module autoloading based on CPU features
    - crypto: vmx - Convert to CPU feature based module autoloading

  * ACPI probe support for AD5592/3 configurable multi-channel converter
    (LP: #1654497)
    - SAUCE: iio: dac: ad5592r: Add ACPI support
    - SAUCE: iio: dac: ad5593r: Add ACPI support

  * Xenial update to v4.4.40 stable release (LP: #1654602)
    - btrfs: limit async_work allocation and worker func duration
    - Btrfs: fix tree search logic when replaying directory entry deletes
    - btrfs: store and load values of stripes_min/stripes_max in balance status
      item
    - Btrfs: fix qgroup rescan worker initialization
    - USB: serial: option: add support for Telit LE922A PIDs 0x1040, 0x1041
    - USB: serial: option: add dlink dwm-158
    - USB: serial: kl5kusb105: fix open error path
    - USB: cdc-acm: add device id for GW Instek AFG-125
    - usb: hub: Fix auto-remount of safely removed or ejected USB-3 devices
    - usb: gadget: f_uac2: fix error handling at afunc_bind
    - usb: gadget: composite: correctly initialize ep->maxpacket
    - USB: UHCI: report non-PME wakeup signalling for Intel hardware
    - ALSA: usb-audio: Add QuickCam Communicate Deluxe/S7500 to
      volume_control_quirks
    - ALSA: hiface: Fix M2Tech hiFace driver sampling rate change
    - ALSA: hda/ca0132 - Add quirk for Alienware 15 R2 2016
    - ALSA: hda - ignore the assoc and seq when comparing pin configurations
    - ALSA: hda - fix headset-mic problem on a Dell laptop
    - ALSA: hda - Gate the mic jack on HP Z1 Gen3 AiO
    - ALSA: hd...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers