shaking screen

Bug #1651981 reported by Adrian on 2016-12-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

After login into Ubuntu the screen starts to shake permanently.
The login screen is still fine, problem start after log in.
The problem is caused by last kernel update: running Ubuntu with the older kernel 4.8.0-30-generic fixes the issue.

Upstream patch submission:
https://lists.freedesktop.org/archives/dri-devel/2016-December/128331.html

WORKAROUND: Revert:
# first bad commit: [9cc4fd5b9fbb0d74e77c81521da1e2fe712f6787] drm/radeon/si_dpm: workaround for SI kickers

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: linux-image-4.8.0-32-generic 4.8.0-32.34
ProcVersionSignature: Ubuntu 4.8.0-32.34-generic 4.8.11
Uname: Linux 4.8.0-32-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: afiergol 7797 F.... pulseaudio
 /dev/snd/controlC1: afiergol 7797 F.... pulseaudio
 /dev/snd/seq: timidity 6155 F.... timidity
Date: Thu Dec 22 10:02:30 2016
HibernationDevice: RESUME=UUID=7ca97ca1-ca2d-43f6-9b4c-cd61421c0831
InstallationDate: Installed on 2015-04-02 (629 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
MachineType: Hewlett-Packard HP ZBook 15 G2
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.8.0-32-generic root=/dev/mapper/ubuntu--vg-root ro radeon.dpm=1
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.8.0-32-generic N/A
 linux-backports-modules-4.8.0-32-generic N/A
 linux-firmware 1.161.1
SourcePackage: linux
UpgradeStatus: Upgraded to yakkety on 2016-10-16 (66 days ago)
dmi.bios.date: 04/25/2016
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: M70 Ver. 01.15
dmi.board.name: 2253
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 03.12
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvrM70Ver.01.15:bd04/25/2016:svnHewlett-Packard:pnHPZBook15G2:pvrA3008CD10003:rvnHewlett-Packard:rn2253:rvrKBCVersion03.12:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ZBook 15 G2
dmi.product.version: A3008CD10003
dmi.sys.vendor: Hewlett-Packard

Adrian (adrianf0) wrote :
Adrian (adrianf0) on 2016-12-22
description: updated

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Adrian, thank you for reporting this and helping make Ubuntu better.

In order to allow additional upstream developers to examine the issue, at your earliest convenience, could you please test the latest upstream kernel available from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D ? Please keep in mind the following:
1) The one to test is at the very top line at the top of the page (not the daily folder).
2) The release names are irrelevant.
3) The folder time stamps aren't indicative of when the kernel actually was released upstream.
4) Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds .

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Also, you don't need to apport-collect further unless specifically requested to do so.

It is most helpful that after testing of the latest upstream kernel is complete, you mark this report Status Confirmed.

Lastly, to keep this issue relevant to upstream, please continue to test the latest mainline kernel as it becomes available.

Thank you for your help.

tags: added: bios-outdated-1.16 regression-update
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Adrian (adrianf0) on 2016-12-26
tags: added: kernel-bug-exists-upstream-4.10.0-041000rc1
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Adrian, the next step is to fully commit bisect from kernel 4.8.0-30-generic to 4.8.0-32-generic in order to identify the last good kernel commit, followed immediately by the first bad one. This will allow for a more expedited analysis of the root cause of your issue. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions, or providing a commit from a kernel version bisect is not fully commit bisecting.

Also, the kernel release names are irrelevant for the purposes of bisecting.

It is most helpful that after the fix commit (not kernel version) has been identified, you then mark this report Status Confirmed.

Thank you for your help.

tags: added: kernel-bug-exists-upstream-4.10-rc1 needs-bisect
removed: kernel-bug-exists-upstream-4.10.0-041000rc1
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Adrian (adrianf0) wrote :

I sent the patch to <email address hidden>.

Result of bisection:

# bad: [bafa160b3ae93a4d6f6989e6b32bc4d06b56be31] UBUNTU: Ubuntu-4.8.0-31.33
# good: [4b87663a746d13120384360f7e6129fd2828b485] UBUNTU: Ubuntu-4.8.0-30.32
git bisect start 'Ubuntu-4.8.0-31.33' 'Ubuntu-4.8.0-30.32'
# bad: [63d1d029bf41f625ee23888484815acbbf88afd7] mmc: sdhci: Fix CMD line reset interfering with ongoing data transfer
git bisect bad 63d1d029bf41f625ee23888484815acbbf88afd7
# good: [c4f21d2d45d0d390a5510d0128d7c03c0f4bdc56] mac80211: discard multicast and 4-addr A-MSDUs
git bisect good c4f21d2d45d0d390a5510d0128d7c03c0f4bdc56
# bad: [992733430c9d7ea2fd1eebe6c5e5f1c667b0e9e7] net: Add netdev all_adj_list refcnt propagation to fix panic
git bisect bad 992733430c9d7ea2fd1eebe6c5e5f1c667b0e9e7
# bad: [c098aeb56ee8bd422bcf416eb1a32f2ef3aeddcb] drm/i915/fbc: fix CFB size calculation for gen8+
git bisect bad c098aeb56ee8bd422bcf416eb1a32f2ef3aeddcb
# good: [67ef4bbe62cd7eb46d9b4f8c4ecbab9c05c6da27] drm/radeon/si_dpm: Limit clocks on HD86xx part
git bisect good 67ef4bbe62cd7eb46d9b4f8c4ecbab9c05c6da27
# bad: [9b326d0d38ca7ba837eaa1ea20f0025c566c8005] drm/fb-helper: Keep references for the current set of used connectors
git bisect bad 9b326d0d38ca7ba837eaa1ea20f0025c566c8005
# bad: [74980b9e4b15a5228db4ac01b9e07c7e063b3b88] drm/nouveau/acpi: fix check for power resources support
git bisect bad 74980b9e4b15a5228db4ac01b9e07c7e063b3b88
# bad: [cd8ae00ac77adbe3d00702daad77608aecceb77a] drm/radeon: drop register readback in cayman_cp_int_cntl_setup
git bisect bad cd8ae00ac77adbe3d00702daad77608aecceb77a
# bad: [9cc4fd5b9fbb0d74e77c81521da1e2fe712f6787] drm/radeon/si_dpm: workaround for SI kickers
git bisect bad 9cc4fd5b9fbb0d74e77c81521da1e2fe712f6787
# first bad commit: [9cc4fd5b9fbb0d74e77c81521da1e2fe712f6787] drm/radeon/si_dpm: workaround for SI kickers

tags: added: performed-bisect
removed: needs-bisect
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: patch

Adrian, to clarify:
1) You tested reverting first bad commit: [9cc4fd5b9fbb0d74e77c81521da1e2fe712f6787] drm/radeon/si_dpm: workaround for SI kickers and it was confirmed to stop the problem completely?
2) Regarding your patch https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1651981/+attachment/4798046/+files/0001-Add-dpm-stability-quirk-for-HP-Firepro-W5170M.patch was this also confirmed to stop the problem completely?

description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Adrian (adrianf0) wrote :

Christopher,
1) Yes, reverting the bad commit (9cc4fd5b9fbb0d74e77c81521da1e2fe712f6787) stop the problem completely.
2) Yes, I have tested the patch and it stops the problem completely.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: bisect-done
removed: performed-bisect
tags: removed: patch
description: updated
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Joseph Salisbury (jsalisbury) wrote :

Thank you for providing a patch, and making Ubuntu better.

Can you provide some information on the status of the patch with regards to getting it merged upstream? Has it been sent upstream, what sort of feedback has it received, is it getting applied to a subsystem maintainer's tree, etc?

People affected by this bug are probably wondering why the kernel team doesn't just apply the patch and fix it. The reason is that the kernel team is reluctant (not opposed) to apply any patch to a stable kernel that is not from upstream. Applying patches that don't come from upstream add greatly to the support of the kernel as other upstream patches may touch the same area as the non-upstream patch and may prevent them from applying cleanly.

To submit your patch, send your patch with the detailed description/changelog and your Signoff (ending with Signed-off-by: your name <email>), to the emails listed from ./scripts/get_maintainer.pl drivers/SUBSYSTEM-DETAILS (the get_maintainer.pl is from the kernel sources). Once you have sent the patch upstream and it's accepted, please drop a note here so that we can cherry-pick/include the patch into Ubuntu kernel.

tags: added: kernel-da-key
Adrian (adrianf0) on 2017-01-18
Changed in linux (Ubuntu):
status: Triaged → Confirmed

Adrian, to clarify, did you test the patch yourself (not rely on what someone else said)?

If not, could you please do so following https://wiki.ubuntu.com/Kernel/KernelBisection#Testing_a_newly_released_patch_from_upstream ?

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Adrian (adrianf0) wrote :

Christopher, I have tested and confirm that cherry pick of commit 8a08403bcb39f5d0e733bcf59a8a74f16b538f6e from the upstream kernel to Ubuntu-4.8.0-37.39 tag fixes the issue.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: cherry-pick
Changed in linux (Ubuntu Yakkety):
status: New → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-yakkety' to 'verification-done-yakkety'. If the problem still exists, change the tag 'verification-needed-yakkety' to 'verification-failed-yakkety'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-yakkety
Adrian (adrianf0) on 2017-02-27
tags: added: verification-done-yakkety
removed: verification-needed-yakkety
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package linux - 4.8.0-40.43

---------------
linux (4.8.0-40.43) yakkety; urgency=low

  * linux: 4.8.0-40.43 -proposed tracker (LP: #1667066)

  [ Andy Whitcroft ]
  * NFS client : permission denied when trying to access subshare, since kernel
    4.4.0-31 (LP: #1649292)
    - fs: Better permission checking for submounts

  * shaking screen (LP: #1651981)
    - drm/radeon: drop verde dpm quirks

  * [0bda:0328] Card reader failed after S3 (LP: #1664809)
    - usb: hub: Wait for connection to be reestablished after port reset

  * linux-lts-xenial 4.4.0-63.84~14.04.2 ADT test failure with linux-lts-xenial
    4.4.0-63.84~14.04.2 (LP: #1664912)
    - SAUCE: apparmor: fix link auditing failure due to, uninitialized var

  * In Ubuntu 17.04 : after reboot getting message in console like Unable to
    open file: /etc/keys/x509_ima.der (-2) (LP: #1656908)
    - SAUCE: ima: Downgrade error to warning

  * 16.04.2: Extra patches for POWER9 (LP: #1664564)
    - powerpc/mm: Fix no execute fault handling on pre-POWER5
    - powerpc/mm: Fix spurrious segfaults on radix with autonuma

  * ibmvscsis: Add SGL LIMIT (LP: #1662551)
    - ibmvscsis: Add SGL limit

  * [Hyper-V] Bug fixes for storvsc (tagged queuing, error conditions)
    (LP: #1663687)
    - scsi: storvsc: Enable tracking of queue depth
    - scsi: storvsc: Remove the restriction on max segment size
    - scsi: storvsc: Enable multi-queue support
    - scsi: storvsc: use tagged SRB requests if supported by the device
    - scsi: storvsc: properly handle SRB_ERROR when sense message is present
    - scsi: storvsc: properly set residual data length on errors

  * Ubuntu16.10-KVM:Big configuration with multiple guests running SRIOV VFs
    caused KVM host hung and all KVM guests down. (LP: #1651248)
    - KVM: PPC: Book 3S: XICS cleanup: remove XICS_RM_REJECT
    - KVM: PPC: Book 3S: XICS: correct the real mode ICP rejecting counter
    - KVM: PPC: Book 3S: XICS: Fix potential issue with duplicate IRQ resends
    - KVM: PPC: Book 3S: XICS: Implement ICS P/Q states
    - KVM: PPC: Book 3S: XICS: Don't lock twice when checking for resend

  * ISST-LTE:pNV: ppc64_cpu command is hung w HDs, SSDs and NVMe (LP: #1662666)
    - blk-mq: Avoid memory reclaim when remapping queues
    - blk-mq: Fix failed allocation path when mapping queues
    - blk-mq: Always schedule hctx->next_cpu

  * systemd-udevd hung in blk_mq_freeze_queue_wait testing unpartitioned NVMe
    drive (LP: #1662673)
    - percpu-refcount: fix reference leak during percpu-atomic transition

  * [Yakkety SRU] Enable KEXEC support in ARM64 kernel (LP: #1662554)
    - [Config] Enable KEXEC support in ARM64.

  * [Hyper-V] Fix ring buffer handling to avoid host throttling (LP: #1661430)
    - Drivers: hv: vmbus: On write cleanup the logic to interrupt the host
    - Drivers: hv: vmbus: On the read path cleanup the logic to interrupt the host
    - Drivers: hv: vmbus: finally fix hv_need_to_signal_on_read()

  * brd module compiled as built-in (LP: #1593293)
    - CONFIG_BLK_DEV_RAM=m

  * regession tests failing after stackprofile test is run (LP: #1661030)
    - SAUCE: fix regression with domain change in compla...

Read more...

Changed in linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Adrian (adrianf0) wrote :

Why the patch was dropped in the version 4.8.0.41.52 of linux-image-gerneric?
Does 4.8.0.41.52 corresponds to tag Ubuntu-4.8.0-41.44 ? If so, why the numbers don't match ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.