ndiswrapper-1.59 for kernel 4.8.0-41-generic (x86_64) doesn't compile/install

Bug #1651846 reported by Heiko Sieger on 2016-12-21
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-hwe (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Linux Mint 18.1 Serena
Ubuntu 16.04

Package:
ndiswrapper:
  Installed: 1.59-6
  Candidate: 1.59-6
  Version table:
 *** 1.59-6 500
        500 http://archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        100 /var/lib/dpkg/status

When installing kernel 4.8.0-30-generic on Linux Mint 18.1 (Ubuntu 16.04), ndiswrapper returns the following error:
"Building initial module for 4.8.0-30-generic
Error! Bad return status for module build on kernel: 4.8.0-30-generic (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.59/build/make.log for more information."

The same happens when re-installing via Synaptic. Synaptic reports "Changes applied" (doesn't report failure), but in fact there is no ndiswrapper module in /var/lib/dkms/ndiswrapper.

Here the content of /var/lib/dkms/ndiswrapper/1.59/build/make.log:

DKMS make.log for ndiswrapper-1.59 for kernel 4.8.0-30-generic (x86_64)
ד' דצמ 21 12:20:38 IST 2016
make: Entering directory '/usr/src/linux-headers-4.8.0-30-generic'
  LD /var/lib/dkms/ndiswrapper/1.59/build/built-in.o
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/crt_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/hal_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/ndis_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel_io_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/rtl_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/usb_exports.h
  MKSTUBS /var/lib/dkms/ndiswrapper/1.59/build/win2lin_stubs.h
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/crt.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/hal.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/iw_ndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/loader.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/ndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel_io.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/pe_linker.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/pnp.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/proc.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/rtl.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/wrapmem.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/wrapndis.o
/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.c: In function ‘tx_worker’:
/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.c:707:16: error: ‘struct net_device’ has no member named ‘trans_start’
    wnd->net_dev->trans_start = jiffies;
                ^
scripts/Makefile.build:289: recipe for target '/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.o' failed
make[1]: *** [/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.o] Error 1
Makefile:1489: recipe for target '_module_/var/lib/dkms/ndiswrapper/1.59/build' failed
make: *** [_module_/var/lib/dkms/ndiswrapper/1.59/build] Error 2
make: Leaving directory '/usr/src/linux-headers-4.8.0-30-generic'
---
ApportVersion: 2.20.1-0ubuntu2.4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: heiko 2688 F...m pulseaudio
 /dev/snd/controlC0: heiko 2688 F.... pulseaudio
 /dev/snd/controlC2: heiko 2688 F.... pulseaudio
 /dev/snd/controlC1: heiko 2688 F.... pulseaudio
CurrentDesktop: MATE
DistroRelease: Linux 18.1
HibernationDevice: RESUME=UUID=8102f808-7e26-489e-949b-978c20bc8175
InstallationDate: Installed on 2015-12-03 (383 days ago)
InstallationMedia: Linux Mint 17.3 "Rosa" - Release amd64 20151115
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
Package: linux (not installed)
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.8.0-30-generic root=/dev/mapper/lm13-root ro usbhid.quirks=0x058F:0x9410:0x20000000 ipv6.disable=1 vga=893 modprobe.blacklist=nouveau quiet intel_iommu=on iommu=pt
ProcVersionSignature: Ubuntu 4.8.0-30.32~16.04.1-generic 4.8.6
RelatedPackageVersions:
 linux-restricted-modules-4.8.0-30-generic N/A
 linux-backports-modules-4.8.0-30-generic N/A
 linux-firmware 1.157.6
RfKill:

Tags: serena
Uname: Linux 4.8.0-30-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kvm libvirtd lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 07/25/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4801
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: SABERTOOTH X79
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4801:bd07/25/2014:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnSABERTOOTHX79:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1651846

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected serena
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Heiko Sieger, thank you for reporting this. However, Linux Mint is not a recognized flavour of Ubuntu. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of your OS. Thanks!

If you are interested in learning more about recognized flavours of Ubuntu, check http://www.ubuntu.com/about/about-ubuntu/flavours.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Heiko Sieger (h-sieger) wrote :

Fair enough.

However, I believe that you'll find the same bug in Ubuntu and any of the recognized flavors.

Jaime R. Garza (garzaj) wrote :

THis bug also affects me!

This Bug Also affects me!

Also it is not a Linux Mint Bug.
Same happens in the standard Ubuntu 16.04, too!!!!

Look at

https://people.canonical.com/~ubuntu-archive/pending-sru.html -> changelog bug #1625089

and

https://launchpad.net/ubuntu/+source/ndiswrapper/

and

https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1625089

Changed in linux (Ubuntu):
status: Invalid → Confirmed
description: updated

1.60 packages needs to be pushed
from
Proposed (universe)
to
Release (universe)
in the repository of Ubuntu 16.04.

Changed in linux-hwe (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
summary: - ndiswrapper-1.59 for kernel 4.8.0-30-generic (x86_64) doesn't
+ ndiswrapper-1.59 for kernel 4.8.0-41.44~16.04.1 (x86_64) doesn't
compile/install
summary: - ndiswrapper-1.59 for kernel 4.8.0-41.44~16.04.1 (x86_64) doesn't
+ ndiswrapper-1.59 for kernel 4.8.0-41-generic (x86_64) doesn't
compile/install

Error! Bad return status for module build on kernel: 4.8.0-41-generic (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.59/build/make.log for more information.

DKMS make.log for ndiswrapper-1.59 for kernel 4.8.0-41-generic (x86_64)
Sa 18. Mär 10:21:55 CET 2017
make: Verzeichnis „/usr/src/linux-headers-4.8.0-41-generic“ wird betreten
  LD /var/lib/dkms/ndiswrapper/1.59/build/built-in.o
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/crt_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/hal_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/ndis_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel_io_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/rtl_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.59/build/usb_exports.h
  MKSTUBS /var/lib/dkms/ndiswrapper/1.59/build/win2lin_stubs.h
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/crt.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/hal.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/iw_ndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/loader.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/ndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/ntoskernel_io.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/pe_linker.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/pnp.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/proc.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/rtl.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/wrapmem.o
  CC [M] /var/lib/dkms/ndiswrapper/1.59/build/wrapndis.o
/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.c: In function ‘tx_worker’:
/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.c:707:16: error: ‘struct net_device’ has no member named ‘trans_start’
    wnd->net_dev->trans_start = jiffies;
                ^
scripts/Makefile.build:289: die Regel für Ziel „/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.o“ scheiterte
make[1]: *** [/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.o] Fehler 1
Makefile:1491: die Regel für Ziel „_module_/var/lib/dkms/ndiswrapper/1.59/build“ scheiterte
make: *** [_module_/var/lib/dkms/ndiswrapper/1.59/build] Fehler 2
make: Verzeichnis „/usr/src/linux-headers-4.8.0-41-generic“ wird verlassen

Installing the ndiswrapper 1.60-3 from the "proposed" repository solved the problem.

But enabling the "proposed" repository or installing any of its packages is not a stable solution, there are too many unstable packages with side effects.......

Doug Rohm (drohm) wrote :

How do you enable 'proposed' repository in LM 18.1?

Never active proposed/romeo repository if you want a stable & productive environment!

The proposed/romeo repository is for the builds, which needs to be tested!

Julian Andres Klode (juliank) wrote :

This was fixed in bug 1625089

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux-hwe (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers