Mouse cursor invisible or does not move

Bug #1646574 reported by Paweł Bylica on 2016-12-01
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Yakkety
Medium
Joseph Salisbury

Bug Description

When using nouveau driver for my GTX 1070 (mobile) the mouse cursor is fixed in left upper corner or sometimes disappear. I actually can click or hover everywhere on the screen, I just don't know where the mouse is pointer at the moment.
---
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: yakkety
DistroRelease: Ubuntu 16.10
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.8.0-27-generic, x86_64: installed
 bbswitch, 0.8, 4.9.0-040900rc7-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GP104M [GeForce GTX 1070] [10de:1be1] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: CLEVO/KAPOK Computer GP104M [GeForce GTX 1070] [1558:6a04]
InstallationDate: Installed on 2016-11-26 (5 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 8087:0a2b Intel Corp.
 Bus 001 Device 003: ID 1c7a:0603 LighTuning Technology Inc.
 Bus 001 Device 002: ID ffc0:0040
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Notebook P65_67RSRP
Package: xserver-xorg-video-nouveau 1:1.0.12-2
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.8.0-27-generic.efi.signed root=UUID=a596a1fd-2912-4a20-a48c-6b8a32078b5c ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.8.0-27.29-generic 4.8.1
Tags: yakkety ubuntu
Uname: Linux 4.8.0-27-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/24/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.05.03
dmi.board.asset.tag: Tag 12345
dmi.board.name: P65_67RSRP
dmi.board.vendor: Notebook
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Notebook
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.05.03:bd08/24/2016:svnNotebook:pnP65_67RSRP:pvrNotApplicable:rvnNotebook:rnP65_67RSRP:rvrNotApplicable:cvnNotebook:ct10:cvrN/A:
dmi.product.name: P65_67RSRP
dmi.product.version: Not Applicable
dmi.sys.vendor: Notebook
version.compiz: compiz 1:0.9.13.0+16.10.20160818.2-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2

apport information

no longer affects: linux (Ubuntu)
tags: added: apport-collected ubuntu yakkety
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Johan Ferner (johan-ferner) wrote :

I first see this in the installer and that makes installing Ubuntu a challenge...
The cursor does move but is invisible so you can kind of guess where you are supposed to click.
After installing the problem is still present.

Hardware is GTX 1080 on a desktop.

Doug Core (minit) wrote :

This frozen cursor in top left problem happened to me with Ubuntu 16.10 using a GTX 1070 in a desktop as well. I made it through the installation using the keyboard. Once I installed the nvidia-367 binary drivers the problem went away.

I ended up needing Ubuntu 16.04 for what I was doing and the cursor always worked during installation of that version.

David Jordan (dmj726) wrote :

This bug affects a number of different systems with Nvidia 10 Series (Pascal) GPUs. When using Nouveau, the cursor is drawn in the top left corner of the screen and appears to be stuck there despite the user being able to move around and click anywhere.

While it's possible to work around this bug by installing the proprietary Nvidia driver, this bug is a huge hassle when installing from the standard iso. (Also when the proprietary driver breaks or is removed for some reason)

The Nouveau developers report that this is fixed in Kernel 4.10 and pointed to this commit as solving the issue:
https://github.com/skeggsb/nouveau/commit/b94985176af536ab752a63baecdee263ffcce63f
With the two preceding commits being needed as well:
https://github.com/skeggsb/nouveau/commit/0d874f550816a6d7038658c3ec78c992e40c132f
https://github.com/skeggsb/nouveau/commit/88a1b714678ad1f5bda441052383e70a9d52f100

Still need to test these commits, but they look promising.

With 16.04.2 bringing in the 4.8 kernel, which is affected by this bug, it would be nice to have these cherry picked to make sure the ISO works with modern NVIDIA GPUs.

Brad Figg (brad-figg) on 2017-01-24
affects: xserver-xorg-video-nouveau (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Yakkety):
status: New → In Progress
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Changed in linux (Ubuntu Yakkety):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

I built a Yakkety test kernel with the three patches mentioned in comment #23. The test kernel can be downloaded from:

http://kernel.ubuntu.com/~jsalisbury/lp1646574/

Can you test this kernel and see if it resolves this bug?

Note, you need to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

Doug Core (minit) wrote :

Yes, this test kernel from comment #24 resolved the problem for me. I installed 16.10 from an ISO I had downloaded on 01-Jan-2017 and confirmed the cursor didn't work. I didn't allow it to connect to a network and installed no updates. I then installed the test kernel and the cursor started working after a reboot. I have a GTX 1070 in a desktop machine. Thank you!

David Jordan (dmj726) wrote :

Initial testing shows that the test kernel resolves the issue as well. I will continue to test to check for regressions, but I think we have a solution here.

Changed in linux (Ubuntu Yakkety):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.8.0-37.39

---------------
linux (4.8.0-37.39) yakkety; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1659381

  * Mouse cursor invisible or does not move (LP: #1646574)
    - drm/nouveau/disp/nv50-: split chid into chid.ctrl and chid.user
    - drm/nouveau/disp/nv50-: specify ctrl/user separately when constructing
      classes
    - drm/nouveau/disp/gp102: fix cursor/overlay immediate channel indices

 -- Benjamin M Romer <email address hidden> Wed, 25 Jan 2017 16:12:02 -0200

Changed in linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-hwe has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers