Sound fails after suspend state

Bug #1645022 reported by Chad March on 2016-11-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have a new Dell XPS 13 9360 with Ubuntu 16.04 4.4.0-47-generic. Whenever I close the lid, it is set to suspend the OS state. Whenever I resume, the sound card and settings all appear normal, however no sound comes out of the speakers. Restarting the computer does not restore the sound state, but shutting down and starting up does. Similar issues occur with the touchscreen capabilities.
---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marchchad 3952 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=5c44e7ca-8d62-43ab-b1f7-ee3b36a231c0
InstallationDate: Installed on 2016-11-20 (5 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 0c45:670c Microdia
 Bus 001 Device 003: ID 04f3:20d0 Elan Microelectronics Corp.
 Bus 001 Device 002: ID 0cf3:e301 Atheros Communications, Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 13 9360
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-47-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.4.0-47.68-generic 4.4.24
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-47-generic N/A
 linux-backports-modules-4.4.0-47-generic N/A
 linux-firmware 1.157.5
Tags: xenial
Uname: Linux 4.4.0-47-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/13/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.0.7
dmi.board.name: 0T3FTF
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.0.7:bd09/13/2016:svnDellInc.:pnXPS139360:pvr:rvnDellInc.:rn0T3FTF:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 13 9360
dmi.sys.vendor: Dell Inc.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1645022

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected xenial
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.9 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.9-rc7

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Chad March (marchchad) wrote :

I'll try out the latest upstream kernel tonight.

The computer started out with Windows 10 and it was super buggy and I wanted to give Ubuntu a shot. I installed this kernel via USB. I have not tried a previous version of Ubuntu yet.

Some additional behavior notes:

Currently when I resume from a suspended state, without plugging any devices, I get a popup asking "What type of device did you plug in?" and gives me options for Headphones, Headset, or Microphone. (Attached is a screenshot) When this happens, I've tried all 3 device options, clicking cancel, closing the dialog, and going to the Sound Settings..., but no matter what path I pursue, no audio will play. When looking at the Output tab of the Sound Settings, under the "Play Sounds Through" list, there are 3 separate HDMI audio outputs, the HD Sound Card, and the headphone jack listed. Regardless of which option I choose, no audio plays. If I restart (not power off/on) while in this state, when I log back in and check the settings, all audio output options are gone and only the Dummy Output option remains.

Also, after a recent shutdown/power on power cycle to restore audio functionality, audio only plays out of the right speakers.

Other notes:

I installed the Arc Desktop theme (https://github.com/horst3180/arc-theme). I doubt it effects it, but who knows.

I've also checked daily for any updates in the Software Center and have run apt-get upgrade && apt-get update too.

Hopefully these additional details will help you. If there are any other screenshots, log files, whatever you need, let me know and I'll provide them ASAP.

Chad March (marchchad) wrote :

I upgraded to 16.10 and am having the same issues.

I downloaded the following headers and image:
linux-headers-4.9.0-040900rc7-generic_4.9.0-040900rc7.201611271731_amd64.deb
linux-image-4.9.0-040900rc7-generic_4.9.0-040900rc7.201611271731_amd64.deb

And ran this command in the folder I downloaded them to:
sudo dpkg -i *.deb

This failed however, see attached.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Chad March (marchchad) wrote :

kernel-bug-exists-upstream

Chad March (marchchad) wrote :

Actually, I just tested everything out again, and although the install of the rc7 kernel failed the sound functionality seems to have been restored. I've checked resuming from a suspended state, restart and full power cycle and it seems to persist.

Chad March, to clarify https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1645022/comments/20 which kernel are you using when everything is working?

tags: added: bios-outdated-1.2.3
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Chad March (marchchad) wrote :

I ran `uname -r` and this is the output:

4.9.0-040900rc7-generic

Not everything is working, but for the scope of this bug report, the sound and controls are working as expected.

Chad March, the next step is to fully reverse commit bisect from kernel 4.8 to 4.9-rc7 in order to identify the last bad commit, followed immediately by the first good one. Once this good commit has been identified, it may be reviewed for backporting. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection#How_do_I_reverse_bisect_the_upstream_kernel.3F ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Also, the kernel release names are irrelevant for the purposes of bisecting.

It is most helpful that after the fix commit (not kernel version) has been identified, you then mark this report Status Confirmed.

Thank you for your help.

tags: added: kernel-fixed-upstream kernel-fixed-upstream-4.9-rc7 needs-reverse-bisect
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers