Xenial update to 4.4.32 stable release

Bug #1642573 reported by Luis Henriques on 2016-11-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Luis Henriques

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The 4.4.32 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches from the 4.4.32 stable release shall be applied:

tcp: fix overflow in __tcp_retransmit_skb()
net: avoid sk_forward_alloc overflows
tcp: fix wrong checksum calculation on MTU probing
tcp: fix a compile error in DBGUNDO()
ip6_gre: fix flowi6_proto value in ip6gre_xmit_other()
ipmr, ip6mr: fix scheduling while atomic and a deadlock with ipmr_get_route
tg3: Avoid NULL pointer dereference in tg3_io_error_detected()
net: fec: set mac address unconditionally
net: pktgen: fix pkt_size
net/sched: act_vlan: Push skb->data to mac_header prior calling skb_vlan_*() functions
net: Add netdev all_adj_list refcnt propagation to fix panic
packet: call fanout_release, while UNREGISTERING a netdev
netlink: do not enter direct reclaim from netlink_dump()
ipv6: tcp: restore IP6CB for pktoptions skbs
ip6_tunnel: fix ip6_tnl_lookup
ipv6: correctly add local routes when lo goes up
net: pktgen: remove rcu locking in pktgen_change_name()
bridge: multicast: restore perm router ports on multicast enable
rtnetlink: Add rtnexthop offload flag to compare mask
net: add recursion limit to GRO
ipv4: disable BH in set_ping_group_range()
ipv4: use the right lock for ping_group_range
net: sctp, forbid negative length
udp: fix IP_CHECKSUM handling
net sched filters: fix notification of filter delete with proper handle
sctp: validate chunk len before actually using it
packet: on direct_xmit, limit tso and csum to supported devices
of: silence warnings due to max() usage
Revert KVM: MIPS: Drop other CPU ASIDs on guest MMU changes
KVM: MIPS: Drop other CPU ASIDs on guest MMU changes
drm/amdgpu/dp: add back special handling for NUTMEG
drm/amdgpu: fix DP mode validation
drm/radeon/dp: add back special handling for NUTMEG
drm/radeon: fix DP mode validation
scsi: megaraid_sas: fix macro MEGASAS_IS_LOGICAL to avoid regression
Linux 4.4.32

Luis Henriques (henrix) on 2016-11-17
tags: added: kernel-stable-tracking-bug
description: updated
Luis Henriques (henrix) on 2016-11-17
Changed in linux (Ubuntu Xenial):
assignee: nobody → Luis Henriques (henrix)
status: New → In Progress
Luis Henriques (henrix) on 2016-11-17
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (17.0 KiB)

This bug was fixed in the package linux - 4.4.0-57.78

---------------
linux (4.4.0-57.78) xenial; urgency=low

  * Release Tracking Bug
    - LP: #1648867

  * Miscellaneous Ubuntu changes
    - SAUCE: Do not build the xr-usb-serial driver for s390

linux (4.4.0-56.77) xenial; urgency=low

  * Release Tracking Bug
    - LP: #1648867

  * Release Tracking Bug
    - LP: #1648579

  * CONFIG_NR_CPUS=256 is too low (LP: #1579205)
    - [Config] Increase the NR_CPUS to 512 for amd64 to support systems with a
      large number of cores.

  * NVMe drives in Amazon AWS instance fail to initialize (LP: #1648449)
    - SAUCE: (no-up) NVMe: only setup MSIX once

linux (4.4.0-55.76) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1648503

  * NVMe driver accidentally reverted to use GSI instead of MSIX (LP: #1647887)
    - (fix) NVMe: restore code to always use MSI/MSI-x interrupts

linux (4.4.0-54.75) xenial; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1648017

  * Update hio driver to 2.1.0.28 (LP: #1646643)
    - SAUCE: hio: update to Huawei ES3000_V2 (2.1.0.28)

  * linux: Enable live patching for all supported architectures (LP: #1633577)
    - [Config] CONFIG_LIVEPATCH=y for s390x

  * Botched backport breaks level triggered EOIs in QEMU guests with --machine
    kernel_irqchip=split (LP: #1644394)
    - kvm/irqchip: kvm_arch_irq_routing_update renaming split

  * Xenial update to v4.4.35 stable release (LP: #1645453)
    - x86/cpu/AMD: Fix cpu_llc_id for AMD Fam17h systems
    - KVM: x86: fix missed SRCU usage in kvm_lapic_set_vapic_addr
    - KVM: Disable irq while unregistering user notifier
    - fuse: fix fuse_write_end() if zero bytes were copied
    - mfd: intel-lpss: Do not put device in reset state on suspend
    - can: bcm: fix warning in bcm_connect/proc_register
    - i2c: mux: fix up dependencies
    - kbuild: add -fno-PIE
    - scripts/has-stack-protector: add -fno-PIE
    - x86/kexec: add -fno-PIE
    - kbuild: Steal gcc's pie from the very beginning
    - ext4: sanity check the block and cluster size at mount time
    - crypto: caam - do not register AES-XTS mode on LP units
    - drm/amdgpu: Attach exclusive fence to prime exported bo's. (v5)
    - clk: mmp: pxa910: fix return value check in pxa910_clk_init()
    - clk: mmp: pxa168: fix return value check in pxa168_clk_init()
    - clk: mmp: mmp2: fix return value check in mmp2_clk_init()
    - rtc: omap: Fix selecting external osc
    - iwlwifi: pcie: fix SPLC structure parsing
    - mfd: core: Fix device reference leak in mfd_clone_cell
    - uwb: fix device reference leaks
    - PM / sleep: fix device reference leak in test_suspend
    - PM / sleep: don't suspend parent when async child suspend_{noirq, late}
      fails
    - IB/mlx4: Check gid_index return value
    - IB/mlx4: Fix create CQ error flow
    - IB/mlx5: Use cache line size to select CQE stride
    - IB/mlx5: Fix fatal error dispatching
    - IB/core: Avoid unsigned int overflow in sg_alloc_table
    - IB/uverbs: Fix leak of XRC target QPs
    - IB/cm: Mark stale CM id's whenever the mad agent was unregistered
    - netfilter: nft_dynset: fix element timeou...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers