perf stat interval display broken on 4.4.x

Bug #1636647 reported by James Yang
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

perf stat with interval display (-I flag) gives incorrect results because the following perf/urgent patch has not been applied. (It's not in upstream longterm 4.4 either.)

https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/tools/perf/util/stat.c?id=51fd2df1e882a3c2a3f4b6c9ff243a93c9046dba

# cat /proc/version_signature
Ubuntu 4.4.0-34.53-generic 4.4.15

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1636647

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
James Yang (james-yang-g) wrote :
Revision history for this message
James Yang (james-yang-g) wrote :
Revision history for this message
James Yang (james-yang-g) wrote :
Revision history for this message
James Yang (james-yang-g) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key xenial
Changed in linux (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Xenial):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Luis Henriques (henrix)
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Xenial):
assignee: Tim Gardner (timg-tpi) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers