WLAN connection not being picked up after hibernation

Bug #163521 reported by aspa on 2007-11-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Quite frequently my laptop fails to reconnect to the wireless lan after waking up from hibernation.
Sometimes the network manager applet shows the network signal level indication bars but there's no connectivity, sometimes the applet shows the "connecting to network" indication but connection is never established.
Sometimes after hibernation I get the keyring password prompt and the system is able to reconnect just fine.

I'm using Ubuntu 7.10 with all the latest updates on Dell Latitude D620.

aspa@aspa-laptop:~$ dmesg|grep ipw3945:
[ 13.800000] ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.2.2mp.ubuntu1
[ 13.800000] ipw3945: Copyright(c) 2003-2006 Intel Corporation
[ 13.800000] ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
[ 15.704000] ipw3945: Detected geography ABG (13 802.11bg channels, 23 802.11a channels)

aspa (marko-asplund) on 2007-12-04
description: updated
aspa (marko-asplund) wrote :

I switched to the iwl3945 driver but i'm still seeing the same symptoms.
The issue seems to appear when the system goes into hibernation in one network and wakes up in another.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in linux:
status: New → Incomplete
aspa (marko-asplund) wrote :

Unfortunately I don't have the machine anymore. It's also not possible for me to install Ubuntu on my current machine.

Michael Nagel (nailor) wrote :

thats bad news, but i am closing this bug as nothing can be done here, then.
feel free to report other bug or reopen this one should you return to ubuntu sometime and experience problems...

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers