Screen flickers when booting ubuntu 16.10 on USB stick

Bug #1634451 reported by Basil Eric on 2016-10-18
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

My PC is Acer Aspire V3-772G. At present, I am using Ubuntu 16.04. I made bootable USB sticks using images of Ubuntu 16.10 and Ubuntu Gnome 16.10 and tried to install both of them. However, during boot up, the screen flickers when the mouse is not moving. This screen flickering does not happen when I boot Ubuntu/Ubuntu Gnome 16.04 on USB stick.

LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-43-generic 4.4.0-43.63
ProcVersionSignature: Ubuntu 4.4.0-43.63-generic 4.4.21
Uname: Linux 4.4.0-43-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: basilrabi 2030 F.... pulseaudio
 /dev/snd/controlC0: basilrabi 2030 F.... pulseaudio
CurrentDesktop: Unity
Date: Tue Oct 18 18:09:25 2016
HibernationDevice: RESUME=UUID=0d507585-3d7d-4cbb-89ff-5b4cd2b964ff
InstallationDate: Installed on 2016-04-24 (176 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: Acer Aspire V3-772G
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-43-generic.efi.signed root=UUID=3d4fde01-c8b1-4497-b23d-ed75f4d8fe85 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-43-generic N/A
 linux-backports-modules-4.4.0-43-generic N/A
 linux-firmware 1.157.4
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/07/2014
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.15
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: VA70_HW
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.15:bd03/07/2014:svnAcer:pnAspireV3-772G:pvrV1.15:rvnAcer:rnVA70_HW:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Aspire V3-772G
dmi.product.version: V1.15
dmi.sys.vendor: Acer

Basil Eric (basilrabi) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Can you see if this issue also happens with the latest daily image? It can be downloaded from:
http://cdimage.ubuntu.com/daily-live/current/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Basil Eric (basilrabi) wrote :

I just tried the latest daily image. The flickering is still there.

Additional information:
1. I tried connecting a secondary monitor via HDMI. The 2nd monitor does not flicker.
2. When the mouse pointer is moving, the primary monitor does not flicker.
3. When the web browser is loading, the primary monitor does not flicker. However, while the mouse is idle, the mouse pointer jitters.

Pigeon (david-galambos) wrote :

I updated my 16.04 to 16.10 and have to confirm that flickering is still there and the text console is doing the same.
I changed the kernel to 4.4 (from 16.04) and the flickering was gone.

Basil Eric (basilrabi) wrote :

This issue is also experienced in Fedora by updating the kernel to 4.6+
https://bugs.freedesktop.org/show_bug.cgi?id=97875

hakon (hakon-hagland) wrote :

I have the same problem. I installed a fresh Ubuntu 16.10 on my Lenovo Edge540 laptop. Screen starts flickering during installation from USB and only stops when the mouse is moving. Very annoying. See this question on askubuntu.com :

http://askubuntu.com/q/838957/156688

seems like there are many people having this issue.

hakon (hakon-hagland) wrote :

It was not quite correct what I said about flickering stopping only when mouse moves. It also stops when something is output continuously to the terminal window. For example, running the following command in gnome-terminal window:

perl -MTime::HiRes -E '$i=0;while (1) { $i++; Time::HiRes::sleep( 0.2 ); say "Hello $i" }'

causes the flickering to stop. However, if I increase the sleep delay between writes to the terminal from 0.2 to 0.3 seconds, flickering starts again. So the output must be continuous for the flickering to stop.

Grzegorz Śliwiński (fizyk) wrote :

just tried with regular live usb image on my laptop before upgrading, and same issue prompted me to find both this bug report and the askubuntu question. noticed same thing if soemthing is happening (webpage loading) there's no backlight flickering, otherwise it constantly flickers.

BE-H (beh65) wrote :

Hi, I just upgraded my Lenovo Ideapad Z510 from 16.04 to 16.10 and have the same problem. Would be good to get this fixed as it is really annoying.

BE-H (beh65) wrote :

I can also confirm what was written above. If I boot using kernel 4.4 the flickering goes away, but that is just a circumvention and not a solution.

Grzegorz Śliwiński (fizyk) wrote :

Ubuntu 16.04.2 is also affected. Just tried from LiveUSB

Noxum (noxum) wrote :

use i915.enable_psr=0 in kernel cmdline
See: https://patchwork.kernel.org/patch/8297141/

BE-H (beh65) wrote :

I installed Ubuntu 17.04 and with that I do not have the issue anymore.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.