yakkety: daily powerpc server ISO fails to find cdrom during install in a VM

Bug #1628284 reported by Nish Aravamudan on 2016-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Yakkety
High
Tim Gardner

Bug Description

xenial daily ISO successfully installs using the same method on the same system, but yakkety reports:

Sep 27 21:13:14 cdrom-detect: Searching for Ubuntu installation media...
Sep 27 21:13:18 cdrom-detect: Devices: ''
Sep 27 21:13:23 cdrom-detect: Devices: ''
Sep 27 21:13:24 kernel: [ 154.649279] random: crng init done
Sep 27 21:13:28 cdrom-detect: Devices: ''
Sep 27 21:13:33 cdrom-detect: Devices: ''
Sep 27 21:13:38 cdrom-detect: Devices: ''
Sep 27 21:13:43 cdrom-detect: Devices: ''
Sep 27 21:13:48 cdrom-detect: Devices: ''
Sep 27 21:13:53 cdrom-detect: Devices: ''
Sep 27 21:13:58 cdrom-detect: Devices: ''
Sep 27 21:14:06 cdrom-detect: CDROM-detect failed; unmounting CD just to be sure
Sep 27 21:14:06 main-menu[267]: WARNING **: Configuring 'cdrom-detect' failed with error code 1
Sep 27 21:14:06 main-menu[267]: WARNING **: Menu item 'cdrom-detect' failed.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1628284

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1628284

tags: added: iso-testing
Nish Aravamudan (nacc) wrote :

I'm not able to run apport-collect from the installer shell.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-4.8
Andy Whitcroft (apw) on 2016-09-28
Changed in linux (Ubuntu):
importance: Undecided → High
Tim Gardner (timg-tpi) wrote :

Nish - Can you list the failing kernel version ? Also, please try the install using the net boot from http://cdimage.ubuntu.com/netboot/16.10/, or ISO from http://cdimage.ubuntu.com/releases/16.10/beta-2/

Changed in linux (Ubuntu Yakkety):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Nish Aravamudan (nacc) wrote :

uname -a from the installer shell:

Linux (none) 4.8.0-17-generic #19-Ubuntu SMP Sun Sep 25 05:58:36 UTC 2016 ppc64 GNU/Linux

We blocked release of the powerpc iso for beta2 because of this bug in #ubuntu-release, so there is no beta-2 image :)

For the net boot iso, (maybe because of the virtualized nic?) no network device is found and errors out there too.

Note this is trivially reproducible on a ppc64le host with:

qemu-system-ppc64 -enable-kvm -machine pseries,accel=kvm,usb=off -cpu host -smp cores=2,threads=1 -m 8G -no-reboot -device spapr-vscsi -display none -nographic -cdrom yakkety-server-powerpc.iso -drive file=/path/to/qcow/file,cache=unsafe -net nic -net user -boot dc

Tim Gardner (timg-tpi) wrote :

Nish - is this bug still present ? The daily ISO can be found at http://cdimage.ubuntu.com/ubuntu-server/daily/current/yakkety-server-powerpc.iso

Nish Aravamudan (nacc) wrote :

Hi Tim,

Discussed this with Josh Powers and it seems at least this particular issue is now fixed, sorry for the delay on my end.

-Nish

Changed in linux (Ubuntu Yakkety):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers