OOPS on beaglebone on boot of 4.4.0-36-generic under snappy ubuntu core xenial

Bug #1625177 reported by Oliver Grawert on 2016-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Paolo Pisati
Xenial
Undecided
Unassigned

Bug Description

SRU:

Problem: during installation, before configuring the network interfaces, netconf puts down all the network links and cpsw gets suspended - later on the PM code kicks and tries to access the suspended hardware generating an oops

Fix: apply the patches present in:

git://git.launchpad.net/~p-pisati/ubuntu/+source/linux x-master_lp1625177

and recompile.

How to reproduce: try to install an ubuntu-core image using the above patched kernel

----

trying to assemble a new series 16 ubuntu core image for the beaglebone black i am constantly running into an OOPS on first boot. seemingly related to the NIC driver since the NIC does not work after the OOPS.

syslog can be found at http://paste.ubuntu.com/23202737/

a test image exposing the bug can be found at:
http://people.canonical.com/~ogra/snappy/all-snaps/daily/current/

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1625177

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Oliver Grawert (ogra) wrote :

the log is in the pastebin mentioned in the description ...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Paolo Pisati (p-pisati) on 2016-09-19
Changed in linux (Ubuntu):
assignee: nobody → Paolo Pisati (p-pisati)
Paolo Pisati (p-pisati) on 2016-09-30
description: updated
description: updated
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Xenial):
status: New → Fix Committed
Seth Forshee (sforshee) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Oliver Grawert (ogra) on 2016-10-19
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.4.0-47.68

---------------
linux (4.4.0-47.68) xenial; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1636941

  * Add a driver for Amazon Elastic Network Adapters (ENA) (LP: #1635721)
    - lib/bitmap.c: conversion routines to/from u32 array
    - net: ethtool: add new ETHTOOL_xLINKSETTINGS API
    - net: ena: Add a driver for Amazon Elastic Network Adapters (ENA)
    - [config] enable CONFIG_ENA_ETHERNET=m (Amazon ENA driver)

  * unexpectedly large memory usage of mounted snaps (LP: #1636847)
    - [Config] switch squashfs to single threaded decode

 -- Kamal Mostafa <email address hidden> Wed, 26 Oct 2016 10:47:55 -0700

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers