rtl8821ae WiFI does not work

Bug #1622293 reported by Anton Polukhin on 2016-09-11
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

rtl8821ae does not work out-of the box on Ubuntu 16.04. It does not detect any WIFi networks and laptop starts with Wifi disabled in NetworkManager. To make rtl8821ae work I have to do the following:

echo "blacklist ideapad_laptop" | sudo tee /etc/modprobe.d/idepad.conf

After that rtl8821ae loses connection occasionally. None of those helped:

echo rtl8812ae >> /etc/modules
echo "options rtl8821ae ips=0 fwlps=0" | sudo tee /etc/modprobe.d/rtl8821ae.conf
sudo modprobe -r rtl8821ae && sudo modprobe rtl8821ae
options rtl8821ae ips=0 swenc=1 debug=5 msi=0
sudo iw dev wlp2s0 set power_save off

Installing new driver from here https://github.com/lwfinger/rtlwifi_new did not help.

Issue close to this one was reported here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1526683

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-36-generic 4.4.0-36.55
ProcVersionSignature: Ubuntu 4.4.0-36.55-generic 4.4.16
Uname: Linux 4.4.0-36-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: antoshkka 3397 F.... pulseaudio
 /dev/snd/controlC0: antoshkka 3397 F.... pulseaudio
CurrentDesktop: Unity
Date: Sun Sep 11 10:09:39 2016
HibernationDevice: RESUME=UUID=de96877a-7ace-47cc-ac4c-b4662a72a1b7
InstallationDate: Installed on 2016-09-10 (0 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: LENOVO 80NY
ProcFB: 0 amdgpudrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-36-generic.efi.signed root=UUID=d62213ac-da8e-417a-83fb-b8163b78199b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-36-generic N/A
 linux-backports-modules-4.4.0-36-generic N/A
 linux-firmware 1.157.3
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/15/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: CECN43WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: Allsparks 5B
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40688 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo ideapad Y700-15ACZ
dmi.modalias: dmi:bvnLENOVO:bvrCECN43WW:bd09/15/2015:svnLENOVO:pn80NY:pvrLenovoideapadY700-15ACZ:rvnLENOVO:rnAllsparks5B:rvrSDK0J40688WIN:cvnLENOVO:ct10:cvrLenovoideapadY700-15ACZ:
dmi.product.name: 80NY
dmi.product.version: Lenovo ideapad Y700-15ACZ
dmi.sys.vendor: LENOVO

Anton Polukhin (antoshkka) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Anton Polukhin, thank you for reporting this and helping make Ubuntu better.

In order to allow additional upstream developers to examine the issue, at your earliest convenience, could you please test the latest upstream kernel available from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D ? Please keep in mind the following:
1) The one to test is at the very top line at the top of the page (not the daily folder).
2) The release names are irrelevant.
3) The folder time stamps aren't indicative of when the kernel actually was released upstream.
4) Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds .

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Also, you don't need to apport-collect further unless specifically requested to do so.

It is most helpful that after testing of the latest upstream kernel is complete, you mark this report Status Confirmed.

Lastly, to keep this issue relevant to upstream, please continue to test the latest mainline kernel as it becomes available.

Thank you for your help.

tags: added: cecn43ww
removed: rtl8821ae
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Anton Polukhin (antoshkka) wrote :

With kernel 4.8-rc5, rtl8821ae does not looses connection (at least network manager does not display that), but the speed drops down to 0 really often and restores only after half a minute.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.8-rc5

Anton Polukhin:
1) Could you please advise to your router manufacturer, model, and firmware version?
2) Could you please ensure you are testing the latest mainline kernel (now 4.8-rc6)?

tags: added: latest-bios-cecn43ww
removed: cecn43ww
Anton Polukhin (antoshkka) wrote :

1) Manufacturer: TP-LINK
Model: WR841N v9 00000000
Firmware: 3.15.9 Build 140625 Rel.64271n

Anton Polukhin (antoshkka) wrote :

2) Problems with kernel 4.8-rc6 are mostly the same: tl8821ae does not loose the connection (at least network manager does not display that), but the speed drops down to 50KB/s really often. Instead of 2.5 MB/s connection speed, I have an average of ~100KB/s, with rare peeks up to 2.5MB/s and common dropdowns to less that 50KB/s. Latency is huge: if I pause downloading at the speed of 50KB/s and try to download some very simple web page, it may take a few minutes.

tags: added: kernel-bug-exists-upstream-4.8-rc6
tags: removed: kernel-bug-exists-upstream-4.8-rc5
Anton Polukhin (antoshkka) wrote :

I've changed the router to Netgear WNDR4000 and the problem still exists. Previous router TP-LINK WR841N v9 was successfully used by 5 different devices, so the problem is not in the router's firmware. It's in the rtl8821ae kernel module.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Anton Polukhin, could you please advise to your router firmware version?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Anton Polukhin (antoshkka) wrote :

Vendor Netgear
Hardware Version WNDR4000
Firmware Version V1.0.2.4_9.1.86
GUI Language Version V1.0.2.4_2.1.17.1

Firmware is up-to-date, I've updated it a few days ago.

Anton Polukhin, to clarify, what version of 802.11 are you using (ex. 802.11n)?

tags: added: latest-firmware
Anton Polukhin (antoshkka) wrote :

It uses 2.4GHz b/g/n and there's no way to disable 802.11n or force only 802.11b/g usage.

Anton Polukhin, the issue you are reporting is an upstream one. Could you please report this problem following the instructions verbatim at https://wiki.ubuntu.com/Bugs/Upstream/kernel to the appropriate mailing list (TO Larry.Finger, and Realtek WlanFAE CC linux-wireless)?

Please provide a direct URL to your post to the mailing list when it becomes available so that it may be tracked.

Thank you for your help.

Changed in linux (Ubuntu):
importance: Medium → High
status: Incomplete → Triaged
summary: - rtl8821ae WiFI does not work on Ubuntu 16.04
+ rtl8821ae WiFI does not work
NickT (nick-thearle) wrote :

Wifi drops with Ubuntu version 16.04.2 LTS (hardware enablement turned on) with kernel versions 4.10.0-27 and 4.10.0-28. It worked OK with kernel 4.8.0-58. The kernel upgrade was done when prompted by Ubuntu.

The wifi drops when BBC's iplayer or any of the speed test sites downloads a lot of data.

The wifi configuration as produced by a sudo lshw -C network is:

*-network
       description: Wireless interface
       product: RTL8821AE 802.11ac PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 00
       serial: b0:c0:90:3b:d8:f3
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8821ae driverversion=4.10.0-27-generic firmware=N/A ip=192.168.0.12 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:51 ioport:3000(size=256) memory:b2000000-b2003fff

After the wifi is dropped, the command sudo service network-manager restart does not turn on the wifi again

NickT (nick-thearle) wrote :

The same error is now exhibited with the newly released kernel version 4.10.0-30

Kai-Heng Feng (kaihengfeng) wrote :

Try latest mainline kernel & latest firmware for rtl8821ae.

James Cameron (quozl) wrote :

Summary; my own rtl8821ae frequent connection lost problem was fixed by upstream patch b8b8b16352cd ("rtlwifi: rtl8821ae: Fix connection lost problem") merged for 4.14-rc4.

I've recently fixed a problem very much like the problems reported in this bug. In particular the loss of WiFi scan results, and the connection loss on a burst of download data. Workaround was to turn wireless off then on again (using rfkill), or reboot. What I did was

(a) test several ubuntu kernels to find which ones were affected,

(b) using git bisect, tested several custom kernels, and proved my problem began with a single commit 40b368af4b75 ("rtlwifi: Fix alignment issues"),

(c) worked with upstream to determine a likely cause; the commit wasn't widely tested,

(d) proved through testing that the BIOS can have an effect; because the rtl8821ae driver does not reset the card, but inherits the card in whatever state the BIOS left it. This can randomise problem reports.

(e) proved that a power down and reboot can have a different effect to a warm reboot; some of the wireless card device registers are unchanged on warm reboot. This can randomise problem reports.

Hope that helps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers