Dbus fails to start sometimes after installing RT kernel

Bug #162035 reported by ces on 2007-11-11
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running Ubuntu 7.10. Recently I installed the real time kernel from the standard Ubuntu repositories (2.6.22-14-rt). After installing it, I think dbus fails to start at boot sometimes. At first I thought it was a problem with gnome-settings-daemon, because it wouldn't start and was the most obvious error, but then I noticed that Tracker wouldn't work correctly, and that I couldn't even lock my screen. The problem was that none of these applications could connect to dbus. When I run dbus-monitor in the terminal, I get the error:

Failed to open connection to session message bus: Failed to connect to socket /tmp/dbus-cZvDXoT3nt: Connection refused

A similar error appears when I run other programs that need to connect to dbus in the terminal.

This doesn't happen regularly; sometimes, when I boot up everything is ok. But the problem occurs around 50% of the time. It isn't an isolated incident, either; please refer to the following discussions in the Ubuntu Forums:

http://ubuntuforums.org/showthread.php?t=605974
http://ubuntuforums.org/showthread.php?t=587410

Some posts seem to confirm that the problems started after the installation of the RT kernel, and that the root cause is that nothing can connect to dbus. The problems reported don't have conclusive resolutions in the threads either.

I'm not sure what logs, etc. are needed, so please tell me what other information you need. Thanks.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in linux:
status: New → Incomplete
Michael Nagel (nailor) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers