Kernel 4.4.0-34 caused Redshift/Flux/brightness-controller etc. to stop working

Bug #1617686 reported by JI Xiang on 2016-08-28
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

As per reported by several users, such as in https://ubuntuforums.org/showthread.php?t=2333398, apps that control screen gamma, such as Redshift/Flux/brightness-controller, stopped working under the newest kernel 4.4.0-34 in Ubuntu 16.04 LTS, and we're not sure what caused the issue.

Those apps are still working well on external monitors. It's just the internal monitor that is not responsive. Any setting just simply has no effect.

It seems that all the users are using Skylake-based laptop.

In my case, my laptop is on Skylake and GTX980M.

Links for the individual apps mentioned above:
- Redshift http://jonls.dk/redshift/
- Flux https://justgetflux.com/linux.html
- brightness-controller https://apps.ubuntu.com/cat/applications/brightness-controller/

---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jx 4045 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=66785c85-3633-4f60-b15d-718b7b14873e
InstallationDate: Installed on 2016-04-25 (125 days ago)
InstallationMedia: It
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 046d:c07e Logitech, Inc.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Hasee Computer CP65R
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-34-generic root=UUID=d940d1fe-4c2c-4de3-b82d-108083812e0e ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.4.0-34.53-generic 4.4.15
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-34-generic N/A
 linux-backports-modules-4.4.0-34-generic N/A
 linux-firmware 1.157.3
Tags: xenial
Uname: Linux 4.4.0-34-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/18/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.05.05
dmi.board.asset.tag: Tag 12345
dmi.board.name: P65_P67RGRERA
dmi.board.vendor: Notebook
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Notebook
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.05.05:bd09/18/2015:svnHaseeComputer:pnCP65R:pvrNotApplicable:rvnNotebook:rnP65_P67RGRERA:rvrNotApplicable:cvnNotebook:ct10:cvrN/A:
dmi.product.name: CP65R
dmi.product.version: Not Applicable
dmi.sys.vendor: Hasee Computer

JI Xiang (szjx) on 2016-08-28
description: updated
Colin Watson (cjwatson) on 2016-08-28
affects: launchpad → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1617686

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
JI Xiang (szjx) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected xenial
description: updated
JI Xiang (szjx) wrote : CRDA.txt

apport information

apport information

JI Xiang (szjx) wrote : IwConfig.txt

apport information

apport information

JI Xiang (szjx) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

JI Xiang (szjx) wrote : RfKill.txt

apport information

JI Xiang (szjx) wrote : UdevDb.txt

apport information

apport information

description: updated
JI Xiang (szjx) wrote : AlsaInfo.txt

apport information

JI Xiang (szjx) wrote : CRDA.txt

apport information

apport information

JI Xiang (szjx) wrote : IwConfig.txt

apport information

apport information

JI Xiang (szjx) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

JI Xiang (szjx) wrote : RfKill.txt

apport information

JI Xiang (szjx) wrote : UdevDb.txt

apport information

apport information

description: updated
JI Xiang (szjx) wrote : AlsaInfo.txt

apport information

JI Xiang (szjx) wrote : CRDA.txt

apport information

apport information

JI Xiang (szjx) wrote : IwConfig.txt

apport information

apport information

JI Xiang (szjx) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

JI Xiang (szjx) wrote : RfKill.txt

apport information

JI Xiang (szjx) wrote : UdevDb.txt

apport information

apport information

JI Xiang (szjx) wrote :

Sorry, please ignore the first two sets of logs I attached. I was running kernel 4.0.0-28 to circumvent this bug. The last set of logs is collected on kernel 4.0.0-34

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
JI Xiang (szjx) wrote :

The last two sets of logs are both from 4.0.0-34 actually.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream stable kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.4 stable kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.19

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: kernel-da-key needs-bisect
JI Xiang (szjx) wrote :

I tested on kernel 4.4.19-040419 and the bug seems to be gone.

tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

The proposed Xenial kernel now has the 4.4.19 updates and is in the -proposed repository. Would it be possible for you to test this latest kernel and post back if it resolves this bug?

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed.

tags: added: kernel-fixed-upstream-4.4.19 needs-reverse-bisect regression-update
removed: 16.04 4.4.0-34 display kernel needs-bisect
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
description: updated
Jesse Johnson (holocronweaver) wrote :

I just tested kernel 4.4.0-37-generic from xenial-proposed and flux is still unable to change the display settings.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Jesse Johnson, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
JI Xiang (szjx) wrote :

Actually, kernel 4.4.0-41-generic from xenial-proposed works for me if I'm using the NVIDIA graphics card, but doesn't work on Intel integrated graphics card.

4.4.19 works on both.

Actually, this doesn't seem to be an error in the kernel itself.

It affects 16.04 and 14.04.5 with kernel 4.4.0-45 and is related to the propritary Nvidia driver later than 361.42.

Solution: go back to 361.42 which let's flux change the color immedieately after restarting lightdm.

See: https://github.com/xflux-gui/xflux-gui/issues/27

Can be closed here, or?

JI Xiang (szjx) wrote :

Well no. I reported that it doesn't work on both Nvidia card and the integrated Intel card. While on another kernel it works on both Nvidia and Intel cards. I currently have Nvidia 364 driver and I have redshift working totally fine. So I don't believe it's induced by NVIDIA driver. Maybe you're having another bug?

JI Xiang (szjx) wrote :

@thorsten-munsch Maybe you should actually file another bug report instead.

Anthony Wong (anthonywong) wrote :

I tested and found 4.4.0-34 has this issue, but from 4.4.0-36 and up, the issue no longer exist. Ji Xiang, can you confirm this?

tags: removed: kernel-da-key
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.