Can't boot from new kernel 4.4.0-34. Old kernel 4.4.0-31 is fine.

Bug #1611831 reported by Ryan Budney on 2016-08-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Joseph Salisbury

Bug Description

Greetings,

I recently upgraded from the 4.4.0-31 to 4.4.0-34 kernel in Ubuntu 16.04. If I try booting from 4.4.0-34, my system freezes just after I enter my password to decrypt my hard-drive. If I ask it to boot from 4.4.0-31, everything is fine.

My boot.log file:

  lvmetad is not active yet, using direct activation during sysinit
  Volume group "ubuntu-vg" not found
  Cannot process volume group ubuntu-vg
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
  Reading all physical volumes. This may take a while...
  Found volume group "ubuntu-vg" using metadata type lvm2
  /run/lvm/lvmetad.socket: connect failed: No such file or directory
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
  2 logical volume(s) in volume group "ubuntu-vg" now active
/dev/mapper/ubuntu--vg-root: recovering journal
/dev/mapper/ubuntu--vg-root: clean, 525872/28426240 files, 91143613/113674240 blocks

It's unclear to me what is going wrong. There appears to be no activity on the computer. I let the boot sequence sit for 10 minutes (way longer than an average boot time) my laptop's fan is running full-tilt. But there was no hard-drive activity.

How can I find out what's going wrong?

I'm running Ubuntu 16.04 Linux on a Lenovo W530. I'm not certain what other information would be helpful for a bug report. I would be happy to submit whatever is deemed helpful.
---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: rybu 4449 F.... pulseaudio
 /dev/snd/controlC0: rybu 4449 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=48cdbc4a-e07f-4aa4-bb23-e2904e1cd350
InstallationDate: Installed on 2016-04-26 (106 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: LENOVO 2436CTO
Package: linux (not installed)
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-31-generic root=/dev/mapper/ubuntu--vg-root ro quiet splash
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-31-generic N/A
 linux-backports-modules-4.4.0-31-generic N/A
 linux-firmware 1.157.2
Tags: xenial
Uname: Linux 4.4.0-31-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/18/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: G5ETA3WW (2.63 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2436CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG5ETA3WW(2.63):bd09/18/2015:svnLENOVO:pn2436CTO:pvrThinkPadW530:rvnLENOVO:rn2436CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2436CTO
dmi.product.version: ThinkPad W530
dmi.sys.vendor: LENOVO

Paul White (paulw2u) on 2016-08-10
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1611831

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected xenial
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream stable kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.4 stable kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.16

Changed in linux (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
tags: added: performing-bisect-done
Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in linux (Ubuntu Xenial):
importance: Undecided → High
status: New → In Progress
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Xenial):
assignee: nobody → Joseph Salisbury (jsalisbury)
tags: added: performing-bisect
removed: performing-bisect-done
Ryan Budney (delooper) wrote :

I just booted to:

uname -a
Linux rybu-ThinkPad-W530 4.4.16-040416-generic #201607271333 SMP Wed Jul 27 17:35:45 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

So I think this means the problem is not in 4.4.16.

So I will add the kernel-fixed-upstream tag, and confirmed.

Changed in linux (Ubuntu):
status: In Progress → Confirmed
Changed in linux (Ubuntu Xenial):
status: In Progress → Confirmed
tags: added: kernel-fixed-upstream
Joseph Salisbury (jsalisbury) wrote :

That indicates the bug is either already fixed in upstream 4.4.16 or it's an Ubuntu specific bug.

To confirm it's now fixed upstream, can you test 4.4.15. It should contain the bug, since Ubuntu 4.4.0-34 had those stable updates and not the 4.4.16 stable updates.

The 4.4.15 kernel can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.15/

Another testing option would be to test the Xenial -proposed kernel. Xenial -proposed now does have the v4.4.16 stable updates.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed.

Thank you in advance!

tags: added: bios-outdated-2.65 kernel-fixed-upstream-4.4.15 needs-reverse-bisect regression-update
removed: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Ryan Budney (delooper) wrote :

The bug is only semi-fixed upstream. With kernels 4.4.0-36 and 38 there is still a bug but it is different than what I originally reported. With these two kernels, I can boot up the system and even log in, but once I log in my home directory appears to be empty. I imagine this is because it remains encrypted.

I will update the status accordingly.

tags: removed: kernel-fixed-upstream-4.4.15
Ryan Budney (delooper) wrote :

The bios-outdated-2.65 tag, what does this mean? I tried clicking on it but there's no description as far as I can tell.

Ryan Budney (delooper) wrote :

Regarding post number 18, I spoke too soon about kernel:

Linux rybu-ThinkPad-W530 4.4.16-040416-generic #201607271333 SMP Wed Jul 27 17:35:45 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

That kernel boots and I can log into Ubuntu with it, even into my account. But all the files in my home directory are gone. I suspect this is due to the directory being encrypted.

Ryan Budney, to keep this relevant to upstream, one would want check for, and test the latest mainline kernel (now 4.8.1) as it is released.

Could you please advise?

Ryan Budney (delooper) wrote :

I have kernel 4.4.16-040416-generic running and the problem is still there. It appears that encryptfs is partially broken and this is a known bug. I can change into directories and open files. The only problem now is that when I use a command like ls, I get responses such as:

ls: cannot open directory '.': Wrong medium type

I will try loading 4.8.1 now.

Ryan Budney (delooper) wrote :

kernel 4.4.0-43-generic is working fine. Installed it today. Encryptfs seems to be back to being fully operational.

So, I haven't tried 4.8.1 but it appears the bug was fixed before then.

Ryan Budney (delooper) wrote :

Should I convert to "fix released" ? There is no "resolved" tag.

Ryan Budney, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1611831/comments/25 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

no longer affects: linux (Ubuntu Xenial)
Changed in linux (Ubuntu):
status: Incomplete → Invalid
Dan Moore (lilrubberduky) wrote :

While I'm not using encryption, I am using LVM and am experincing this same problem on 4.4.0-59 and 4.8.0, upgrading from 3.19.0-79 which was previously working.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Dan Moore (lilrubberduky) wrote :

I was able to install 4.4.0-43-generic and extras, and it works. Will test on 4.4.0-59 and 4.8.0 and report back.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers