embed derivative kernel target names in repo git tags

Bug #1599924 reported by Kamal Mostafa on 2016-07-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Kamal Mostafa
Precise
Undecided
Unassigned
Wily
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

To avoid git repo tag namespace collisions, the derivative kernel target names should be embedded in their git 'release' tags, e.g. in the Ubuntu Xenial git repo:

tag Ubuntu-raspi2-4.4.0-1017.23 instead of Ubuntu-4.4.0-1017.23
tag Ubuntu-snapdragon-4.4.0-1020.23 instead of Ubuntu-4.4.0-1020.23

This new tag naming scheme should be applied to the main kernel branch and the -meta branch for each derivative.

Derivatives to be changed:

xenial/raspi2
xenial/snapdragon
wily/raspi2
precise/ti-omap4

Changed in linux (Ubuntu):
status: New → In Progress
description: updated
Kamal Mostafa (kamalmostafa) wrote :

No further updates are planned for Wily's kernel.

Changed in linux (Ubuntu Wily):
status: New → Won't Fix
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
Changed in linux (Ubuntu Xenial):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Kamal Mostafa (kamalmostafa) wrote :

debian/gbp.conf changes and tags pushed for:

xenial/raspi2
xenial/snapdragon
precise/ti-omap4

Tim Gardner (timg-tpi) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
tags: added: verification-done-xenial
removed: verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers