linux-headers-3.2.0-105 not in precise-security

Bug #1597517 reported by vdloo on 2016-06-29
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I noticed that linux-headers-3.2.0-105 is not in precise-security.

> Package not available
http://packages.ubuntu.com/precise/devel/linux-headers-3.2.0-105-generic

Looks like it was published but then removed again: https://launchpad.net/ubuntu/precise/amd64/linux-headers-3.2.0-105-generic

Are the headers not always in the security repo if the image is? http://packages.ubuntu.com/precise/linux-image-3.2.0-105-generic

For previous generic kernels like 3.2.0-102 and 3.2.0-104 the headers are in precise-security as well instead of only in precise-update.

See http://packages.ubuntu.com/precise/linux-headers-3.2.0-102-generic and http://packages.ubuntu.com/precise/linux-headers-3.2.0-104-generic

I ran into this trying to install the virtualbox guest additions into a precise64 Vagrant with a 3.2.0-105 kernel. The guest plugin tries to install the latest headers like 'linux-headers-`uname -r`'

see https://github.com/dotless-de/vagrant-vbguest/blob/d36ba2e4ae00577b4169bf1336a6a3264277c1e7/lib/vagrant-vbguest/installers/debian.rb#L31

this fails because the box I am using has precise-security in the sources.list but not precise-update.

I submitted a question about this and was suggested to create a bugreport: https://answers.launchpad.net/ubuntu/+source/linux/+question/295780

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1597517

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
vdloo (rickvandeloo) on 2016-06-29
Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2016-06-29
Changed in linux (Ubuntu):
status: New → Incomplete
Acid (guillaume-onlineacid) wrote :

Hi,

- I confirm the above issue in our production servers which are configured to update their packages only from a local mirror of the security pocket with unattended-upgrades. They cannot upgrade the linux kernel to version 3.2.0-105 because the linux-headers-3.2.0-105 package is missing in the security pocket.

- Usually, the kernel upgrades work well with our local mirror of the security pocket with unattended-upgrades.

- Aptitude also report this error :

[root@######## ~]# aptitude dist-upgrade
The following NEW packages will be installed:
  linux-headers-3.2.0-105-generic{ab} linux-image-3.2.0-105-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic
3 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 39.8 MB of archives. After unpacking 162 MB will be used.
The following packages have unmet dependencies:
 linux-headers-3.2.0-105-generic : Depends: linux-headers-3.2.0-105 which is a virtual package.
The following actions will resolve these dependencies:

     Remove the following packages:
1) linux-generic
2) linux-headers-generic

     Keep the following packages at their current version:
3) linux-headers-3.2.0-105-generic [Not Installed]

Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

- Finally, we also cannot install any new server (preseed) because of this missing dependancy.

Jason Gladish (jason-k4c) wrote :
Download full text (10.0 KiB)

Here's the log from running `sudo unattended-upgrade --dry-run --debug` in case it's helpful:

2016-07-07 16:58:53,281 INFO Initial blacklisted packages:
2016-07-07 16:58:53,282 INFO Starting unattended upgrades script
2016-07-07 16:58:53,282 INFO Allowed origins are: ['o=Ubuntu,a=precise-security']
2016-07-07 16:58:53,745 DEBUG adjusting candidate version: '<Version: package:'apt' version:'0.8.16~exp12ubuntu10.21'>'
2016-07-07 16:58:53,761 DEBUG adjusting candidate version: '<Version: package:'apt-transport-https' version:'0.8.16~exp12ubuntu10.21'>'
2016-07-07 16:58:53,771 DEBUG adjusting candidate version: '<Version: package:'apt-utils' version:'0.8.16~exp12ubuntu10.21'>'
2016-07-07 16:58:53,821 DEBUG adjusting candidate version: '<Version: package:'dpkg' version:'1.16.1.2ubuntu7.7'>'
2016-07-07 16:58:53,843 DEBUG adjusting candidate version: '<Version: package:'dpkg-dev' version:'1.16.1.2ubuntu7.7'>'
2016-07-07 16:58:53,958 DEBUG adjusting candidate version: '<Version: package:'libapt-inst1.4' version:'0.8.16~exp12ubuntu10.21'>'
2016-07-07 16:58:53,970 DEBUG adjusting candidate version: '<Version: package:'libapt-pkg4.12' version:'0.8.16~exp12ubuntu10.21'>'
2016-07-07 16:58:54,013 DEBUG adjusting candidate version: '<Version: package:'libdpkg-perl' version:'1.16.1.2ubuntu7.7'>'
2016-07-07 16:58:54,277 DEBUG adjusting candidate version: '<Version: package:'ntp' version:'1:4.2.6.p3+dfsg-1ubuntu3.6'>'
2016-07-07 16:58:54,291 DEBUG adjusting candidate version: '<Version: package:'ntpdate' version:'1:4.2.6.p3+dfsg-1ubuntu3.6'>'
2016-07-07 16:58:54,340 DEBUG adjusting candidate version: '<Version: package:'puppet' version:'2.7.11-1ubuntu2.7'>'
2016-07-07 16:58:54,362 DEBUG adjusting candidate version: '<Version: package:'puppet-common' version:'2.7.11-1ubuntu2.7'>'
2016-07-07 16:58:54,449 DEBUG adjusting candidate version: '<Version: package:'unattended-upgrades' version:'0.76ubuntu1.1'>'
2016-07-07 16:58:55,110 DEBUG Checking: cloud-init (["<Origin component:'main' archive:'precise-updates' origin:'Ubuntu' label:'Ubuntu' site:'us-east-1.ec2.archive.ubuntu.com' isTrusted:True>"])
2016-07-07 16:58:55,138 DEBUG Checking: facter (["<Origin component:'main' archive:'precise' origin:'Puppetlabs' label:'Puppetlabs' site:'apt.puppetlabs.com' isTrusted:True>"])
2016-07-07 16:58:55,178 DEBUG Checking: grub-legacy-ec2 (["<Origin component:'main' archive:'precise-updates' origin:'Ubuntu' label:'Ubuntu' site:'us-east-1.ec2.archive.ubuntu.com' isTrusted:True>"])
2016-07-07 16:58:55,193 DEBUG Checking: instrumental-tools (["<Origin component:'main' archive:'precise' origin:'https://packagecloud.io/expectedbehavior/instrumental' label:'instrumental' site:'packagecloud.io' isTrusted:True>"])
2016-07-07 16:58:55,401 DEBUG Checking: libruby2.0 (["<Origin component:'main' archive:'precise' origin:'LP-PPA-brightbox-ruby-ng' label:'Brightbox Ruby NG' site:'ppa.launchpad.net' isTrusted:True>"])
2016-07-07 16:58:55,487 DEBUG Checking: linux-headers-virtual (["<Origin component:'main' archive:'precise-updates' origin:'Ubuntu' label:'Ubuntu' site:'us-east-1.ec2.archive.ubuntu.com' isTrusted:True>", "<Origin component:'main' archive:'precise-security' origin:'Ubuntu' lab...

Alex King (ahex) wrote :

This is affecting me as well, on a few servers.

# cat /etc/apt/sources.list
#deb http://aptproxy.sitehost.co.nz/ubuntu precise main multiverse universe
deb http://nz.archive.ubuntu.com/ubuntu precise main multiverse universe restricted
deb http://archive.ubuntu.com/ubuntu precise main multiverse universe restricted
deb http://archive.ubuntu.com/ubuntu precise-security main multiverse universe restricted

# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  linux-headers-server linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

# apt-get install linux-headers-3.2.0-105-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-headers-3.2.0-105-generic : Depends: linux-headers-3.2.0-105 but it is not installable
E: Unable to correct problems, you have held broken packages.

# dpkg --get-selections|grep -v install$
#

# apt-get install linux-headers-3.2.0-105
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package linux-headers-3.2.0-105 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'linux-headers-3.2.0-105' has no installation candidate

c_t (chefturner) wrote :

This affects me as well when trying to install a new preseeded server. Are there any plans to bring linux-headers-3.2.0-105 back into the security pocket?

c_t (chefturner) wrote :

I was able to work around this issue in the preseed.cfg for now by directly selecting a HWE kernel:

-d-i base-installer/kernel/override-image string linux-server
+d-i base-installer/kernel/override-image string linux-generic-lts-trusty

While this might not be what everyone wants it is a viable workaround for me at the moment.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions