duplicate touchpad reported and syndaemon/synclient does not work

Bug #1591669 reported by sanette on 2016-06-12
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

This is on a Dell XPS 13 9350 DE running ubuntu 16.04.
This laptop has a touchpad and a touchscreen.
I'm reporting here about the touchpad.

One can see from Xorg.0.log and "xinput list" that *two* touchpads are registered by the system

one is called "DLL0704:01 06CB:76AE Touchpad"
and the other "SynPS/2 Synaptics TouchPad"

As a result, syndaemon is not working.
To check this, open two terminals, press and hold some key, like "e" in one of them. It starts filling with "eeeeeee". Now while holding the key, use the touchpad to tap on the other terminal. Then "eeee" fills the new terminal.
Expected behaviour:
tapping on the other terminal should have no effet, the "e"'s should continue to fill the first terminal.

Moreover, configuring the touchpad with synclient is not working either.

FIX:

Since invoking
xinput disable "SynPS/2 Synaptics TouchPad"
has no effect, it is clear that this one is a "false" touchpad.

Hence this fix is:
Add an "ignore" section in /usr/share/X11/xorg.conf.d/50-synaptics.conf

I added, line 29:

Section "InputClass"
        Identifier "touchpad ignore SynPS/2 Synaptics duplicate"
        MatchProduct "SynPS/2 Synaptics TouchPad"
        Option "Ignore" "on"
EndSection

Now it works. The touchpad is correctly disabled when using the keyboard, and moreover I can configure it using synclient, or adding a file to /etc/X11/xorg.conf.d/

Of course this fix is not universal because I had to use the precise name of the "false touchpad" as reported by xinput.

---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: san 1697 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=0dbbd1c1-bb58-45af-8c68-716d7ae636e7
InstallationDate: Installed on 2016-06-03 (9 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 0c45:670c Microdia
 Bus 001 Device 003: ID 04f3:20d0 Elan Microelectronics Corp.
 Bus 001 Device 002: ID 8087:0a2b Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 13 9350
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-24-generic.efi.signed root=UUID=75dd5fb6-2ff1-4f2b-859d-4c3942a5c45b ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-24-generic N/A
 linux-backports-modules-4.4.0-24-generic N/A
 linux-firmware 1.157
Tags: xenial
Uname: Linux 4.4.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 03/01/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.3.3
dmi.board.name: 09JHRY
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.3.3:bd03/01/2016:svnDellInc.:pnXPS139350:pvr:rvnDellInc.:rn09JHRY:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 13 9350
dmi.sys.vendor: Dell Inc.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1591669

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected xenial
description: updated
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

sanette (sanette-linux) wrote :

ABOUT THE LOGS:

I'm sorry I'm not used to reporting bugs.
After I received the email telling me to "apport-collect 1591669"
I did it, but then I realized I had already implemented the "fix"...
So I have removed the fix, rebooted, and re-run "apport-collect 1591669"

===> you may ignore #2 -- #14

sanette (sanette-linux) wrote :

I think this is a regression:

I've just tested a live USB Linux Mint 17.3 cinnamon (based on ubuntu 14.04)
and there the touchpad is not duplicated.

only "SynPS/2 Synaptics TouchPad"
is reported by the system

sanette (sanette-linux) on 2016-06-13
description: updated
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.7-rc1 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.7-rc3-yakkety/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
sanette (sanette-linux) wrote :

Hi Joe. I've just tested the latest kernel, but
the bug is not fixed in 4.7.0-040700rc3-generic

(same behaviour)

tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
sanette (sanette-linux) wrote :

another way to "fix" the bug is to suspend/resume.

Indeed, after resume, the false device is removed.

$ tail -n 3 /var/log/Xorg.0.log
(EE) SynPS/2 Synaptics TouchPad: Read error 19
[ 285.414] (II) config/udev: removing device SynPS/2 Synaptics TouchPad
[ 285.430] (II) UnloadModule: "synaptics"

(but then the touchscreen doesn't work anymore... but this is probably a different bug)

fish (discordianfish) wrote :

Have a XPS 13 9350 DE and looks like I'm affected by the same issue and also suspend/resume removes the device. Yet I have several issues and it doesn't seem to matter whether the 'fake' touchpad was removed by suspend/resume.

For me too the mouse isn't disabled when typing but this is only sometimes a problem. It seems there is some other heuristic going on which prevents accidentially moving the mouse (palm detection?). Other times though it's a problem and I haven't figured out what this depends on.

But my main problem is that the middle mouse emulation never worked for me, just never isolated this enough to fill an issue. Going to test some newer kernels too, maybe this is related to this issue here too.

Jan Drewes (jdewes) wrote :

I am experiencing the same(?) bug with Kubuntu 17.04, all updates as of May-13 2017. Suspending/Resuming does not help in my case.

Dell Precision 5510 9550

Interestingly, the problem started to show up only recently and intermittently. I can't for sure say since when exactly. I will try the above workaround by ignoring the spurious entry in xinput.

mbietenholz (mbieten) wrote :

I'm having the same bug (ie. can't seem to disable touchpad while typing) on a Dell 5520 Precision
with Ubuntu 16.04. I did have two touchpad entries, disabled one as above, but that doesn't solve the problem.

Dave Chiluk (chiluk) on 2017-07-13
tags: added: indeed
To post a comment you must log in.