Ubuntu 16.04 Two finger scrolling/multitouch not working

Bug #1587913 reported by JoMo on 2016-06-01
80
This bug affects 14 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I've done a fresh install of Ubuntu 16.04 on my Asus G501 but the two finger scrolling isn't working. The touchpad works but sometimes after restarting it doesn't get detected and so I have to shutdown in order to get it working again.

I'm running the latest bios for my model 206, and have updated to the mainline kernel 4.6.

My xinput list shows the following;

Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ FTE1001:00 0B05:0101 id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Sleep Button id=9 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam id=10 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

WORKAROUND: https://github.com/vlasenko/hid-asus-fte-dkms

---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: josh 1684 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=79b14c98-ef5a-4add-a8b0-8529f66d7165
InstallationDate: Installed on 2016-05-28 (5 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 04f2:b3fd Chicony Electronics Co., Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. G501VW
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-22-generic.efi.signed root=UUID=f4198650-b09e-454f-b7b7-1f07576eb8d2 ro quiet splash nouveau.modeset=0 acpi_osi=! acpi_backlight=native vt.handoff=7
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-22-generic N/A
 linux-backports-modules-4.4.0-22-generic N/A
 linux-firmware 1.157
Tags: xenial
Uname: Linux 4.4.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip input lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 03/16/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: G501VW.206
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: G501VW
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG501VW.206:bd03/16/2016:svnASUSTeKCOMPUTERINC.:pnG501VW:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG501VW:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: G501VW
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
---
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
BootLog: /dev/sda5: clean, 256126/1525920 files, 1438889/6103552 blocks
CurrentDesktop: Unity
DistUpgraded: Fresh install
DistroCodename: xenial
DistroRelease: Ubuntu 16.04
DistroVariant: ubuntu
InstallationDate: Installed on 2016-05-28 (5 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 04f2:b3fd Chicony Electronics Co., Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. G501VW
Package: xserver-xorg-input-synaptics 1.8.2-1ubuntu3 [modified: usr/share/X11/xorg.conf.d/50-synaptics.conf]
PackageArchitecture: amd64
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-22-generic.efi.signed root=UUID=f4198650-b09e-454f-b7b7-1f07576eb8d2 ro quiet splash nouveau.modeset=0 acpi_osi=! acpi_backlight=native vt.handoff=7
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Tags: xenial ubuntu
Uname: Linux 4.4.0-22-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip input lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 03/16/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: G501VW.206
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: G501VW
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG501VW.206:bd03/16/2016:svnASUSTeKCOMPUTERINC.:pnG501VW:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG501VW:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: G501VW
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1587913/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
JoMo (joshmo-169) on 2016-06-01
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1587913

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected xenial
description: updated
JoMo (joshmo-169) wrote : CRDA.txt

apport information

apport information

apport information

apport information

JoMo (joshmo-169) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

apport information

JoMo (joshmo-169) wrote : RfKill.txt

apport information

JoMo (joshmo-169) wrote : UdevDb.txt

apport information

apport information

affects: linux (Ubuntu) → xserver-xorg-input-synaptics (Ubuntu)
tags: added: ubuntu
description: updated

apport information

apport information

apport information

apport information

JoMo (joshmo-169) wrote : Lspci.txt

apport information

apport information

apport information

apport information

apport information

JoMo (joshmo-169) wrote : UdevDb.txt

apport information

apport information

apport information

JoMo (joshmo-169) wrote : xinput.txt

apport information

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Confirmed
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: Undecided → High
burabure (nccolas) wrote :

Similar issue on an Asus UX501VW, using ubuntu 16.04 kernel 4.6.3. Touchpad is detected as "FTE1001:00 0B05:0101" (FocalTech maybe?) basic pointing capabilities work, but its not detected as a touchpad, no synaptycs drivers loaded, no multitouch gestures, no palm rejection (which is driving me crazy). No further issues after suspend.

Should I open a new Issue?

Ali Tolga Özbaş (eroniss55) wrote :

Same issue on ASUS TP200SA

Joseph Valeros (valerosjoseph) wrote :

Same here. My laptop is ASUS K555U.

Yigal Shenkman (poochon) wrote :

Also happens on Ubuntu 16.04, ASUS X556U

Moritz (moritzteuber) wrote :

Not sure if this helps, but i've been struggling with these issues since 12.04 (see bugs #1166442 and #1272777).
There have fixes in 3.15.05 and later ones, but this issue occured again with kernels 4 and ongoing. Other than using these kernels, I have not found an approriate solution.

May this can help fix this.

I'm using a Gigabyte U2442n laptop with an older Elantech touchpad.

Dmytro (dv-karnaukh) wrote :

Same issue on an Asus UX501VW
ubuntu 16.04.1 kernel 4.7.2. Touchpad is detected as "FTE1001:00 0B05:0101"

JoMo, in order to allow additional upstream developers to examine the issue, at your earliest convenience, could you please test the latest upstream kernel available from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D ? Please keep in mind the following:
1) The one to test is at the very top line at the top of the page (not the daily folder).
2) The release names are irrelevant.
3) The folder time stamps aren't indicative of when the kernel actually was released upstream.
4) Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds .

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Also, you don't need to apport-collect further unless specifically requested to do so.

It is most helpful that after testing of the latest upstream kernel is complete, you mark this report Status Confirmed.

Lastly, to keep this issue relevant to upstream, please continue to test the latest mainline kernel as it becomes available.

Thank you for your help.

tags: added: bios-outdated-300
removed: asus clickpad multitouch
Changed in xserver-xorg-input-synaptics (Ubuntu):
importance: High → Low
status: Confirmed → Incomplete
JoMo (joshmo-169) on 2016-09-05
tags: added: bios-updated-300 kernel-bug-exists-upstream kernel-bug-exists-upstream-4.8-rc5
David DIDIER (ddidier) wrote :

I have the same touchpad on my Asus Zenbook UX501 and I can confirm that it isn't recognized as such by the latest kernels installed from http://kernel.ubuntu.com/~kernel-ppa/mainline/ : 4.4.19, 4.5.7, 4.6.7 nor 4.7.2. Moreover the function key to enable or disable the touchpad is not recognized at all (tested with xev).
See https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1620811

David DIDIER, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

JoMo (joshmo-169) wrote :

kernel-bug-exists-upstream kernel-bug-exists-upstream-4.8-rc7

JoMo (joshmo-169) wrote :

After all these months, this has fixed the issue...

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Incomplete
description: updated
affects: xserver-xorg-input-synaptics (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Low → High
status: Incomplete → Triaged
knerl ington (knerlington) wrote :

I have a very similar or the exact same issue, but with the touchpad used on Dell's XPS 9550.
In this case the touchpad being used as reported by "cat /proc/bus/input/devices" is: DLL06E4:01 06CB:7A13 Touchpad

It shows up if I run "xinput list" as well. However. I usually have a generic Synaptics touchpad entry there as well, but in order for palm detection to work I had to disable it by entering the following in "51-synaptics-quirks.conf" under /usr/share/X11/xorg.conf.d:

# Disable generic Synaptics device, as we're using
# "DLL0704:01 06CB:76AE Touchpad"
# Having multiple touchpad devices running confuses syndaemon
Section "InputClass"
        Identifier "SynPS/2 Synaptics TouchPad"
        MatchProduct "SynPS/2 Synaptics TouchPad"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/event*"
        Option "Ignore" "on"
EndSection

Right after login it works just like it should and in Windows the issue is not present so I know it's not hardware related. But after a random amount of time the "tap to click" function and scrolling stops working. The mouse pointer can still be used and the physical clicks work. It's really annoying not being able to scroll or tap to click using the touchpad. The options are enabled in the GUI settings.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers