Xorg freeze [drm] stuck on render ring - gpu hanging too fast, banning

Bug #1574266 reported by FM33 on 2016-04-24
124
This bug affects 25 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

dmesg output :

[ 8815.416923] [drm] stuck on render ring
[ 8815.417367] [drm] GPU HANG: ecode 6:0:0x05b2c6c5, in Compositor [21164], reason: Ring hung, action: reset
[ 8815.419462] drm/i915: Resetting chip after gpu hang
[ 8821.417592] [drm] stuck on render ring
[ 8821.418007] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Xorg [1058], reason: Ring hung, action: reset
[ 8821.420108] drm/i915: Resetting chip after gpu hang
[ 8827.430254] [drm] stuck on render ring
[ 8827.430672] [drm] GPU HANG: ecode 6:0:0xfeffffff, in compiz [3107], reason: Ring hung, action: reset
[ 8827.432786] drm/i915: Resetting chip after gpu hang
[ 8833.418862] [drm] stuck on render ring
[ 8833.419454] [drm] GPU HANG: ecode 6:0:0xfeffffff, in compiz [3107], reason: Ring hung, action: reset
[ 8833.421551] drm/i915: Resetting chip after gpu hang
[ 8839.419503] [drm] stuck on render ring
[ 8839.419971] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Compositor [21164], reason: Ring hung, action: reset
[ 8839.422060] drm/i915: Resetting chip after gpu hang
[ 8845.432118] [drm] stuck on render ring
[ 8845.432647] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Xorg [1058], reason: Ring hung, action: reset
[ 8845.434799] drm/i915: Resetting chip after gpu hang
[ 8851.432751] [drm] stuck on render ring
[ 8851.433142] [drm] GPU HANG: ecode 6:0:0xfeffffff, in compiz [6783], reason: Ring hung, action: reset
[ 8851.435224] drm/i915: Resetting chip after gpu hang
[ 8857.457381] [drm] stuck on render ring
[ 8857.457797] [drm] GPU HANG: ecode 6:0:0xfeffffff, in compiz [6783], reason: Ring hung, action: reset
[ 8857.459883] drm/i915: Resetting chip after gpu hang
[ 8863.458003] [drm] stuck on render ring
[ 8863.458555] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Xorg [1058], reason: Ring hung, action: reset
[ 8863.460640] drm/i915: Resetting chip after gpu hang
[ 8869.458654] [drm] stuck on render ring
[ 8869.459001] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Xorg [1058], reason: Ring hung, action: reset
[ 8869.459095] [drm:i915_set_reset_status [i915]] *ERROR* gpu hanging too fast, banning!
[ 8869.461116] drm/i915: Resetting chip after gpu hang
[ 8875.435238] [drm] stuck on render ring
[ 8875.435606] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Compositor [21164], reason: Ring hung, action: reset
[ 8875.437697] drm/i915: Resetting chip after gpu hang
[ 8881.447863] [drm] stuck on render ring
[ 8881.448251] [drm] GPU HANG: ecode 6:0:0xfeffffff, in Compositor [21164], reason: Ring hung, action: reset
[ 8881.450331] drm/i915: Resetting chip after gpu hang
[ 8887.436497] [drm] stuck on render ring
[ 8887.436876] [drm] GPU HANG: ecode 6:0:0xbb8ffff8, in compiz [6817], reason: Ring hung, action: reset
[ 8887.438961] drm/i915: Resetting chip after gpu hang
[ 8893.437078] [drm] stuck on render ring
[ 8893.437471] [drm] GPU HANG: ecode 6:0:0xfeffffff, in compiz [6817], reason: Ring hung, action: reset
[ 8893.439562] drm/i915: Resetting chip after gpu hang

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: xorg 1:7.7+13ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sun Apr 24 15:57:17 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:2002]
InstallationDate: Installed on 2016-04-23 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
ProcEnviron:
 LANGUAGE=fr_FR
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=45576678-3e92-4769-b6d3-3e3cafa54c2e ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/04/2012
dmi.bios.vendor: Intel Corp.
dmi.bios.version: BLH6710H.86A.0160.2012.1204.1156
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: DH67BL
dmi.board.vendor: Intel Corporation
dmi.board.version: AAG10189-209
dmi.chassis.type: 3
dmi.modalias: dmi:bvnIntelCorp.:bvrBLH6710H.86A.0160.2012.1204.1156:bd12/04/2012:svn:pn:pvr:rvnIntelCorporation:rnDH67BL:rvrAAG10189-209:cvn:ct3:cvr:
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Sun Apr 24 12:21:12 2016
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Logitech USB Keyboard KEYBOARD, id 8
 input Logitech USB Keyboard KEYBOARD, id 9
 input Logitech USB Laser Mouse MOUSE, id 10
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu2

FM33 (foxxm) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xorg (Ubuntu):
status: New → Confirmed
Fredrik Normann (smartypants) wrote :

[ 767.459738] [drm] stuck on render ring
[ 767.460216] [drm] GPU HANG: ecode 7:0:0x85fffdfc, in Xorg [1262], reason: Ring hung, action: reset
[ 767.460217] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 767.460218] [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
[ 767.460219] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 767.460219] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 767.460220] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 767.462307] drm/i915: Resetting chip after gpu hang
[ 775.484053] [drm] stuck on render ring
[ 775.484501] [drm] GPU HANG: ecode 7:0:0x85fffdfc, in Xorg [1262], reason: Ring hung, action: reset
[ 775.486600] drm/i915: Resetting chip after gpu hang

Fredrik Normann (smartypants) wrote :

I can trigger the bug by starting Liebre Office Calc

Glop (jul-bzh) wrote :

Same for me, the bug is triggered by Libreoffice 5.1

FM33 (foxxm) wrote :

This bug is much worst in 16.04 than it used to be 14.04 :
Happens very often and freezes the system completely 4 times of 5 instead of just hang display for 30 seconds.

Cyril Jaquier (cyril-jaquier) wrote :

I get this almost every time after resume. Sometimes I can switch to a VT and restart Xorg but sometimes only Magic SysRq work to reboot the laptop. I have never see this issue on this laptop before (14.04 worked just fine).

FM33 (foxxm) on 2016-05-01
summary: - Xorg freeze
+ Xorg freeze [drm] stuck on render ring - gpu hanging too fast, banning
Changed in xorg (Ubuntu):
importance: Undecided → High
Marcin Sochacki (wanted) wrote :

For me it is 100% reproducible with LibreOffice, especially when one quits LO uncleanly and then on the next run it opens a dialog asking about file recovery. Whatever I click in that dialog, LibreOffice will hang for a while and then the whole X session is restarted.

Marcin Sochacki (wanted) wrote :

New finding: installing xserver-xorg-video-intel actually solved the problem for me, LibreOffice is no longer causing Xorg to crash. Previously I think Xorg was working using modesetting driver instead of intel, though I might be wrong.

My HW: Integrated Graphics Chipset: Intel(R) HD Graphics 4600 on FUJITSU LIFEBOOK E754.

Glop (jul-bzh) wrote :

Installing xserver-xorg-video-intel also solved the problem for me.

HW: Intel Corporation Haswell-ULT Integrated Graphics Controller.

(thanks Marcin!)

Kris (kmbroga) wrote :

Can confirm: installing xserver-xorg-video-intel solves the problem even with nvidia 650m optimus (intel running via bumblebee)

tags: added: latest-bios-0160

FM33, thank you for reporting this and helping make Ubuntu better.

Could you please provide the missing information following https://wiki.ubuntu.com/X/Troubleshooting/Freeze ?

Changed in xorg (Ubuntu):
status: Confirmed → Incomplete
Gregory Burd (gregburd) wrote :

Looks like this just had a patch submitted and accepted to Freedesktop bug.
https://bugs.freedesktop.org/show_bug.cgi?format=multiple&id=96878

jap1968 (jap1968) wrote :

Same problem here. I rarely had this problem previously with Ubuntu 14.04, but since updated to Ubuntu 16.04 I am suffering this issue very often.

The problem mainly appears when trying to resume the laptop from suspend. Mine has already installed xserver-xorg-video-intel. The laptop has an intel HD Graphics 4400 video adapter, the one integrated within the Core i7-4510U CPU

$ lspci
...
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)

jap1968, it will help immensely if you filed a new report with Ubuntu by ensuring you have the package xdiagnose installed, and that you click the Yes button for attaching additional debugging information running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Karl Kastner (kastner-karl) wrote :

For me, this also sometimes happens after suspending. Then, characters are not anymore displayed and I have to restart the display manager with ctrl-backspace. This problem emerged over the last year, so probably a regression bug.

affects: xorg (Ubuntu) → linux (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.