alsa applications crash on playing with sound-usb (terratec phase 26)

Bug #157198 reported by sense on 2007-10-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
sticks702@yahoo.com
linux-source-2.6.22 (Ubuntu)
Undecided
sticks702@yahoo.com

Bug Description

Binary package hint: linux-image-2.6.22-14-rt

I have a Terratec Phase 26 USB soundcard, which worked fine under feisty and edgy. WIth the updated to Gutsy I experience a crash whenever an application tries to play sound with this soundcard.

One example:
1. I open gnome-sound-properties
2. select USB-Audio
3. click on test

Result: immediate Segmentation fault

I could reproduce this using the same sound card on a friend's notebook (an IBM modell, I have got a Samsung X-10). Tested it with this kernel 2.6.22-14-rt #1 SMP PREEMPT RT Mon Oct 15 01:05:51 GMT 2007 i686 GNU/Linux, as well als the non -rt one.

I am not fully sure if this is related, but dmesg outputs this:
..
[ 7390.506532] BUG: unable to handle kernel paging request at virtual address 99396086
[ 7390.506542] printing eip:
[ 7390.506545] f88b669c
[ 7390.506547] *pde = 00000000
[ 7390.506552] Oops: 0000 [#1]
[ 7390.506554] PREEMPT SMP
[ 7390.506559] Modules linked in: af_packet binfmt_misc ppdev ipv6 speedstep_centrino cpufreq_userspace cpufreq_stats cpufreq_powe
rsave cpufreq_ondemand freq_table cpufreq_conservative video sbs container button dock battery ac ext3 jbd mbcache sha256 cbc blkc
ipher aes_i586 dm_crypt dm_mod sbp2 parport_pc lp parport snd_intel8x0 snd_ac97_codec ac97_bus pcmcia snd_seq_dummy snd_usb_audio
snd_pcm_oss snd_seq_oss snd_mixer_oss nvidia(P) snd_pcm agpgart snd_usb_lib ipw2100 yenta_socket snd_seq_midi i2c_core ieee80211 r
src_nonstatic joydev ieee80211_crypt pcmcia_core snd_rawmidi videodev snd_seq_midi_event v4l2_common v4l1_compat snd_hwdep snd_seq
 snd_timer snd_seq_device iTCO_wdt snd serio_raw iTCO_vendor_support shpchp pci_hotplug soundcore snd_page_alloc psmouse evdev xfs
 usbhid hid sg sr_mod cdrom sd_mod ata_piix ata_generic ohci1394 ehci_hcd 3c59x uhci_hcd libata ieee1394 mii usbcore scsi_mod ther
mal processor fan fuse apparmor commoncap
[ 7390.506653] CPU: 0
[ 7390.506654] EIP: 0060:[<f88b669c>] Tainted: P VLI
[ 7390.506657] EFLAGS: 00010282 (2.6.22-14-rt #1)
[ 7390.506692] EIP is at hcd_buffer_free+0x1c/0xa0 [usbcore]
[ 7390.506696] eax: 99396086 ebx: 00000040 ecx: 1f805180 edx: 00000040
[ 7390.506701] esi: df805180 edi: 99396086 ebp: f6c7f2c0 esp: f56fdea4
[ 7390.506705] ds: 007b es: 007b fs: 00d8 gs: 0033 ss: 0068 preempt:00000001
[ 7390.506711] Process mixer_applet2 (pid: 6065, ti=f56fc000 task=f58341b0 task.ti=f56fc000)
[ 7390.506714] Stack: 1f805180 f716ea00 00000000 f8acecfc 1f805180 f6c7f300 f6c7f30c f8aced98
[ 7390.506724] f70b34ac f70b3400 00001fff f6c7b800 f8a96548 f6c7cb40 f6c7b940 f89c7b05
[ 7390.506734] 00000001 00001000 f89c7b9f f6c7b800 f5753480 f6c7b800 f6c7b9bc f89c36f0
[ 7390.506744] Call Trace:
[ 7390.506769] [<f8acecfc>] snd_usbmidi_out_endpoint_delete+0x2c/0x50 [snd_usb_lib]
[ 7390.506791] [<f8aced98>] snd_usbmidi_free+0x28/0x60 [snd_usb_lib]
[ 7390.506814] [<f8a96548>] snd_rawmidi_free+0x68/0x80 [snd_rawmidi]
[ 7390.506832] [<f89c7b05>] snd_device_free+0x65/0xb0 [snd]
[ 7390.506862] [<f89c7b9f>] snd_device_free_all+0x4f/0x60 [snd]
[ 7390.506891] [<f89c36f0>] snd_card_do_free+0x30/0x100 [snd]
[ 7390.506913] [<f89c38ad>] snd_card_file_remove+0xed/0x120 [snd]
[ 7390.506945] [<f89c75ff>] snd_ctl_release+0xef/0x100 [snd]
[ 7390.506978] [<f89c3e51>] snd_disconnect_release+0x71/0xa0 [snd]
[ 7390.507010] [<c01862a4>] __fput+0x94/0x180
[ 7390.507036] [<c0183337>] filp_close+0x47/0x80
[ 7390.507053] [<c0184789>] sys_close+0x69/0xc0
[ 7390.507068] [<c0104362>] sysenter_past_esp+0x6b/0xa9
[ 7390.507114] =======================
[ 7390.507116] Code: bb 5c a4 c7 eb c8 90 90 90 90 90 90 90 90 90 83 ec 0c 89 74 24 04 89 ce 8b 4c 24 10 85 f6 89 1c 24 89 d3 89 7c 24 08 89 c7 74 5e <8b> 00 31 d2 8b 80 c4 01 00 00 85 c0 74 5f 8d b6 00 00 00 00 3b
[ 7390.507161] EIP: [<f88b669c>] hcd_buffer_free+0x1c/0xa0 [usbcore] SS:ESP 0068:f56fdea4
..

The Hardy Heron kernel was recently uploaded for testing. We'd really appreciate it if you could try testing with this newer kernel and verify if this issue still exists. Unfortunately, the Hardy Heron Alpha1 LiveCD was released with the older 2.6.22 kernel. You'll have to manually install the newer Hardy Heron kernel in order to test. This should not be the case for Alpha2 which is set to come out around Dec 20. However, here are the instructions to install if you choose to do so, otherwise just wait for Alpha2 to come out:

1) edit the file /etc/apt/sources.list and add the following line:

deb http://archive.ubuntu.com/ubuntu hardy main restricted

2) sudo apt-get update
3) sudo apt-get install linux-image-2.6.24-1-generic
4) reboot and select the new kernel from the grub menu

After you've tested, please feel free to revert back - ie boot into the old kernel, sudo apt-get remove linux-image-2.6.24-1-generic, and remove the line from /etc/apt/sources.list . Please update this report with your results. Thanks in advance!

Changed in linux:
status: New → Incomplete

I'm opened a new task against the actively developed kernel. However, I'm closing the report against linux-source-2.6.22 as it does not meet the criteria for a stable release update. You can learn more about the stable release update process at https://wiki.ubuntu.com/StableReleaseUpdates . Thanks!

Changed in linux-source-2.6.22:
status: New → Won't Fix
sense (robert-deejayshome) wrote :

I tested linux-image-2.6.24-1-generic according to your description and experienced the same behaviour:

 1. I open gnome-sound-properties
2. select USB-Audio
3. click on test

Result: immediate Segmentation fault

on the same hardware (Samsung X-10 and Terratec Phase 26 USB)

/var/log/syslog and dmesg are less verbose, the only relevant line seems to be this:

"kernel: [ 416.186565] gnome-sound-pro[6309]: segfault at b5418000 eip b6e40c5c esp b53deee0 error 7"

Thanks for testing and the update. Per the kernel team's bug policy, can you please attach the following information for the newer kernel:

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

sense (robert-deejayshome) wrote :

Sorry it took that long. I have tested with 2.6.24-5 and experienced the same behaviour

sense (robert-deejayshome) wrote :
sense (robert-deejayshome) wrote :
sense (robert-deejayshome) wrote :
sense (robert-deejayshome) wrote :

I did some search on the internet and here (http://<email address hidden>/msg20842.html) I found someone with the same problem. As for him, setting the card's mode to 16bit/48kHz with six channels resolved the problem, so I guess the problem is converting the between 16 and 26 bit mode. Note: On feisty and edgy the 24/48 mode worked.

Hi Sense,

Did the workaround also work for you? Also, the latest dmesg output you attached for the newer kernel doesn't seem to capture the kernel oops. Care to reattach? Thanks.

neocoretech (neocoretech) wrote :

In my case it worked fine switching the card to 16/48 mode...

i just had to change the default device with asoundconf from 2448USB to 1648USB...
Still it's worth fixing this bug, as many people on the net think, this card is unsupported in Ubuntu...

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
cepheus52 (cepheus52) wrote :

I have indentieke problems with my external USB ale SIS IO|2 sound card. Is there a solution?
<email address hidden>

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

cepheus52 schrieb:
> I have indentieke problems with my external USB ale SIS IO|2 sound
> card. Is there a solution?
>
Hi! I could workaround the problem by setting my sound card in 16bit
mode, the alsa bugs only appeared in 24bit mode. My card has a button
on the outside for this setting, but yours has none, right? (I checked
some pictures of it on the web.) Maybe there is a way to change this
setting per hardware, maybe you have to do some alsa settings, or
using JACK helps (it can do the conversion internally).

I hope this helps you towards finding a solution...

Ciao, Robert
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFIlG5UYtcqd8/QtA4RAvc6AJ9RCr+KljiXOMuKfNV8z8EGd6cQKwCeMGSF
NpCOHITVcYOZzgsvR7SV6KY=
=4rtn
-----END PGP SIGNATURE-----

cepheus (cepheus) wrote :

Thanks for helping! Robert! It's difficulty to explain what happens because I cant find a pattern. There are no hardware-possibilities to change settings on my ext usb ALESIS io|2. I open gnome-sound-properties, select USB-Audio, click on test and it works. I hear the testtone. I switch in the terminal to Rhythmbox, click on play: immediate Segmentation fault!
Again in soundproperties (usb audio selected) I click on test and the testtone is there. While the test is running, that means while I hear the testtone using my ext usb (!!!) I start in the terminal Rhythmbox. Everyting works fine!!! I hear the music AND the testtone but the terminal shows a message: (rhythmbox:7245): GStreamer-CRITICAL **:
Trying to dispose element test, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.
 That's the only circumstance Rhythmbox AND usb is working. So, why change to an other bit-rate (if possible)?

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Amit Kucheria (amitk) wrote :

This bug was reported a while ago but there hasn't been any recent comments or updates. Is this still an issue with the latest pre-release of Jaunty 9.04? Refer to http://www.ubuntu.com/testing/jaunty/beta . Please let us know.

Changed in linux (Ubuntu):
status: Triaged → Incomplete

Hi!

I'll do as soon as I come around to test the beta release. Please
understand that as I am a user, not a developer, so this is not my
number 1 priority..

sense (robert-deejayshome) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I just tested it with a jaunty live cd from 24/04/09. In all three
modes I tested, namely 24/96 in, 24/48 and 16/48:

- - I open gnome-sound-properties
- - the card is detected correctly as TerraTec Phase 26 (<mode>) (with
gnome-sound-properties as well as with alsamixer -c 1), I select it
- - I click on "Test"
- - an error-window appears "'audiotestsrc wave=sine freq=512 ! audi
[..] Could not open device"

My laptop is still a Samsung X-10 model. The live cd did not include
mplayer, so I did not know how to test whether this is gstreamer or
alsa related. I'd be happy to run some further tests on the live cd,
if needed.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJ+uf/pV1S7wsdZyYRAleOAKCWsqjPqA/cAY4VNadFKq+BP8gjDwCcCLeA
IO1mRdpfGg5ZKZoeQ0m6QtM=
=gCoX
-----END PGP SIGNATURE-----

Amit Kucheria (amitk) on 2009-05-03
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
sense (robert-deejayshome) wrote :
Download full text (6.9 KiB)

here some additional information:

 - if I select "TerraTec Phase 26 .. (OSS)" in gnome-sound-properties, I can hear the test tone.
- selecting "TerraTec Phase 26 .. (ALSA)" yields this message:

 sound-properties-Message: Error running pipeline 'audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink': Could not open audio device for playback. [gstalsasink.c(694): gst_alsasink_open (): /GstBin:bin0/GstHalAudioSink:halaudiosink0/GstBin:bin1/GstAlsaSink:alsasink0:
Playback open error on device 'default:1': Invalid argument]

- the complete output when pressing "F3" in alsamixer:

/proc/asound/version: # │
│ │==================== # │
│ │Advanced Linux Sound Architecture Driver Version 1.0.18rc3. # │
│ │ # │
│ │/proc/asound/cards: # │
│ │=================== # │
│ │ 0 [I82801DBICH4 ]: ICH4 - Intel 82801DB-ICH4 # │
│ │ Intel 82801DB-ICH4 with CS4202 at irq 11 # │
│ │ 1 [USB1648 ]: USB-Audio - PHASE 26 USB(16/48) # │
│ │ TerraTec PHASE 26 USB(16/48) at usb-0000:00:1d.0-2, full speed# │
│ │ ▒ │
│ │/proc/asound/devices: ▒ │
│ │===================== ▒ │
│ │ 2: : timer ▒ │
│ │ 3: : sequencer ▒ │
│ │ 4: [ 1- 0]: digital audio playback ▒ │
│ │ 5: [ 1- 0]: digital audio capture ▒ │
│ │ 6: [ 1] : control ▒ │
│ │ 7: [ 1- 0]: raw midi ▒ │
│ │ 8: [ 0- 4]: digital audio playback ▒ │
│ │ 9: [ 0- 3]: digital audio capture ▒ │
│ │ 10: [ 0- 2]: digital audio capture ▒ │
│ │ 11: [ 0- 1]: digital audio capture ▒ │
│ │ 12: [ 0- 0]: digital audio playback ▒ │
│ │ 13: [ 0- 0]: digital ...

Read more...

sense (robert-deejayshome) wrote :

and two more things:

 - if I select "TerraTec Phase 26 .. (OSS)" in gnome-sound-properties, even though I can hear the test tone, playing the example file in totem does neither result in some output, nor in an error

- the same (no error, no output) when trying to access the device with
    aplay -d "USB1648" /usr/share/sounds/question.wav

Changed in linux-source-2.6.22 (Ubuntu):
assignee: nobody → sticks702@yahoo.com (sticks702)
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → sticks702@yahoo.com (sticks702)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers