No sound on Asus e200ha, intel sst with cx2072x codec

Bug #1563110 reported by Gianmaria Scorza on 2016-03-28
308
This bug affects 56 people
Affects Status Importance Assigned to Milestone
ALSA driver
Fix Released
Unknown
alsa-driver (Ubuntu)
High
Unassigned
linux (Ubuntu)
High
Unassigned

Bug Description

I've recently bought an Asus e200ha.
Sound in this laptop doesn't work.
The sound card is an intel sst with codec conexant cx2072x

aplay -l:
aplay: device_list:268: no soundcard found...
in the sound setting there is a "Dummy output"
---
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CurrentDesktop: XFCE
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=7b77dc46-7d5b-4869-83dd-739980736c3a
InstallationDate: Installed on 2016-03-28 (0 days ago)
InstallationMedia: Linux Mint 17.3 "Rosa" - Release amd64 20160105
Lsusb:
 Bus 002 Device 002: ID 0781:5583 SanDisk Corp.
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 13d3:3496 IMC Networks
 Bus 001 Device 002: ID 04f2:b54b Chicony Electronics Co., Ltd
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: ASUSTeK COMPUTER INC. E200HA
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic root=UUID=50fb13c0-a8cd-441d-a38b-c0295c1b9a15 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.19.0-32.37~14.04.1-generic 3.19.8-ckt7
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-32-generic N/A
 linux-backports-modules-3.19.0-32-generic N/A
 linux-firmware 1.127.16
Tags: rosa
Uname: Linux 3.19.0-32-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 11/26/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: E200HA.203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: E200HA
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrE200HA.203:bd11/26/2015:svnASUSTeKCOMPUTERINC.:pnE200HA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnE200HA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: E200HA
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

affects: launchpad → ubuntu
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1563110

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected rosa
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Raymond (superquad-vortex2) wrote :
Changed in alsa-driver (Ubuntu):
status: Confirmed → Incomplete
Gianmaria Scorza (scogiam95) wrote :

The sst platform in use is the SND_SOC_INTEL_CHT_BSW, but there isn't a module compatible with the Conexant cx2072x codec

Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
Gianmaria Scorza (scogiam95) wrote :

The sound card in this laptop is the Intel sst cherry trail, the codec is the cx2072x

Gianmaria Scorza (scogiam95) wrote :

I had already seen that patch, but unfortunately is for intel HD audio (hda) not for intel sst. in sound/soc/codec is missing the codec cx2072x:
https://github.com/torvalds/linux/tree/master/sound/soc/codecs

in sound /soc/intel/boards there are only cht_bsw_max98090_ti.c, cht_bsw_rt5645.c, cht_bsw_rt5672.c, is missing an eventual cht_bsw_cx2072x.c:
https://github.com/torvalds/linux/tree/master/sound/soc/intel/boards

Gianmaria Scorza (scogiam95) wrote :

dmesg say :
[ 12.270548] intel_sst_acpi 808622A8:00: No matching machine driver found

there is 0x808622a8, but there isn't a driver for it

Gianmaria Scorza (scogiam95) wrote :

This is a tree of module on the latest kernel on my pc

/lib/modules/4.6.0-040600rc1-generic/kernel/sound/soc/intel $ tree
.
├── atom
│   ├── snd-soc-sst-mfld-platform.ko
│   └── sst
│   ├── snd-intel-sst-acpi.ko
│   ├── snd-intel-sst-core.ko
│   └── snd-intel-sst-pci.ko
├── boards
│   ├── snd-soc-skl_rt286.ko
│   ├── snd-soc-sst-bytcr-rt5640.ko
│   ├── snd-soc-sst-cht-bsw-max98090_ti.ko
│   ├── snd-soc-sst-cht-bsw-rt5645.ko
│   └── snd-soc-sst-cht-bsw-rt5672.ko
├── common
│   ├── snd-soc-sst-acpi.ko
│   ├── snd-soc-sst-dsp.ko
│   ├── snd-soc-sst-ipc.ko
│   └── snd-soc-sst-match.ko
└── skylake
    ├── snd-soc-skl-ipc.ko
    └── snd-soc-skl.ko

5 directories, 15 files

Changed in linux (Ubuntu):
importance: Undecided → Medium
Gianmaria Scorza (scogiam95) wrote :

Any news about this bug?

vittorio (vittoriourbani) wrote :

hi gianmaria, are you italian? if so ciao hai il mio stesso problema, io con pavilion x2 10n105nl con atom z8300!
your trouble is mine too, i also tried kernel 4.4 4.5 4.6 and ubuntu mate 16.04 but no any improvements. let's hope a kernel patch or a new kernel release to fix it.
my spec: hp pavilion x2 10n105nl, atom z8300 on board.

Gianmaria Scorza (scogiam95) wrote :

hi vittorio! Si sono italiano!
Purtroppo da quanto mi ha detto uno sviluppatore ASoC manca proprio il driver per questo codec, il supporto non arriverà tanto presto, se mai arriverà.
Dato che ero in tempo ho fatto il reso su amazon, meno male!
English translation: An ASoC develor said that is missing the driver for this chipset, this may take a while to get support for this platform unfortunately.
I sent back the pc to Amazon,I was fortunately in time to do it!

vittorio (vittoriourbani) wrote :

brutta notizia, son costretto a tornare su windows..grazie della risposta e buona giornata.
thanks for reply, i'm forced to go back on windows..

Dani (danimixsenses) wrote :

anything new on this? =(

vittorio (vittoriourbani) wrote :

any good news. I tried to recompile dsdt table, to enable snd_hda_intel and snd_hda_codecs_conexant disabling intel_sst: no improvements, also restoring alsactl.
my workaround was..buying a bluetooth mini speakers..
..hoping for hotfixes.
What a pity!

Rubens (rubensdeveloper) wrote :

Any news? Arghh, I've bought it few weeks ago and the first thing I did was install Ubuntu 14.04. No wifi, no sound, no "touchpad" and no card reader, but the rest is working flawless. I am a web developer and I found this little thing awesome for continue my work at home. I got the wifi working now and for the sound I'm using a bluetooth headset device, but it hasn't got much sound quality... I hope they find a solution for the audio at least.....

vittorio (vittoriourbani) wrote :

hi rubens, for your touchpad issue: what kernel have you? ('uname -a' comand in terminal). Some have resolved by updating the kernel to xenial-release one.

1 comments hidden view all 254 comments
Rubens (rubensdeveloper) wrote :

Hi Vittorio, the touchpad is working, but not the gestures. Sorry for the misunderstanding :-).

Rubens (rubensdeveloper) wrote :

Any news on this? I miss the terminal so much :S:S:S....

Barry (b-kooij) wrote :

Any update on this? I'd love the get the touchpad working properly.

Download full text (3.4 KiB)

Hello,

The touchpad is working fine with 4.4.0-23-generic, but the sound problem
persists.

On Mon, Jun 6, 2016 at 4:16 PM, Barry <email address hidden> wrote:

> Any update on this? I'd love the get the touchpad working properly.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1563110
>
> Title:
> No sound on Asus e200ha, intel sst with cx2072x codec
>
> Status in ALSA driver:
> Unknown
> Status in alsa-driver package in Ubuntu:
> Confirmed
> Status in linux package in Ubuntu:
> Confirmed
>
> Bug description:
> I've recently bought an Asus e200ha.
> Sound in this laptop doesn't work.
> The sound card is an intel sst with codec conexant cx2072x
>
> aplay -l:
> aplay: device_list:268: no soundcard found...
> in the sound setting there is a "Dummy output"
> ---
> ApportVersion: 2.14.1-0ubuntu3.19
> Architecture: amd64
> AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq',
> '/dev/snd/timer'] failed with exit code 1:
> CurrentDesktop: XFCE
> DistroRelease: Ubuntu 14.04
> HibernationDevice: RESUME=UUID=7b77dc46-7d5b-4869-83dd-739980736c3a
> InstallationDate: Installed on 2016-03-28 (0 days ago)
> InstallationMedia: Linux Mint 17.3 "Rosa" - Release amd64 20160105
> Lsusb:
> Bus 002 Device 002: ID 0781:5583 SanDisk Corp.
> Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
> Bus 001 Device 003: ID 13d3:3496 IMC Networks
> Bus 001 Device 002: ID 04f2:b54b Chicony Electronics Co., Ltd
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: ASUSTeK COMPUTER INC. E200HA
> Package: linux (not installed)
> ProcEnviron:
> TERM=xterm
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-32-generic
> root=UUID=50fb13c0-a8cd-441d-a38b-c0295c1b9a15 ro quiet splash vt.handoff=7
> ProcVersionSignature: Ubuntu 3.19.0-32.37~14.04.1-generic 3.19.8-ckt7
> RelatedPackageVersions:
> linux-restricted-modules-3.19.0-32-generic N/A
> linux-backports-modules-3.19.0-32-generic N/A
> linux-firmware 1.127.16
> Tags: rosa
> Uname: Linux 3.19.0-32-generic x86_64
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
> _MarkForUpload: True
> dmi.bios.date: 11/26/2015
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: E200HA.203
> dmi.board.asset.tag: ATN12345678901234567
> dmi.board.name: E200HA
> dmi.board.vendor: ASUSTeK COMPUTER INC.
> dmi.board.version: 1.0
> dmi.chassis.asset.tag: ATN12345678901234567
> dmi.chassis.type: 10
> dmi.chassis.vendor: ASUSTeK COMPUTER INC.
> dmi.chassis.version: 1.0
> dmi.modalias:
> dmi:bvnAmericanMegatrendsInc.:bvrE200HA.203:bd11/26/2015:svnASUSTeKCOMPUTERINC.:pnE200HA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnE200HA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
> dmi.product.name: E200HA
> dmi.product.version: 1.0
> dmi.sys.vendor: ASUSTeK COMPUTER INC.
>
> To manage notifications abo...

Read more...

vittorio (vittoriourbani) wrote :

not yet working issues: audio, integrated camera, microsd card reader, battery recognizing; with kernel 4.6 and 4.7rc1 also.

carlix (carlixlinux) wrote :

Same problem with Acer Aspire Switch 10 "intel sst audio device (wdm)"

cmmndrkn (tihomir-tsvetcov) wrote :

I just got my E200HA and faced these problems. Does anyone found a solution for the sound and the card reader already?

Jose Luis (xoserabade) wrote :

I think for this device was the same problem because they have the same Intel Atom processor Z8300. Here they solved the problem, I don't know if this solution can be ported for ASUS Vivobook E200AH.
http://forum.kodi.tv/showthread.php?tid=261371&page=3

Regards.

Hayashi (synzl) on 2016-11-07
tags: added: xenial
Changed in linux (Ubuntu):
importance: Medium → High
Changed in alsa-driver (Ubuntu):
importance: Undecided → High
Changed in alsa-driver (Ubuntu):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Marek (yesion) on 2017-07-14
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → Fix Committed
Miroslaw (m.stepanenko) on 2017-08-16
Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
174 comments hidden view all 254 comments

It is working perfectly well in Ubuntu 18.04 beta 2. Please remember that it's not just a newer kernel that's needed. ALSA may need to be upgraded as well and the required codec has to be present.

Yes, it is working in Ubuntu 18.04. Thanks you.
Have a nice day

(In reply to Jakub K. from comment #94)
> Yes, it is working in Ubuntu 18.04. Thanks you.
> Have a nice day

(In reply to Caitlyn Martin from comment #93)
> It is working perfectly well in Ubuntu 18.04 beta 2. Please remember that
> it's not just a newer kernel that's needed. ALSA may need to be upgraded as
> well and the required codec has to be present.

Do you mean that it works "out of the box"? The bug has been fixed in the new version of Ubuntu?

> Do you mean that it works "out of the box"? The bug has been fixed in the
> new version of Ubuntu?

Yes, that is exactly what I mean. It just works immediately after installation. Having said that, you still have to use the Linuxium image or remaster the iso to get the installer to work, unlike Fedora and SUSE which have installers that support Atom and Apollo Lake devices. A working iso is at: http://linuxiumcomau.blogspot.com/2018/04/fourth-look-at-ubuntu-1804-lts-bionic.html

Hi,

But not work on manjaro 17.1.11 !
The bug is not fixed is not integrated to kernel no ?
Have possibility to merge driver on kernel 4.18 ?

https://www.manjaro.fr/forum/viewtopic.php?f=19&t=8812&hilit=asus
https://forum.manjaro.org/t/asus-e200ha-no-sound/44205/7
https://bugzilla.kernel.org/show_bug.cgi?id=200491

Cordialy

It is fixed in the 4.18 kernel but more than an updated kerne is
required. You also need an up to date version of alsa and the new
codec to be included when the kernel is compiled. The problem with
Manjaro is almost certainly a Manjaro problem, not an upstream
problem.

On Sat, Jul 14, 2018 at 4:15 AM, <email address hidden> wrote:
> https://bugzilla.kernel.org/show_bug.cgi?id=115531
>
> liberodark (<email address hidden>) changed:
>
> What |Removed |Added
> ----------------------------------------------------------------------------
> CC| |<email address hidden>
>
> --- Comment #97 from liberodark (<email address hidden>) ---
> Hi,
>
> But not work on manjaro 17.1.11 !
> The bug is not fixed is not integrated to kernel no ?
> Have possibility to merge driver on kernel 4.18 ?
>
> https://www.manjaro.fr/forum/viewtopic.php?f=19&t=8812&hilit=asus
> https://forum.manjaro.org/t/asus-e200ha-no-sound/44205/7
> https://bugzilla.kernel.org/show_bug.cgi?id=200491
>
> Cordialy
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.

Changed in alsa-driver:
status: Unknown → Confirmed

Is it fixed or not?

If fixed, where is the update patch?

Chris Hand (oompa) on 2018-07-30
Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released

(In reply to Caitlyn Martin from comment #98)
> It is fixed in the 4.18 kernel but more than an updated kerne is
> required. You also need an up to date version of alsa and the new
> codec to be included when the kernel is compiled. The problem with
> Manjaro is almost certainly a Manjaro problem, not an upstream
> problem.

I'm not sure what you are talking about, I also checked ubuntu source but there's really no sign of the driver having ever landed farther than the majestic tree by Heiko
https://github.com/heikomat/linux/tree/cx2072x
(in the Asus-E200HA specific repo in fact, they mention xubuntu 18.04 still require patching and all)

The 808622A8 id you reported above is the just the Intel "Smart Sound Technology" device.
But the actual audio codec is another thing. In fact windows driver pack just has an AudioRealtek folder.

Nothing to do with this issue.

https://support.hp.com/us-en/drivers/selfservice/swdetails/hp-x2-10-p000-notebook-pc/12499232/model/13443302/swItemId/ob-201938-1
https://wiki.debian.org/InstallingDebianOn/HP/Pavilion%20x2%2010%20(2015%20model)/Jessie

See comment #73. FWIW I pinged someone at Conexant one year ago,
the answer was essentially "no time, but soon". I guess it will
never happen. IMHO Takeshi should just submit his version even if it
has minor issues.

Well, that explains the pitiful situation. Let's see if CCing the conexant author solves anything.

It did actually improve something on their own repo.. Not sure why he never got back
https://github.com/conexant/codec_drivers/commits/rpi-4.4.y

Hi is not merged on 4.16 / 4.17 / 4.18 / 4.19 for what ?

https://forum.manjaro.org/t/asus-e200ha-no-sound/44205/17
marcin19883 say : Kernel 4.19 RC1 Audio not working. No codec include. :(

(In reply to Caitlyn Martin from comment #98)
> It is fixed in the 4.18 kernel but more than an updated kerne is
> required. You also need an up to date version of alsa and the new
> codec to be included when the kernel is compiled. The problem with
> Manjaro is almost certainly a Manjaro problem, not an upstream
> problem.
>
> On Sat, Jul 14, 2018 at 4:15 AM, <email address hidden>
> wrote:
> > https://bugzilla.kernel.org/show_bug.cgi?id=115531
> >
> > liberodark (<email address hidden>) changed:
> >
> > What |Removed |Added
> >
> ----------------------------------------------------------------------------
> > CC| |<email address hidden>
> >
> > --- Comment #97 from liberodark (<email address hidden>) ---
> > Hi,
> >
> > But not work on manjaro 17.1.11 !
> > The bug is not fixed is not integrated to kernel no ?
> > Have possibility to merge driver on kernel 4.18 ?
> >
> > https://www.manjaro.fr/forum/viewtopic.php?f=19&t=8812&hilit=asus
> > https://forum.manjaro.org/t/asus-e200ha-no-sound/44205/7
> > https://bugzilla.kernel.org/show_bug.cgi?id=200491
> >
> > Cordialy
> >
> > --
> > You are receiving this mail because:
> > You are on the CC list for the bug.

And have view is not officialy merged arch and majanro is not implicated for this problem.

Please make a official merge to add audio codec.

Cordialy

(In reply to marcin19883 from comment #104)
> https://github.com/conexant/codec_drivers/commits/rpi-4.4.y
>
> Autor adding support linux kernel 4.18.

Sorry for bothering, but did he try to merge it to the main kernel? Or do we have to compile it ourselves from this branch?

(In reply to Jacek Jagosz from comment #105)
> (In reply to marcin19883 from comment #104)
> > https://github.com/conexant/codec_drivers/commits/rpi-4.4.y
> >
> > Autor adding support linux kernel 4.18.
>
> Sorry for bothering, but did he try to merge it to the main kernel? Or do we
> have to compile it ourselves from this branch?

I have no idea. I'm a beginning linux user. I am currently using Arch Linux and the cx2072x kernel from AUR. It works great. Everything works, even better than on ubuntu 18.04.

> Or do we have to compile it ourselves from this branch?

There is prebuilt packages, if you need them: https://github.com/heikomat/linux/releases

By the way, is UCM from Comment 68 is recent, or there is newer version somewhere?

Created attachment 280807
Takashi cx2072x patch against 4.20

I've had a bit of trouble following this discussion in terms of what has been added by Takashi et al's patches. So here is a diff against vanilla kernel 4.20.0 to see what the changes and additions are, for ease of reference.

> Or do we have to compile it ourselves from this branch?

If you use debian or derivatives, you can find the releases in Heikomat's repo.

If you use ArchLinux or derivitives, you can use AUR (https://aur.archlinux.org/packages/linux-cx2072x/) to build your own packages, or you can use my prebuilt packages (built from AUR) from here: https://files.linux365.ro/linux-cx2072x/

In case anyone is searching the web to seek solutions, I'll put on the record that 4.20.4, with the patch as generated above, along with the UCM files that have been posted on git at https://github.com/heikomat/linux/tree/cx2072x/cx2072x_fixes_and_manual/chtcx2072x - sound is now functioning on my Asus Transformer Mini T103HA.

Shouldn't really matter as I am using an updated but otherwise vanilla kernel from ftp.kernel.org, but again, for the record, this is under Slackware Current (live ISO from alienBob 1.3.0.2, 20190117).

Thanks all. I hope these efforts can be merged into mainline Linux and ALSA, but I'm sure there are reasons above my head as to why they have not.

*** Bug 200431 has been marked as a duplicate of this bug. ***

> I hope these efforts can be merged into mainline Linux and ALSA.

Me too: I lack the know-how to fix the kernel myself, unfortunately...

(In reply to mirh from comment #113)
> https://mailman.alsa-project.org/pipermail/alsa-devel/2019-May/149706.html
>
> CX2072X is landing in 5.3.

That's good news! I'll look forward to it, thanks :)

Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc

This driver (along with necessary alsa ucm files) as now included with 5.3.x is working on my system (vanilla 5.3.4). I'd recommend closing this bug as FIXED.

TC (zenoarrow) wrote :
Download full text (5.9 KiB)

I'm running Ubuntu 19.10 on an Asus E200H laptop. I'm getting no sound output. CX2027x kernel modules seem to be available but there appear to be issues during boot.

Including the following information to help track down the issue (if there's anything else that I should provide please let me know):

(base) zenoarrow@zenoarrow-E200HA:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.10
Release: 19.10
Codename: eoan

uname -a
Linux zenoarrow-E200HA 5.3.0-23-generic #25-Ubuntu SMP Tue Nov 12 09:22:33 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

dmesg | grep cx2072x
[ 9.287864] cx2072x i2c-14F10720:00: codec version: 14f150f2,00100101
[ 11.889796] bytcht_cx2072x bytcht_cx2072x: snd-soc-dummy-dai <-> media-cpu-dai mapping ok
[ 11.890348] bytcht_cx2072x bytcht_cx2072x: snd-soc-dummy-dai <-> deepbuffer-cpu-dai mapping ok
[ 11.895693] bytcht_cx2072x bytcht_cx2072x: cx2072x-hifi <-> ssp2-port mapping ok
[ 11.895903] bytcht_cx2072x bytcht_cx2072x: ASoC: sink widget Playback overwritten
[ 11.895928] bytcht_cx2072x bytcht_cx2072x: ASoC: source widget Capture overwritten
[ 11.896417] cx2072x i2c-14F10720:00: ASoC: Failed to create Playback debugfs file: -17
[ 11.896425] cx2072x i2c-14F10720:00: ASoC: Failed to create Capture debugfs file: -17
[ 11.915242] input: bytcht-cx2072x Headset as /devices/pci0000:00/808622A8:00/bytcht_cx2072x/sound/card1/input14
[ 124.561900] Modules linked in: rfcomm twofish_generic twofish_x86_64_3way twofish_x86_64 twofish_common serpent_sse2_x86_64 serpent_generic blowfish_generic blowfish_x86_64 blowfish_common cast5_generic cast_common des_generic algif_skcipher camellia_generic camellia_x86_64 xcbc md4 pci_stub algif_hash vboxpci(OE) af_alg vboxnetadp(OE) vboxnetflt(OE) xfrm_user xfrm4_tunnel tunnel4 ipcomp xfrm_ipcomp esp4 vboxdrv(OE) ah4 l2tp_ppp l2tp_netlink l2tp_core ip6_udp_tunnel udp_tunnel af_key xfrm_algo pppox ccm bnep ip6table_filter ip6_tables iptable_filter bpfilter binfmt_misc nls_iso8859_1 snd_soc_sst_byt_cht_cx2072x joydev snd_hdmi_lpe_audio mei_hdcp intel_rapl_msr intel_powerclamp coretemp kvm_intel kvm irqbypass punit_atom_debug crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 crypto_simd cryptd glue_helper asus_nb_wmi intel_cstate uvcvideo btusb videobuf2_vmalloc btrtl videobuf2_memops btbcm videobuf2_v4l2 btintel videobuf2_common bluetooth videodev
[ 124.561970] intel_chtdc_ti_pwrbtn input_leds mc ecdh_generic ecc ath10k_pci ath10k_core ath mac80211 cfg80211 libarc4 intel_xhci_usb_role_switch roles sof_acpi_dev snd_sof_intel_byt snd_sof_intel_bdw snd_sof_intel_ipc snd_sof snd_sof_xtensa_dsp snd_intel_sst_acpi snd_intel_sst_core snd_soc_sst_atom_hifi2_platform snd_soc_cx2072x snd_soc_acpi_intel_match snd_soc_acpi snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_pcm snd_seq_midi snd_seq_midi_event i915 snd_rawmidi snd_seq snd_seq_device snd_timer drm_kms_helper drm snd i2c_algo_bit fb_sys_fops syscopyarea mei_txe sysfillrect soundcore sysimgblt mei processor_thermal_device elan_i2c intel_rapl_common int3400_thermal int3403_thermal intel_soc_dts_iosf acpi_thermal_rel int340x_thermal_zone int3406_thermal intel_int00...

Read more...

TC (zenoarrow) wrote :

Following on from the comment above, if I look for "Audio" with a capital A in the dmesg output, this is a shortened version of what I get (the backend DAIs message is repeated multiple times in the real output)...

dmesg | grep Audio
[ 0.159834] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 9.038350] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=0 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input11
[ 9.038558] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=1 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input12
[ 9.038738] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=2 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input13
[ 16.076038] Audio Port: ASoC: no backend DAIs enabled for Audio Port

TC (zenoarrow) wrote :

Also continuing from my messages earlier today, I had some promising looking output from the following two commands...

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: bytchtcx2072x [bytcht-cx2072x], device 0: Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: bytchtcx2072x [bytcht-cx2072x], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

cat /proc/asound/cards
 0 [Audio ]: HdmiLpeAudio - Intel HDMI/DP LPE Audio
                      Intel HDMI/DP LPE Audio
 1 [bytchtcx2072x ]: bytcht-cx2072x - bytcht-cx2072x
                      ASUSTeKCOMPUTERINC.-E200HA-1.0-E200HA

Does this help at all? Is there a reason the HDMI/DP LPE audio output would be picked as the default? Any advice on testing this further?

sultan (sultanqasim) wrote :

Looks like you are missing UCM config files (due to an outdated ALSA UCM package that's not in sync with the kernel). This is what causes the "Audio Port: ASoC: no backend DAIs enabled for Audio Port" messages. See this thread: https://bugzilla.kernel.org/show_bug.cgi?id=115531#c43

TC (zenoarrow) wrote :

Thanks for this sultan, this is useful information. Forgot to mention that I was able to get help in fixing the bug, turns out I needed a newer version of alsa-lib, had to switch to Fedora to get a packaged version but I can confirm audio on my laptop is working now...

https://bugzilla.redhat.com/show_bug.cgi?id=1775732

1 comments hidden view all 254 comments

Why the latest Androidx86 release (9.0-rc1) it's still based on kernel 4.19.80 (https://www.android-x86.org/releases/releasenote-9-0-rc1.html)?

How am I supposed to upgrade to v 5.3.x?

(In reply to Riccardo from comment #116)
> Why the latest Androidx86 release (9.0-rc1) it's still based on kernel
> 4.19.80 (https://www.android-x86.org/releases/releasenote-9-0-rc1.html)?
>
> How am I supposed to upgrade to v 5.3.x?

Riccardo, this bug tracker is related to upstream developing of Linux kernel. Perhaps you have to ask this via Android issue tracker.

Close as fixed based on comment #115.

2 comments hidden view all 254 comments
BeBa (bbara93) wrote :

Hey all,

got it working on my Asus E200HA @ Xubuntu 19.10.
As already mentioned, the installed kernel (currently 5.3.0-24) already brings the driver.

What I had to do was uninstalling libasound2 (currently 1.1.9-1),
as the sound card is not supported in this version.

After uninstalling, I installed the latest alsa-lib [1] (1.2.1.2).
Note, that the default installation of the alsa-lib takes place in "/usr/lib",
but it should be placed in "/usr/lib/x86_64-linux-gnu/".
This can be done by running "./configure --libdir=/usr/lib/x86_64-linux-gnu/".

After installing it, I downloaded the latest alsa-ucm-config [2] (1.2.1.2).
The content of the ucm2 folder must be stored in "/usr/share/alsa/ucm2/".

After a reboot, the sound works :)

So, installing the latest libasound2 (= alsa-lib) on the right place and
placing the UCM files in the right directory did the trick for me.

[1] https://github.com/alsa-project/alsa-lib
[2] https://github.com/alsa-project/alsa-ucm-conf/

Changed in alsa-driver:
status: Confirmed → Fix Released
3 comments hidden view all 254 comments

World Vision India is focused on exclusive expectations of responsibility and straightforwardness which is a statement of our guiding principle on ''how to sponsor a child in another country”. This is on the grounds that we intensely accept that we work successfully for the prosperity of kids. World Vision India ceaselessly endeavors to keep up high national and global models of expert capability and is responsible through proper structures for accomplishing these norms. https://www.worldvision.in

Our vision for every child, life in all its fullness. Our prayer for every heart, the will to make it so.We work toward a nation and a world where every child experiences life in all its fullness. Where they are protected, cared for how to sponsor a child in another country and given the opportunities to become everything they’re meant to be. https://www.hopetoshine.in

Cannabidiol (CBD) has been as of late shrouded in the media, and you may have even considered it to be an include sponsor to your post-exercise smoothie or morning espresso. What precisely is CBD? For what reason is it out of nowhere so famous?
https://cforcbd.com/products/cbd-oil/

Sponsoring a child through World Vision India is one of the best, motivating and compensating approaches to support youngsters. You'll be doing significantly more than assisting with meeting youngsters' fundamental needs – you'll be assisting with equiping them forever. By achieving enduring change in your supported kid's locale, you'll likewise be improving the lives of numerous other defenseless youngsters to Child Ngos child sponsorship is probably the most ideal approaches to give kids better lives and prospects of. At the point when you support a youngster, you will get photo of your supported kid, data about your kid, kid's family and network, yearly report showing the advancement of your kid, World Vision India's magazine Jeevan Sparsh and a chance to blessing, compose or visit your supported kid. https://www.worldvision.in

Our vision for every child, life in all its fullness. Our prayer for every heart, the will to make it so.We work toward a nation and a world where every child experiences life in all its fullness. Where they are protected, cared for to and given the opportunities to become everything they’re Child Ngos
 meant to be. https://www.hopetoshine.in

Hello,
  I know this issue is closed, but should I post
in this thread if I got a problem with my microp
hone on a E200HA, Ubuntu 18.04, custom kernel bas
ed on 5.6.3 with cx2072x support compiled in and
right UCM files ?
Or should I create a bug report ?

Thanks.

Hello,

  I fixed my problem from last comment, here's how I did it:
For the backstory, I have a E200HA Asus Notebook/EEePC.

1. Get kernel with cx2072x support, enable it and update grub to boot into it.
2. Get alsa-lib-1.2.2 (or any stable release I guess) from https://github.com/alsa-project/alsa-lib
3. ./gitcompile --libdir=/usr/lib/x86_64-linux-gnu (or ./configure --libdir=/usr/lib/x86_64-linux-gnu if it didn't work) followed by make && make install
4. Get alsa-ucm-conf from https://github.com/alsa-project/alsa-ucm-conf (again, matching the release number of alsa-lib you compiled, in our case it's 1.2.2)
5. Rename your /usr/share/alsa/ucm into ucm.old directory and create /usr/share/alsa/ucm2 directory
6. Copy ucm2 directory from cloned alsa-ucm-conf git repo into /usr/share/alsa/
7. Reboot

Displaying first 40 and last 40 comments. View all 254 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.