I2C touchscreen init failed on HP X360

Bug #1562778 reported by Phidias on 2016-03-28
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Medium
Phidias
Vivid
Medium
Unassigned
Wily
Medium
Unassigned
Xenial
Medium
Phidias

Bug Description

[Impact]

As title, after upgrading to latest Vivid kernel the touchscreen failed. After bisecting shows this revert cause the regression:

commit 95df597989f6f297db63dd8669656d10f5f48eb1
Author: Andy Shevchenko <email address hidden>
Date: Fri Dec 4 23:49:18 2015 +0200

    Revert "ACPI / LPSS: allow to use specific PM domain during ->probe()"

[Fix]

The reverted patch has had a revised version upstreamed:

commit de16d55206c5ce82ad44590b01718fbe2323853c
Author: Andy Shevchenko <email address hidden>
Date: Fri Dec 4 23:49:19 2015 +0200

    ACPI / LPSS: allow to use specific PM domain during ->probe()

For Vivid it depends on a patch to device core for adding BUS_NOTIFY_DRIVER_NOT_BOUND notification, both are clean cherry-pick.

For Xenial the touchscreen still works because the original patch is not reverted, and with the patch reverted the I2C touchscreen still works fine, so I'll skip Xenial for this patch.

For Wily it also contains the revert patch as Vivid, but the I2C on X360 still works.

[Test]

3.19.0-56 -> Failed
3.19.0-56 + patches -> OK (Including suspend)
4.2.0-34 (with revert patch already) -> OK
4.4.0-15 -> OK
4.4.0-15 + revert patch -> OK
4.4.0-15 + patches -> N/A

Phidias (phidias-chiang) on 2016-03-28
tags: added: originate-from-1490411 stella

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1562778

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
tags: added: kernel-da-key
Phidias (phidias-chiang) on 2016-03-29
tags: removed: xenial
Phidias (phidias-chiang) on 2016-03-29
description: updated
Phidias (phidias-chiang) on 2016-03-29
description: updated
Tim Gardner (timg-tpi) on 2016-03-30
Changed in linux (Ubuntu Xenial):
status: Triaged → In Progress
Changed in linux (Ubuntu Wily):
assignee: nobody → Phidias (phidias-chiang)
status: New → In Progress
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Released
Phidias (phidias-chiang) on 2016-03-31
description: updated
Changed in linux (Ubuntu Vivid):
status: New → Fix Committed
Kamal Mostafa (kamalmostafa) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-vivid
Phidias (phidias-chiang) on 2016-04-26
tags: added: verification-done-vivid
removed: verification-needed-vivid
Changed in linux (Ubuntu Vivid):
importance: Undecided → Medium
Changed in linux (Ubuntu Wily):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :
Download full text (23.4 KiB)

This bug was fixed in the package linux - 3.19.0-59.65

---------------
linux (3.19.0-59.65) vivid; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1571694

  [ Benjamin Tissoires ]

  * SAUCE: Input: synaptics - handle spurious release of trackstick
    buttons, again
    - LP: #1553811

  [ K. Y. Srinivasan ]

  * SAUCE: (noup): Drivers: hv: vmbus: Fix a bug in
    hv_need_to_signal_on_read()
    - LP: #1556264

  [ Kamal Mostafa ]

  * [debian] BugLink: close LP: bugs only for Launchpad urls
  * [Config] updateconfigs after v3.19.8-ckt18

  [ Upstream Kernel Changes ]

  * Revert "jffs2: Fix lock acquisition order bug in jffs2_write_begin"
    - LP: #1561714
  * [stable-only] AIO: properly check iovec sizes
    - LP: #1561714
  * Input: aiptek - fix crash on detecting device without endpoints
    - LP: #1561714
  * wext: fix message delay/ordering
    - LP: #1561714
  * cfg80211/wext: fix message ordering
    - LP: #1561714
  * mac80211: fix use of uninitialised values in RX aggregation
    - LP: #1561714
  * libata: fix HDIO_GET_32BIT ioctl
    - LP: #1561714
  * iwlwifi: mvm: inc pending frames counter also when txing non-sta
    - LP: #1561714
  * [media] adv7604: fix tx 5v detect regression
    - LP: #1561714
  * ahci: add new Intel device IDs
    - LP: #1561714
  * ahci: Order SATA device IDs for codename Lewisburg
    - LP: #1561714
  * Adding Intel Lewisburg device IDs for SATA
    - LP: #1561714
  * mac80211: minstrel_ht: set default tx aggregation timeout to 0
    - LP: #1561714
  * usb: chipidea: otg: change workqueue ci_otg as freezable
    - LP: #1561714
  * jffs2: Fix page lock / f->sem deadlock
    - LP: #1561714
  * Fix directory hardlinks from deleted directories
    - LP: #1561714
  * iommu/amd: Fix boot warning when device 00:00.0 is not iommu covered
    - LP: #1561714
  * iommu/amd: Apply workaround for ATS write permission check
    - LP: #1561714
  * libata: Align ata_device's id on a cacheline
    - LP: #1561714
  * can: gs_usb: fixed disconnect bug by removing erroneous use of kfree()
    - LP: #1561714
  * vfio: fix ioctl error handling
    - LP: #1561714
  * ALSA: ctl: Fix ioctls for X32 ABI
    - LP: #1561714
  * ALSA: rawmidi: Fix ioctls X32 ABI
    - LP: #1561714
  * ALSA: timer: Fix broken compat timer user status ioctl
    - LP: #1561714
  * ALSA: timer: Fix ioctls for X32 ABI
    - LP: #1561714
  * cifs: fix out-of-bounds access in lease parsing
    - LP: #1561714
  * CIFS: Fix SMB2+ interim response processing for read requests
    - LP: #1561714
  * Fix cifs_uniqueid_to_ino_t() function for s390x
    - LP: #1561714
  * arm/arm64: KVM: Fix ioctl error handling
    - LP: #1561714
  * ALSA: hdspm: Fix wrong boolean ctl value accesses
    - LP: #1561714
  * ALSA: hdspm: Fix zero-division
    - LP: #1561714
  * ALSA: hdsp: Fix wrong boolean ctl value accesses
    - LP: #1561714
  * USB: qcserial: add Dell Wireless 5809e Gobi 4G HSPA+ (rev3)
    - LP: #1561714
  * USB: cp210x: Add ID for Parrot NMEA GPS Flight Recorder
    - LP: #1561714
  * ASoC: wm8958: Fix enum ctl accesses in a wrong type
    - LP: #1561714
  * ASoC: wm8994: Fix enum ctl accesses in a wrong type
    - LP: #1561714
  * A...

Changed in linux (Ubuntu Vivid):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Wily):
assignee: Phidias (phidias-chiang) → nobody
status: In Progress → Won't Fix
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers