perf: 24x7: Eliminate domain name suffix in event names

Bug #1560482 reported by bugproxy on 2016-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Canonical Kernel Team
Xenial
Medium
Tim Gardner
Yakkety
Medium
Unassigned
Zesty
Medium
Canonical Kernel Team

Bug Description

Events in the 24x7 counters can belong to different domains like
core, chip, virtual CPU home core, etc. To monitor an event, the
user must specify the required parameters for the event, which
include its name, the chip/core on which to monitor the event
as well as the domain.

Currently the event is specified to the perf tool as:

        'hv_24x7/HPM_0THRD_NON_IDLE_CCYC__PHYS_CORE,core=1/' \

where the event name is 'HPM_0THRD_NON_IDLE_CCYC', the suffix
'__PHYS_CORE' specifies the domain, and 'core=1' specifies the
core. This is inconsistent in that one parameter is specified
as a suffix and the other in a parameter=value format.

To simplify the usage, we can eliminate the suffix and let the
user specify the domain also in the param=value format. While
the domain indices are "well known" or nearly fixed in value,
we could display the domain indices in sysfs as a reference for
the users:

        $ cat /sys/bus/event_source/devices/hv_24x7/interface/domains
        1: Physical Chip
        2: Physical Core
        3: VCPU Home Core
        4: VCPU Home Chip
        5: VCPU Home Node
        6: VCPU Remote Node

Using these the perf event can now be identified as

        hv_24x7/HPM_0THRD_NON_IDLE_CCYC,domain=2,core=1

. This feature is implemented by the following commits which have now been merged into mainline:

        d34171e: powerpc/perf/hv-24x7: Display domain indices in sysfs
        8f69dc7: powerpc/perf/24x7: Eliminate domain suffix in event names

== Comment: #1 - Sukadev Bhattiprolu <email address hidden> - 2016-03-21 15:26:33 ==
Following two upstream commits are also related 24x7 and could
be included in this feature:

e5a5886: powerpc/perf/hv-24x7: Fix usage with chip events.
2b206ee: powerpc/perf/hv-24x7: Display change in counter values

bugproxy (bugproxy) on 2016-03-22
tags: added: architecture-ppc64 bugnameltc-139405 severity-medium targetmilestone-inin16041
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1560482/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Changed in ubuntu:
status: New → Incomplete
status: Incomplete → Confirmed
Steve Langasek (vorlon) on 2016-03-22
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → Medium
status: Confirmed → Triaged
Breno Leitão (breno-leitao) wrote :

Hello Leann,

Do you have any update on this bug?

Dimitri John Ledkov (xnox) wrote :

All of the mentioned commits are in v4.6 and later, thus this is fix released in yakkety and zesty.

Dimitri John Ledkov (xnox) wrote :

Tags: architecture-ppc64 -> seems to be the inconsistent tag.

tags: added: architecture-ppc64le
removed: architecture-ppc64
Changed in linux (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Changed in linux (Ubuntu Yakkety):
status: New → Fix Released
Changed in linux (Ubuntu Zesty):
status: Triaged → Fix Released
Changed in linux (Ubuntu Yakkety):
importance: Undecided → Medium
bugproxy (bugproxy) on 2017-01-04
tags: added: architecture-ppc64
removed: architecture-ppc64le
Tim Gardner (timg-tpi) wrote :
Changed in linux (Ubuntu Xenial):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Luis Henriques (henrix) on 2017-01-10
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
John Donnelly (jpdonnelly) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (10.8 KiB)

This bug was fixed in the package linux - 4.4.0-62.83

---------------
linux (4.4.0-62.83) xenial; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1657430

  * Backport DP MST fixes to i915 (LP: #1657353)
    - SAUCE: i915_bpo: Fix DP link rate math
    - SAUCE: i915_bpo: Validate mode against max. link data rate for DP MST

  * Ubuntu xenial - 4.4.0-59-generic i3 I/O performance issue (LP: #1657281)
    - blk-mq: really fix plug list flushing for nomerge queues

linux (4.4.0-61.82) xenial; urgency=low

  [ Thadeu Lima de Souza Cascardo ]

  * Release Tracking Bug
    - LP: #1656810

  * Xen MSI setup code incorrectly re-uses cached pirq (LP: #1656381)
    - SAUCE: xen: do not re-use pirq number cached in pci device msi msg data

  * nvme drive probe failure (LP: #1626894)
    - nvme: revert NVMe: only setup MSIX once

linux (4.4.0-60.81) xenial; urgency=low

  [ John Donnelly ]

  * Release Tracking Bug
    - LP: #1656084

  * Couldn't emulate instruction 0x7813427c (LP: #1634129)
    - KVM: PPC: Book3S PR: Fix illegal opcode emulation

  * perf: 24x7: Eliminate domain name suffix in event names (LP: #1560482)
    - powerpc/perf/hv-24x7: Fix usage with chip events.
    - powerpc/perf/hv-24x7: Display change in counter values
    - powerpc/perf/hv-24x7: Display domain indices in sysfs
    - powerpc/perf/24x7: Eliminate domain suffix in event names

  * i386 ftrace tests hang on ADT testing (LP: #1655040)
    - ftrace/x86_32: Set ftrace_stub to weak to prevent gcc from using short jumps
      to it

  * VMX module autoloading if available (LP: #1651322)
    - powerpc: Add module autoloading based on CPU features
    - crypto: vmx - Convert to CPU feature based module autoloading

  * ACPI probe support for AD5592/3 configurable multi-channel converter
    (LP: #1654497)
    - SAUCE: iio: dac: ad5592r: Add ACPI support
    - SAUCE: iio: dac: ad5593r: Add ACPI support

  * Xenial update to v4.4.40 stable release (LP: #1654602)
    - btrfs: limit async_work allocation and worker func duration
    - Btrfs: fix tree search logic when replaying directory entry deletes
    - btrfs: store and load values of stripes_min/stripes_max in balance status
      item
    - Btrfs: fix qgroup rescan worker initialization
    - USB: serial: option: add support for Telit LE922A PIDs 0x1040, 0x1041
    - USB: serial: option: add dlink dwm-158
    - USB: serial: kl5kusb105: fix open error path
    - USB: cdc-acm: add device id for GW Instek AFG-125
    - usb: hub: Fix auto-remount of safely removed or ejected USB-3 devices
    - usb: gadget: f_uac2: fix error handling at afunc_bind
    - usb: gadget: composite: correctly initialize ep->maxpacket
    - USB: UHCI: report non-PME wakeup signalling for Intel hardware
    - ALSA: usb-audio: Add QuickCam Communicate Deluxe/S7500 to
      volume_control_quirks
    - ALSA: hiface: Fix M2Tech hiFace driver sampling rate change
    - ALSA: hda/ca0132 - Add quirk for Alienware 15 R2 2016
    - ALSA: hda - ignore the assoc and seq when comparing pin configurations
    - ALSA: hda - fix headset-mic problem on a Dell laptop
    - ALSA: hda - Gate the mic jack on HP Z1 Gen3 AiO
    - ALSA: hd...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers