zFCP on s390x problems on zfcp module unloading

Bug #1559784 reported by Rafael David Tinoco on 2016-03-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Right after unloading zFCP module I got:

[ 1432.522123] sysfs group 0000000000b5aa30 not found for kobject '1:0:0:1073823786'
[ 1432.522138] ------------[ cut here ]------------
[ 1432.522139] WARNING: at /build/linux-RgAt0H/linux-4.3.0/fs/sysfs/group.c:224
[ 1432.522140] Modules linked in: ghash_s390(E) prng(E) aes_s390(E) des_s390(E) des_generic(E) sha512_s390(E) sha256_s390(E) sha1_s390(E) sha_common(E) vmur(E) qeth_l2(E) qeth(E) ccwgroup(E) dasd_eckd_mod(E) dasd_mod(E) zfcp(E-) qdio(E) scsi_transport_fc(E)
[ 1432.522149] CPU: 2 PID: 5873 Comm: rmmod Tainted: G E 4.3.0-2-generic #11-Ubuntu
[ 1432.522151] task: 0000000076f4a9e0 ti: 00000000ed85c000 task.ti: 00000000ed85c000
[ 1432.522152] Krnl PSW : 0704d00180000000 000000000036cbee (sysfs_remove_group+0xbe/0xd0)
[ 1432.522158] R:0 T:1 IO:1 EX:1 Key:0 M:1 W:0 P:0 AS:3 CC:1 PM:0 EA:3
               Krnl GPRS: 0000000000c76c33 0000000000c58e3c 0000000000000045 00000000fb1ac7a0
[ 1432.522160] 000000000036cbea 0000000000000000 0000000078d70050 0000000078d70000
[ 1432.522161] 0000000080000000 00000000f93df000 0000000078d7e010 0000000000000000
[ 1432.522162] 00000000ed85c000 0000000000b5aa30 000000000036cbea 00000000ed85fa78
[ 1432.522168] Krnl Code: 000000000036cbde: c020002bc358 larl %r2,8e528e
                          000000000036cbe4: c0e5fff7144a brasl %r14,24f478
                         #000000000036cbea: a7f40001 brc 15,36cbec
                         >000000000036cbee: e340f0c00004 lg %r4,192(%r15)
                          000000000036cbf4: ebaff0a00004 lmg %r10,%r15,160(%r15)
                          000000000036cbfa: 07f4 bcr 15,%r4
                          000000000036cbfc: 0707 bcr 0,%r7
                          000000000036cbfe: 0707 bcr 0,%r7
[ 1432.522177] Call Trace:
[ 1432.522179] ([<000000000036cbea>] sysfs_remove_group+0xba/0xd0)
[ 1432.522183] [<0000000000575a44>] device_del+0x5c/0x268
[ 1432.522184] [<0000000000575c90>] device_unregister+0x40/0x98
[ 1432.522186] [<00000000004d9b0c>] bsg_unregister_queue+0x74/0xd8
[ 1432.522189] [<00000000005aff76>] __scsi_remove_device+0xe6/0x118
[ 1432.522192] [<00000000005adaca>] scsi_forget_host+0xca/0xf8
[ 1432.522193] [<000000000059fa86>] scsi_remove_host+0xbe/0x1c8
[ 1432.522200] [<000003ff800496a6>] zfcp_scsi_adapter_unregister+0x9e/0xc8 [zfcp]
[ 1432.522202] [<000003ff8003b55e>] zfcp_adapter_unregister+0x7e/0xc0 [zfcp]
[ 1432.522205] [<000003ff8003c876>] zfcp_ccw_remove+0x28e/0x2b0 [zfcp]
[ 1432.522207] [<0000000000604814>] ccw_device_remove+0x44/0x210
[ 1432.522209] [<000000000057a9fe>] __device_release_driver+0xa6/0x150
[ 1432.522211] [<000000000057b782>] driver_detach+0x11a/0x120
[ 1432.522212] [<000000000057a342>] bus_remove_driver+0x82/0x118
[ 1432.522214] [<000003ff8004bdd2>] zfcp_module_exit+0x2a/0x258 [zfcp]
[ 1432.522217] [<00000000001caf6c>] SyS_delete_module+0x1c4/0x210
[ 1432.522221] [<000000000076dbfe>] system_call+0xd6/0x264
[ 1432.522222] [<000003ffb0f6e416>] 0x3ffb0f6e416
[ 1432.522223] Last Breaking-Event-Address:
[ 1432.522224] [<000000000036cbea>] sysfs_remove_group+0xba/0xd0
[ 1432.522225] ---[ end trace 2e7b1c668b02f90a ]---
[ 1432.522430] sysfs group 0000000000b5aa30 not found for kobject '1:0:0:1073823786'
[ 1432.522434] ------------[ cut here ]------------

Opening the bug for tracking purposes.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1559784

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
description: updated
Changed in linux (Ubuntu):
milestone: none → xenial-updates
tags: added: s390 s390x
Changed in linux (Ubuntu):
status: Incomplete → In Progress
importance: Undecided → High
Stefan Bader (smb) wrote :

Hm, Rafael, do we get the same with a more recent kernel? Should be 4.4 something by now...

modinfo zfcp; for i in {1..1000}; do echo "Try $i"; modprobe zfcp; lsmod | grep -q zfcp && echo ok-here; rmmod zfcp; lsmod | grep zfcp || echo ok-gone; done
filename: /lib/modules/4.4.0-15-generic/kernel/drivers/s390/scsi/zfcp.ko
license: GPL
description: FCP HBA driver
author: IBM Deutschland Entwicklung GmbH - <email address hidden>
srcversion: 342AF26FBC6A761648C34AB
alias: ccw:t1731m03dt1732dm04*
alias: ccw:t1731m03dt1732dm03*
depends: qdio,scsi_transport_fc
intree: Y
vermagic: 4.4.0-15-generic SMP mod_unload modversions
parm: queue_depth:Default queue depth for new SCSI devices (uint)
parm: dif:Enable DIF/DIX data integrity support (bool)
parm: allow_lun_scan:For NPIV, scan and attach all storage LUNs (bool)
parm: datarouter:Enable hardware data router support (default on) (bool)
parm: no_auto_port_rescan:no automatic port_rescan (default off) (bool)
parm: port_scan_backoff:upper limit of port scan random backoff in msecs (default 500) (uint)
parm: port_scan_ratelimit:minimum interval between port scans in msecs (default 60000) (uint)
parm: dbfsize:number of pages for each debug feature area (default 4) (uint)
parm: dbflevel:log level for each debug feature area (default 3, range 0..6) (uint)
parm: device:specify initial device (charp)
Try 1
ok-here
ok-gone
Try 2
ok-here
ok-gone
[...]

you get the idea, worked until 1000.

Therefore the bug is invalid with a recent kernel

Changed in linux (Ubuntu Xenial):
status: In Progress → Invalid
status: Invalid → Fix Released
Changed in linux (Ubuntu):
milestone: xenial-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers