Apple Magic Keyboard A1644 fn key does not work

Bug #1558646 reported by wereturtle on 2016-03-17
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I recently purchased an Apple Magic Keyboard model #A1644 (the newest model). Sadly, the fn key seems to be completely nonfunctional. In other words, I cannot hold down fn+left arrow and get the equivalent of the Home key, etc. It just ignores the fn key and behaves like a left arrow key.

I am on Ubuntu 14.04. version_signature output is:

Ubuntu 3.13.0-37.64-generic 3.13.11.7

Output from running hidd is:

04:69:F8:D5:46:48 Magic Keyboard [004c:0267] connected

FYI, my function keys (F1-F12) work perfectly fine and are not mapping to media keys by default, but I had tried all the suggestions on the Ubuntu wiki anyway (https://help.ubuntu.com/community/AppleKeyboard, "Change Function Key behavior"). Still no go. I suspect this is a kernel issue, since there was a bug report several years ago for back then's latest Apple wireless keyboard that had the same issue, and the kernel just needed a patch for the new device ID. But who knows?

Thanks in advance.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1558646

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.5 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Mansour Behabadi (oxplot) wrote :

There is a difference in how the new Apple Magic Keyboard sends the key data for its Fn key compared to the old keyboard. I've added a comment on the existing kernel bug for this issue [1].

[1]: https://bugzilla.kernel.org/show_bug.cgi?id=99881#c14

niedzielski (niedzielski) wrote :

Same issue on XPS 9560 and MacBookPro11,3 on Ubuntu v16.10, kernel v4.8.0-34-generic

Lakmal Liyanage (ldliy1) wrote :

Same issue (paired with a Nuc Skull Canyon).. Fn key works fine when connected via lightning-to-USB cable. very frustrating... Happy to test or help fix this issue in anyway. Cheers.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.