The mic mute key and led can't work on a Lenovo AIO machine

Bug #1555912 reported by Hui Wang on 2016-03-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Critical
Hui Wang
linux (Ubuntu)
Critical
Hui Wang

Bug Description

Press the mic mute button on the side of the AIO monitor, Mic could not be mute, the LED is off always.

This bug is for tracking purposes; please do not triage.

Hui Wang (hui.wang) on 2016-03-11
Changed in hwe-next:
importance: Undecided → Critical
assignee: nobody → Hui Wang (hui.wang)

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1555912

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hui Wang (hui.wang) wrote :

commit 6ef2f68fa38bf415830f67903d87180d933e0f47
Author: Hui Wang <email address hidden>
Date: Fri Mar 11 12:04:02 2016 +0800

    ALSA: hda - fix the mic mute button and led problem for a Lenovo AIO

    This Lenovo ThinkCentre AIO also uses Line2 as mic mute button and
    uses GPIO2 to control the mic mute led, so applying this quirk can
    make both the button and led work.

    Cc: <email address hidden>
    BugLink: https://bugs.launchpad.net/bugs/1555912
    Signed-off-by: Hui Wang <email address hidden>
    Signed-off-by: Takashi Iwai <email address hidden>

Changed in hwe-next:
status: New → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Kamal Mostafa (kamalmostafa) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
Kamal Mostafa (kamalmostafa) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
Hui Wang (hui.wang) on 2016-04-26
tags: added: verification-done-wily verification-done-xenial
removed: verification-needed-wily verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers