Reliably crash kernel 4.4.0.8-generic by reinstalling all packages and waiting for bind9

Bug #1550755 reported by Mark Shuttleworth
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Xenial
High
Tim Gardner

Bug Description

Hiya

I periodically do a full reinstall of all packages just to see what breaks. Today it's the kernel :) Oddly I have reproduced this on several machines. Simply fire up aptitude, go to "Installed" packages, hit Shift-L to reinstall, then g and g again to kick it off. When I get to bind9 I reliably see this:

Feb 27 17:15:18 maas named[35942]: exiting
Feb 27 17:15:18 maas named[35942]: ../../../lib/isc/mem.c:1229: REQUIRE(ctx->references == 1) failed
Feb 27 17:15:19 maas kernel: [ 1422.530027] ------------[ cut here ]------------
Feb 27 17:15:19 maas kernel: [ 1422.535184] kernel BUG at /build/linux-WmE1Ft/linux-4.4.0/kernel/cred.c:431!
Feb 27 17:15:19 maas kernel: [ 1422.543052] invalid opcode: 0000 [#1] SMP
Feb 27 17:15:19 maas kernel: [ 1422.547637] Modules linked in: ufs qnx4 hfsplus hfs minix ntfs msdos jfs xfs xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack xt_tcpudp bridge stp llc iptable_filter ip_tables x_tables ib_iser rdma_cm iw_cm ib_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi bonding nls_iso8859_1 ipmi_ssif ipmi_devintf intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel dcdbas kvm irqbypass joydev input_leds sb_edac mei_me edac_core mei shpchp lpc_ich ipmi_si ipmi_msghandler 8250_fintek acpi_power_meter mac_hid autofs4 btrfs raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor raid6_pq raid1 raid0 multipath linear uas hid_generic ixgbe usb_storage usbhid bnx2x hid dca vxlan crct10dif_pclmul tg3 ip6_udp_tunnel crc32_pclmul udp_tunnel aesni_intel aes_x86_64 lrw ptp gf128mul glue_helper ablk_helper cryptd pps_core megaraid_sas mdio libcrc32c wmi fjes
Feb 27 17:15:19 maas kernel: [ 1422.647254] CPU: 19 PID: 35942 Comm: named Not tainted 4.4.0-8-generic #23-Ubuntu
Feb 27 17:15:19 maas kernel: [ 1422.655605] Hardware name: Dell Inc. PowerEdge R430/03XKDV, BIOS 1.5.4 10/05/2015
Feb 27 17:15:19 maas kernel: [ 1422.663956] task: ffff88102afa0dc0 ti: ffff881026fe4000 task.ti: ffff881026fe4000
Feb 27 17:15:19 maas kernel: [ 1422.672307] RIP: 0010:[<ffffffff8109fcbd>] [<ffffffff8109fcbd>] commit_creds+0x20d/0x250
Feb 27 17:15:19 maas kernel: [ 1422.681446] RSP: 0018:ffff881026fe7940 EFLAGS: 00010206
Feb 27 17:15:19 maas kernel: [ 1422.687373] RAX: 0000000000000000 RBX: ffff881029224c30 RCX: ffff881032d15c00
Feb 27 17:15:19 maas kernel: [ 1422.695337] RDX: 0000000000000009 RSI: 0000000000000001 RDI: ffff88102aae0180
Feb 27 17:15:19 maas kernel: [ 1422.703299] RBP: ffff881026fe7960 R08: ffff88103d6d9f60 R09: ffff88103cc07c00
Feb 27 17:15:19 maas kernel: [ 1422.711260] R10: ffffea00407be000 R11: 0000000000000000 R12: ffff8810349b0fc0
Feb 27 17:15:19 maas kernel: [ 1422.719222] R13: ffff88102afa0dc0 R14: 00007ffffffff000 R15: ffff881026fe7ad0
Feb 27 17:15:19 maas kernel: [ 1422.727186] FS: 00007fa6a87bb740(0000) GS:ffff88103d6c0000(0000) knlGS:0000000000000000
Feb 27 17:15:19 maas kernel: [ 1422.736215] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 27 17:15:19 maas kernel: [ 1422.742625] CR2: 00007ff0731e1000 CR3: 000000101af82000 CR4: 00000000001406e0
Feb 27 17:15:19 maas kernel: [ 1422.750586] Stack:
Feb 27 17:15:19 maas kernel: [ 1422.752826] 000000008bfc6f2a ffff881029224c30 ffff8810297d1a20 ffff88102aae0180
Feb 27 17:15:19 maas kernel: [ 1422.761113] ffff881026fe7988 ffffffff8137111b ffff881029224c30 ffff880034ae8800
Feb 27 17:15:19 maas kernel: [ 1422.769403] 0000000000000000 ffff881026fe79b0 ffffffff8137b212 ffffffff811e6fea
Feb 27 17:15:19 maas kernel: [ 1422.777691] Call Trace:
Feb 27 17:15:19 maas kernel: [ 1422.780420] [<ffffffff8137111b>] aa_replace_current_label+0xeb/0x140
Feb 27 17:15:19 maas kernel: [ 1422.787609] [<ffffffff8137b212>] apparmor_file_alloc_security+0xc2/0x160
Feb 27 17:15:19 maas kernel: [ 1422.795185] [<ffffffff811e6fea>] ? kmem_cache_alloc+0x1ba/0x1e0
Feb 27 17:15:19 maas kernel: [ 1422.801889] [<ffffffff81337eb3>] security_file_alloc+0x33/0x50
Feb 27 17:15:19 maas kernel: [ 1422.808495] [<ffffffff81209d5a>] get_empty_filp+0x9a/0x1c0
Feb 27 17:15:19 maas kernel: [ 1422.814714] [<ffffffff812163ed>] path_openat+0x3d/0x1280
Feb 27 17:15:19 maas kernel: [ 1422.820738] [<ffffffff810c0a84>] ? __wake_up+0x44/0x50
Feb 27 17:15:19 maas kernel: [ 1422.826569] [<ffffffff8128f08b>] ? ext4_free_inode+0x22b/0x630
Feb 27 17:15:19 maas kernel: [ 1422.833174] [<ffffffff81218801>] do_filp_open+0x91/0x100
Feb 27 17:15:19 maas kernel: [ 1422.839198] [<ffffffff810e4ec7>] ? call_rcu_sched+0x17/0x20
Feb 27 17:15:19 maas kernel: [ 1422.845515] [<ffffffff812b3f1b>] ? ext4_destroy_inode+0x3b/0xa0
Feb 27 17:15:19 maas kernel: [ 1422.852218] [<ffffffff8124a7bc>] ? __fsnotify_inode_delete+0x1c/0x20
Feb 27 17:15:19 maas kernel: [ 1422.859406] [<ffffffff812235d8>] ? destroy_inode+0x38/0x60
Feb 27 17:15:19 maas kernel: [ 1422.865622] [<ffffffff8122372d>] ? evict+0x12d/0x190
Feb 27 17:15:19 maas kernel: [ 1422.871257] [<ffffffff812177a4>] ? putname+0x54/0x60
Feb 27 17:15:19 maas kernel: [ 1422.876892] [<ffffffff81217664>] ? getname_kernel+0x34/0x120
Feb 27 17:15:19 maas kernel: [ 1422.883302] [<ffffffff81207237>] file_open_name+0xf7/0x150
Feb 27 17:15:19 maas kernel: [ 1422.889520] [<ffffffff812072c3>] filp_open+0x33/0x60
Feb 27 17:15:19 maas kernel: [ 1422.895156] [<ffffffff8126a8a1>] do_coredump+0x4c1/0xe90
Feb 27 17:15:19 maas kernel: [ 1422.901178] [<ffffffff81371851>] ? profile_signal_perm.part.4+0xb1/0x110
Feb 27 17:15:19 maas kernel: [ 1422.908754] [<ffffffff8108dec8>] get_signal+0x268/0x600
Feb 27 17:15:19 maas kernel: [ 1422.914681] [<ffffffff81016517>] do_signal+0x37/0x6f0
Feb 27 17:15:19 maas kernel: [ 1422.920413] [<ffffffff8108ccec>] ? do_send_sig_info+0x6c/0xa0
Feb 27 17:15:19 maas kernel: [ 1422.926921] [<ffffffff8100320c>] exit_to_usermode_loop+0x8c/0xd0
Feb 27 17:15:19 maas kernel: [ 1422.933719] [<ffffffff81003c2e>] syscall_return_slowpath+0x4e/0x60
Feb 27 17:15:19 maas kernel: [ 1422.940714] [<ffffffff81813fd0>] int_ret_from_sys_call+0x25/0x8f
Feb 27 17:15:19 maas kernel: [ 1422.947512] Code: ca 48 81 fa 20 25 e4 81 0f 84 6c fe ff ff 48 8b 8a c8 00 00 00 48 39 ce 75 e4 3b 82 d4 00 00 00 0f 84 9a fe ff ff 48 89 f2 eb d6 <0f> 0b 0f 0b e8 2a ed fd ff 49 8b 44 24 30 48 89 c2 f7 d0 48 c1
Feb 27 17:15:19 maas kernel: [ 1422.969091] RIP [<ffffffff8109fcbd>] commit_creds+0x20d/0x250
Feb 27 17:15:19 maas kernel: [ 1422.975608] RSP <ffff881026fe7940>
Feb 27 17:15:19 maas kernel: [ 1422.979523] ---[ end trace 9e5c57f08d29feb8 ]---
---
AlsaDevices:
 total 0
 crw-rw----+ 1 root audio 116, 1 Feb 27 17:37 seq
 crw-rw----+ 1 root audio 116, 33 Feb 27 17:37 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.20-0ubuntu3
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp3', '/dev/dsp2', '/dev/dsp1', '/dev/dsp', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer'] failed with exit code 1:
DistroRelease: Ubuntu 16.04
HibernationDevice: RESUME=UUID=e29b05de-72f8-4cfd-9272-b6087dd6aaf6
MachineType: Dell Inc. PowerEdge R430
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-8-generic.efi.signed root=UUID=52010861-42ec-4375-b2f7-a3fd86f5a1cb ro console=tty0 console=ttyS0,115200n8 nomdmonddf nomdmonisw
ProcVersionSignature: Ubuntu 4.4.0-8.23-generic 4.4.2
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-8-generic N/A
 linux-backports-modules-4.4.0-8-generic N/A
 linux-firmware 1.156
RfKill: Error: [Errno 2] No such file or directory
Tags: xenial
Uname: Linux 4.4.0-8-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 10/05/2015
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.5.4
dmi.board.name: 03XKDV
dmi.board.vendor: Dell Inc.
dmi.board.version: A01
dmi.chassis.type: 23
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.5.4:bd10/05/2015:svnDellInc.:pnPowerEdgeR430:pvr:rvnDellInc.:rn03XKDV:rvrA01:cvnDellInc.:ct23:cvr:
dmi.product.name: PowerEdge R430
dmi.sys.vendor: Dell Inc.

Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1550755

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : CRDA.txt

apport information

tags: added: apport-collected xenial
description: updated
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : IwConfig.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : JournalErrors.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Lspci.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Lsusb.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : ProcModules.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : UdevDb.txt

apport information

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : WifiSyslog.txt

apport information

Brad Figg (brad-figg)
tags: added: kernel-da-key kernel-key
Brad Figg (brad-figg)
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Revision history for this message
Tim Gardner (timg-tpi) wrote :

Stefan Bader was able to reproduce this kernel oops using the server ISO. John Johansen was pretty sure the oops was related to Apparmor. Merging the latest Apparmor fixes that were coincidentally staged for the next upload appears to have corrected the problem. My testing has had positive results. Look for these fixes in linux 4.4.0-9.24.

Changed in linux (Ubuntu Xenial):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 1550755] Re: Reliably crash kernel 4.4.0.8-generic by reinstalling all packages and waiting for bind9

Thanks for the quick triage!

Mark

tags: removed: kernel-key
Tim Gardner (timg-tpi)
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers