Surelock-GA2:kernel panic @ cxl_configure_adapter+0x418/0x8b0

Bug #1546145 reported by bugproxy on 2016-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Wily
Undecided
Tim Gardner
Xenial
Medium
Tim Gardner

Bug Description

== Comment: #18 - Andrew Donnellan - 2016-02-15 20:17:01 ==
Canonical kernel team - please apply 1bc74f1ccd457832dc515fc1febe6655985fdcd2 from the powerpc-fixes tree.

https://git.kernel.org/cgit/linux/kernel/git/powerpc/linux.git/commit/?h=fixes&id=1bc74f1ccd457832dc515fc1febe6655985fdcd2

powerpc/powernv: Fix stale PE primary bus
When PCI bus is unplugged during full hotplug for EEH recovery,
the platform PE instance (struct pnv_ioda_pe) isn't released and
it dereferences the stale PCI bus that has been released. It leads
to kernel crash when referring to the stale PCI bus.

This fixes the issue by correcting the PE's primary bus when it's
oneline at plugging time, in pnv_pci_dma_bus_setup() which is to
be called by pcibios_fixup_bus().

CVE References

bugproxy (bugproxy) on 2016-02-16
tags: added: architecture-ppc64le bugnameltc-134012 severity-critical targetmilestone-inin1604
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
Kevin W. Rudd (kevinr) on 2016-02-16
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → Medium
status: New → Triaged
Tim Gardner (timg-tpi) on 2016-02-16
Changed in linux (Ubuntu Xenial):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: Triaged → Fix Committed
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Brad Figg (brad-figg) on 2016-02-23
Changed in linux (Ubuntu Wily):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.5 KiB)

This bug was fixed in the package linux - 4.4.0-7.22

---------------
linux (4.4.0-7.22) xenial; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1547205

  * need arm64 acpi parking protocol support in xenial (LP: #1547047)
    - [Config] Enabled ARM64_ACPI_PARKING_PROTOCOL
    - arm64: kernel: implement ACPI parking protocol

  * Please pull cgroup namespaces (LP: #1546775)
    - SAUCE: (noup) kernfs: Add API to generate relative kernfs path
    - SAUCE: (noup) sched: new clone flag CLONE_NEWCGROUP for cgroup namespace
    - SAUCE: (noup) cgroup: introduce cgroup namespaces
    - SAUCE: (noup) cgroup: cgroup namespace setns support
    - SAUCE: (noup) kernfs: define kernfs_node_dentry
    - SAUCE: (noup) cgroup: mount cgroupns-root when inside non-init cgroupns
    - SAUCE: (noup) Add FS_USERNS_FLAG to cgroup fs
    - SAUCE: (noup) cgroup: Add documentation for cgroup namespaces

  * [Feature]Pulse-Width Modulation enabling on Broxton-P (LP: #1520436)
    - [Config] CONFIG_PWM_OMAP_DMTIMER=m
    - pwm: lpss: Remove ->free() callback
    - pwm: bcm2835: Calculate scaler in ->config()
    - pwm: bcm2835: Prevent division by zero
    - pwm: bcm2835: Fix email address specification
    - pwm: lpss: Update PWM setting for Broxton
    - pwm: lpss: Select core part automatically
    - pwm: lpss: Rework the sequence of programming PWM_SW_UPDATE
    - pwm: fsl-ftm: Fix clock enable/disable when using PM
    - pwm: lpc32xx: correct number of PWM channels from 2 to 1
    - pwm: lpc32xx: make device usable with common clock framework
    - pwm: lpc32xx: fix and simplify duty cycle and period calculations
    - pwm: lpc32xx: return ERANGE, if requested period is not supported
    - pwm: rcar: Improve accuracy of frequency division setting
    - pwm: Add PWM driver for OMAP using dual-mode timers
    - pwm: add HAS_IOMEM dependency to PWM_FSL_FTM
    - pwm: omap-dmtimer: Potential NULL dereference on error
    - pwm: Mark all devices as "might sleep"

  * [Hyper-V] Netmask value is not parsed by hv_set_ifconfig - IP injection (LP: #1540586)
    - [Debian] hv: hv_set_ifconfig -- switch to approved indentation
    - [Debian] hv: hv_set_ifconfig -- fix numerous parameter handling issues

  * Update megaraid driver to MR6.10 (LP: #1544679)
    - megaraid_sas: Do not allow PCI access during OCR
    - megaraid_sas: MFI IO timeout handling
    - megaraid_sas: Syncing request flags macro names with firmware
    - megaraid_sas: Task management support
    - megaraid_sas: Update device queue depth based on interface type
    - megaraid_sas: Fastpath region lock bypass
    - megaraid_sas: Reply Descriptor Post Queue (RDPQ) support
    - megaraid_sas: Code optimization build_and_issue_cmd return-type
    - megaraid_sas: Dual queue depth support
    - megaraid_sas: IO throttling support
    - megaraid_sas: Make adprecovery variable atomic
    - megaraid_sas: MFI adapter OCR changes
    - megaraid_sas: Introduce module parameter for SCSI command timeout
    - megaraid_sas: SPERC OCR changes
    - megaraid_sas: driver version upgrade
    - megaraid: fix null pointer check in megasas_detach_one().
    - megaraid_sas: Fix for IO failing post OCR in SRI...

Read more...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
bugproxy (bugproxy) on 2016-03-01
tags: added: verification-done-wily
removed: verification-needed-wily
Kevin W. Rudd (kevinr) wrote :

Test worked fine in below level.

Kernel Level:
-------------------------------------------
Linux p8tul13-lp1 4.2.0-32-generic #37-Ubuntu SMP Fri Feb 26 02:20:27 UTC 2016 ppc64le ppc64le ppc64le GNU/Linux
ii linux-generic 4.2.0.32.35 ppc64el Complete Generic Linux kernel and headers
ii linux-headers-4.2.0-32 4.2.0-32.37 all Header files related to Linux kernel version 4.2.0
ii linux-headers-4.2.0-32-generic 4.2.0-32.37 ppc64el Linux kernel headers for version 4.2.0 on PowerPC 64el SMP
ii linux-headers-generic 4.2.0.32.35 ppc64el Generic Linux kernel headers
ii linux-image-4.2.0-32-generic 4.2.0-32.37 ppc64el Linux kernel image for version 4.2.0 on PowerPC 64el SMP
ii linux-image-extra-4.2.0-32-generic 4.2.0-32.37 ppc64el Linux kernel extra modules for version 4.2.0 on PowerPC 64el SMP
ii linux-image-generic 4.2.0.32.35 ppc64el Generic Linux kernel image

Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package linux - 4.2.0-34.39

---------------
linux (4.2.0-34.39) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1555821

  [ Florian Westphal ]

  * SAUCE: [nf] netfilter: x_tables: check for size overflow
    - LP: #1555353
  * SAUCE: [nf,v2] netfilter: x_tables: don't rely on well-behaving
    userspace
    - LP: #1555338

linux (4.2.0-33.38) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1554649

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon: call hpd_irq_event on resume"
    - LP: #1554608
  * cxl: Fix PSL timebase synchronization detection
    - LP: #1532914

linux (4.2.0-32.37) wily; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1550045

  [ Kamal Mostafa ]

  * Merged back Ubuntu-4.2.0-31.36

linux (4.2.0-31.36) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1548579

  [ Andy Whitcroft ]

  * [Debian] hv: hv_set_ifconfig -- convert to python3
    - LP: #1506521
  * [Debian] hv: hv_set_ifconfig -- switch to approved indentation
    - LP: #1540586
  * [Debian] hv: hv_set_ifconfig -- fix numerous parameter handling issues
    - LP: #1540586

  [ Carol L Soto ]

  * SAUCE: IB/IPoIB: Do not set skb truesize since using one linearskb
    - LP: #1541326

  [ Dan Streetman ]

  * SAUCE: nbd: ratelimit error msgs after socket close
    - LP: #1505564

  [ Tim Gardner ]

  * Revert "SAUCE: (noup) cxlflash: Fix to avoid virtual LUN failover
    failure"
    - LP: #1541635
  * Revert "SAUCE: (noup) cxlflash: Fix to escalate LINK_RESET also on port
    1"
    - LP: #1541635
  * [Config] ARMV8_DEPRECATED=y
    - LP: #1545542

  [ Upstream Kernel Changes ]

  * x86/xen/p2m: hint at the last populated P2M entry
    - LP: #1542941
  * mm: add dma_pool_zalloc() call to DMA API
    - LP: #1543737
  * sctp: Prevent soft lockup when sctp_accept() is called during a timeout
    event
    - LP: #1543737
  * xen-netback: respect user provided max_queues
    - LP: #1543737
  * xen-netfront: respect user provided max_queues
    - LP: #1543737
  * xen-netfront: update num_queues to real created
    - LP: #1543737
  * iio: adis_buffer: Fix out-of-bounds memory access
    - LP: #1543737
  * KVM: PPC: Fix emulation of H_SET_DABR/X on POWER8
    - LP: #1543737
  * KVM: PPC: Fix ONE_REG AltiVec support
    - LP: #1543737
  * x86/irq: Call chip->irq_set_affinity in proper context
    - LP: #1543737
  * drm/amdgpu: fix tonga smu resume
    - LP: #1543737
  * perf kvm record/report: 'unprocessable sample' error while
    recording/reporting guest data
    - LP: #1543737
  * hrtimer: Handle remaining time proper for TIME_LOW_RES
    - LP: #1543737
  * timerfd: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * posix-timers: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * itimers: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * drm/amdgpu: Use drm_calloc_large for VM page_tables array
    - LP: #1543737
  * drm/amdgpu: fix amdgpu_bo_pin_restricted VRAM placing v2
    - LP: #1543737
  * drm/radeon: properly byte swap vce firmware setup
    - LP: #1543737
  ...

Read more...

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers