ib1: sendonly multicast join failed for ff12:601b:ffff:0000:0000:0000:0000:0016, status -22 (Multicast)

Bug #1542444 reported by bugproxy on 2016-02-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Wily
Undecided
Tim Gardner
Xenial
Undecided
Tim Gardner

Bug Description

---Problem Description---
ib1: sendonly multicast join failed for ff12:601b:ffff:0000:0000:0000:0000:0016, status -22 (Multicast)

---uname output---
Linux ltcalpine-lp4 4.2.0-21-generic #25~14.04.1-Ubuntu SMP Thu Dec 3 13:55:42 UTC 2015 ppc64le ppc64le ppc64le GNU/Linux

---Steps to Reproduce---
 1. run multicast tests and in the syslog you would find the below error messages

[ 362.785829] ib1: sendonly multicast join failed for ff12:601b:ffff:0000:0000:0000:0000:0016, status -22
[ 364.785811] ib1: sendonly multicast join failed for ff12:601b:ffff:0000:0000:0000:0000:0016, status -22

== Comment: #2 - Carol L. Soto <email address hidden> - 2016-02-05 11:29:07 ==
If I add this set of patches I do not see the messages:
From c3acdc06a95ff20d920220ecb931186b0bb22c42 Mon Sep 17 00:00:00 2001
From: Doug Ledford <email address hidden>
Date: Thu, 3 Sep 2015 17:05:58 -0400
Subject: IB/ipoib: Clean up send-only multicast joins

From d1178cbcdcf91900ccf10a177350d7945703c151 Mon Sep 17 00:00:00 2001
From: Jason Gunthorpe <email address hidden>
Date: Fri, 21 Aug 2015 17:34:13 -0600
Subject: IB/ipoib: Suppress warning for send only join failures

From bd99b2e05c4df2a428e5c9dd338289089d0e26df Mon Sep 17 00:00:00 2001
From: Christoph Lameter <email address hidden>
Date: Thu, 24 Sep 2015 12:00:05 -0500
Subject: IB/ipoib: Expire sendonly multicast joins

From c3852ab0e606212de523c1fb1e15adbf9f431619 Mon Sep 17 00:00:00 2001
From: Doug Ledford <email address hidden>
Date: Fri, 25 Sep 2015 14:35:01 -0400
Subject: IB/ipoib: Make sendonly multicast joins create the mcast group

From 2866196f294954ce9fa226825c8c1eaa64c7da8a Mon Sep 17 00:00:00 2001
From: Doug Ledford <email address hidden>
Date: Fri, 25 Sep 2015 22:30:24 -0400
Subject: IB/ipoib: increase the max mcast backlog queue

From 0b5c9279e568d90903acedc2b9b832d8d78e8288 Mon Sep 17 00:00:00 2001
From: Christoph Lameter <email address hidden>
Date: Sun, 11 Oct 2015 18:49:42 -0500
Subject: IB/ipoib: For sendonly join free the multicast group on leave

CVE References

bugproxy (bugproxy) on 2016-02-05
tags: added: architecture-ppc64le bugnameltc-136652 severity-low targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
Kevin W. Rudd (kevinr) on 2016-02-05
affects: ubuntu → linux (Ubuntu)
Tim Gardner (timg-tpi) on 2016-02-05
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Xenial):
assignee: Taco Screen team (taco-screen-team) → Tim Gardner (timg-tpi)
status: New → Fix Released
Changed in linux (Ubuntu Wily):
status: In Progress → Fix Committed
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
bugproxy (bugproxy) on 2016-02-25
tags: added: targetmilestone-inin14044
removed: targetmilestone-inin---

------- Comment From <email address hidden> 2016-02-29 10:01 EDT-------
(In reply to comment #8)
> This bug is awaiting verification that the kernel in -proposed solves the
> problem. Please test the kernel and update this bug with the results. If the
> problem is solved, change the tag 'verification-needed-wily' to
> 'verification-done-wily'.
>
> If verification is not done by 5 working days from today, this fix will be
> dropped from the source code, and this bug will be closed.
>
> See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you!

To verify this issue we need the wily kernel.

bugproxy (bugproxy) on 2016-03-07
tags: added: verification-done-wily
removed: verification-needed-wily
Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package linux - 4.2.0-34.39

---------------
linux (4.2.0-34.39) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1555821

  [ Florian Westphal ]

  * SAUCE: [nf] netfilter: x_tables: check for size overflow
    - LP: #1555353
  * SAUCE: [nf,v2] netfilter: x_tables: don't rely on well-behaving
    userspace
    - LP: #1555338

linux (4.2.0-33.38) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1554649

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon: call hpd_irq_event on resume"
    - LP: #1554608
  * cxl: Fix PSL timebase synchronization detection
    - LP: #1532914

linux (4.2.0-32.37) wily; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1550045

  [ Kamal Mostafa ]

  * Merged back Ubuntu-4.2.0-31.36

linux (4.2.0-31.36) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1548579

  [ Andy Whitcroft ]

  * [Debian] hv: hv_set_ifconfig -- convert to python3
    - LP: #1506521
  * [Debian] hv: hv_set_ifconfig -- switch to approved indentation
    - LP: #1540586
  * [Debian] hv: hv_set_ifconfig -- fix numerous parameter handling issues
    - LP: #1540586

  [ Carol L Soto ]

  * SAUCE: IB/IPoIB: Do not set skb truesize since using one linearskb
    - LP: #1541326

  [ Dan Streetman ]

  * SAUCE: nbd: ratelimit error msgs after socket close
    - LP: #1505564

  [ Tim Gardner ]

  * Revert "SAUCE: (noup) cxlflash: Fix to avoid virtual LUN failover
    failure"
    - LP: #1541635
  * Revert "SAUCE: (noup) cxlflash: Fix to escalate LINK_RESET also on port
    1"
    - LP: #1541635
  * [Config] ARMV8_DEPRECATED=y
    - LP: #1545542

  [ Upstream Kernel Changes ]

  * x86/xen/p2m: hint at the last populated P2M entry
    - LP: #1542941
  * mm: add dma_pool_zalloc() call to DMA API
    - LP: #1543737
  * sctp: Prevent soft lockup when sctp_accept() is called during a timeout
    event
    - LP: #1543737
  * xen-netback: respect user provided max_queues
    - LP: #1543737
  * xen-netfront: respect user provided max_queues
    - LP: #1543737
  * xen-netfront: update num_queues to real created
    - LP: #1543737
  * iio: adis_buffer: Fix out-of-bounds memory access
    - LP: #1543737
  * KVM: PPC: Fix emulation of H_SET_DABR/X on POWER8
    - LP: #1543737
  * KVM: PPC: Fix ONE_REG AltiVec support
    - LP: #1543737
  * x86/irq: Call chip->irq_set_affinity in proper context
    - LP: #1543737
  * drm/amdgpu: fix tonga smu resume
    - LP: #1543737
  * perf kvm record/report: 'unprocessable sample' error while
    recording/reporting guest data
    - LP: #1543737
  * hrtimer: Handle remaining time proper for TIME_LOW_RES
    - LP: #1543737
  * timerfd: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * posix-timers: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * itimers: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * drm/amdgpu: Use drm_calloc_large for VM page_tables array
    - LP: #1543737
  * drm/amdgpu: fix amdgpu_bo_pin_restricted VRAM placing v2
    - LP: #1543737
  * drm/radeon: properly byte swap vce firmware setup
    - LP: #1543737
  ...

Read more...

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
bugproxy (bugproxy) on 2016-09-30
tags: removed: verification-done-wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers