Backport upstream cxlflash commits to Ubuntu 15.10 (Wily) SRU stream

Bug #1541635 reported by bugproxy on 2016-02-03
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Wily
Undecided
Tim Gardner
Xenial
Medium
Tim Gardner

Bug Description

== Comment: #0 - UMA KRISHNAN <email address hidden> - 2016-02-03 16:41:26 ==

The following fixes for cxlflash are upstreamed as of 4.5-rc1, please backport them to Wily SRU stream:

b45cdbaf9f7f0486847c52f60747fb108724652a cxlflash: Resolve oops in wait_port_offline

ee91e332a6e6e9b939f60f6e1bd72fb2def5290d cxlflash: Fix to resolve cmd leak after host reset

85599218914dadad3347eaa4337e71f09f39e78f cxlflash: Removed driver date print

21891a452a42afc2313f1e3a69040e46c1d068c1 cxlflash: drop unlikely before IS_ERR_OR_NULL

f2dd80ecca5f06b46134f2bd811f046c503c756c powerpc/powernv: Panic on unhandled Machine Check

As an FYI, these 2 fixes were also upstreamed but are already present in the Wily SRU stream (they were accepted by Canonical as SAUCE/noup):

d5e26bb1d812ba74f29b6bcbc88c3dbfb3eed824 cxlflash: Fix to avoid virtual LUN failover failure

a9be294ecb3b9dc82b15625631b153f871181d16 cxlflash: Fix to escalate LINK_RESET also on port 1

CVE References

bugproxy (bugproxy) on 2016-02-03
tags: added: architecture-ppc64le bugnameltc-136562 severity-medium targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)
Kevin W. Rudd (kevinr) on 2016-02-03
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → Medium
status: New → Triaged
Tim Gardner (timg-tpi) wrote :

cxl: Fix possible idr warning when contexts are released
cxl: use correct operator when writing pcie config space values
cxlflash: drop unlikely before IS_ERR_OR_NULL
cxl: Fix DSI misses when the context owning task exits
cxlflash: Removed driver date print
cxlflash: Fix to resolve cmd leak after host reset
cxlflash: Resolve oops in wait_port_offline
cxlflash: Enable device id for future IBM CXL adapter
cxl: fix build for GCC 4.6.x
cxl: use -Werror only with CONFIG_PPC_WERROR
cxl: Enable PCI device ID for future IBM CXL adapter

Changed in linux (Ubuntu Xenial):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: Triaged → Fix Committed
Tim Gardner (timg-tpi) on 2016-02-04
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Wily):
status: In Progress → Fix Committed
bugproxy (bugproxy) on 2016-02-12
tags: added: targetmilestone-inin1510
removed: targetmilestone-inin---
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
Uma Krishnan (ukrishn) on 2016-02-25
description: updated
tags: added: verification-done-wily
removed: verification-needed-wily

------- Comment From <email address hidden> 2016-02-25 18:31 EDT-------
I have verified that Wily SRU has the patches I requested. I have modified the tag to verification-done-wily.

Thanks !

Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package linux - 4.2.0-34.39

---------------
linux (4.2.0-34.39) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1555821

  [ Florian Westphal ]

  * SAUCE: [nf] netfilter: x_tables: check for size overflow
    - LP: #1555353
  * SAUCE: [nf,v2] netfilter: x_tables: don't rely on well-behaving
    userspace
    - LP: #1555338

linux (4.2.0-33.38) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1554649

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon: call hpd_irq_event on resume"
    - LP: #1554608
  * cxl: Fix PSL timebase synchronization detection
    - LP: #1532914

linux (4.2.0-32.37) wily; urgency=low

  [ Kamal Mostafa ]

  * Release Tracking Bug
    - LP: #1550045

  [ Kamal Mostafa ]

  * Merged back Ubuntu-4.2.0-31.36

linux (4.2.0-31.36) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1548579

  [ Andy Whitcroft ]

  * [Debian] hv: hv_set_ifconfig -- convert to python3
    - LP: #1506521
  * [Debian] hv: hv_set_ifconfig -- switch to approved indentation
    - LP: #1540586
  * [Debian] hv: hv_set_ifconfig -- fix numerous parameter handling issues
    - LP: #1540586

  [ Carol L Soto ]

  * SAUCE: IB/IPoIB: Do not set skb truesize since using one linearskb
    - LP: #1541326

  [ Dan Streetman ]

  * SAUCE: nbd: ratelimit error msgs after socket close
    - LP: #1505564

  [ Tim Gardner ]

  * Revert "SAUCE: (noup) cxlflash: Fix to avoid virtual LUN failover
    failure"
    - LP: #1541635
  * Revert "SAUCE: (noup) cxlflash: Fix to escalate LINK_RESET also on port
    1"
    - LP: #1541635
  * [Config] ARMV8_DEPRECATED=y
    - LP: #1545542

  [ Upstream Kernel Changes ]

  * x86/xen/p2m: hint at the last populated P2M entry
    - LP: #1542941
  * mm: add dma_pool_zalloc() call to DMA API
    - LP: #1543737
  * sctp: Prevent soft lockup when sctp_accept() is called during a timeout
    event
    - LP: #1543737
  * xen-netback: respect user provided max_queues
    - LP: #1543737
  * xen-netfront: respect user provided max_queues
    - LP: #1543737
  * xen-netfront: update num_queues to real created
    - LP: #1543737
  * iio: adis_buffer: Fix out-of-bounds memory access
    - LP: #1543737
  * KVM: PPC: Fix emulation of H_SET_DABR/X on POWER8
    - LP: #1543737
  * KVM: PPC: Fix ONE_REG AltiVec support
    - LP: #1543737
  * x86/irq: Call chip->irq_set_affinity in proper context
    - LP: #1543737
  * drm/amdgpu: fix tonga smu resume
    - LP: #1543737
  * perf kvm record/report: 'unprocessable sample' error while
    recording/reporting guest data
    - LP: #1543737
  * hrtimer: Handle remaining time proper for TIME_LOW_RES
    - LP: #1543737
  * timerfd: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * posix-timers: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * itimers: Handle relative timers with CONFIG_TIME_LOW_RES proper
    - LP: #1543737
  * drm/amdgpu: Use drm_calloc_large for VM page_tables array
    - LP: #1543737
  * drm/amdgpu: fix amdgpu_bo_pin_restricted VRAM placing v2
    - LP: #1543737
  * drm/radeon: properly byte swap vce firmware setup
    - LP: #1543737
  ...

Read more...

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) wrote :

UBUNTU: Ubuntu-4.4.0-4.18

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers