The lpfc driver is at rev 11.0.0.0 and needs to be at 11.0.0.10

Bug #1541592 reported by Dick Kennedy on 2016-02-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Tim Gardner
Xenial
Undecided
Tim Gardner

Bug Description

Brian here are the commit ids between 11.0.0.0 and 11.0.0.10.
The one with the comment after it is not from avago it is from kernel.org only take it if your kernel changed the blk_use_tag api.

e79504236548e4c909959ba444f87a12224555ac
64d513ac31bd02a3c9b69ef04444f36c196f9a9d /* THis one you may not need, it was from the upstream community */
f5cb5304eb26d307c9b30269fb0e007e0b262b7d
d6de08cc46269899988b4f40acc7337279693d4b
4b7789b71c916f79a3366da080101014473234c3
6690e0d4fc5cccf74534abe0c9f9a69032bc02f0
c90261dcd86e4eb5c9c1627fde037e902db8aefa
4258e98ee3862ca7036654b43c839ab7668043e0
81e7517723fc17396ba91f59312b3177266ddbda
eb8d68c9930f7f9c8f3f4a6059b051b32077a735
5afab6bbf3f026b7d50451acbfdc12300c5f4353
a085e87c814567c94e5d375e7362f9f25030aac1
01c73bbcd7cc4f31f45a1b0caeacdba46acd9c9c
4360ca9c24388e44cb0e14861a62fff43cf225c0
448193b5b5e2471fc90ea11e78c39bcfd167efb6
9be321819c43417432a8376428b90fe3fe3a3510
699acd6220ea5b20b25d5eec0ab448827d745357
b034573c7eb39aa58cd4a08e487869fea6d4ad2d

===
Kernel-Description: Update lpfc driver to 11.0.0.10

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1541592

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
status: Incomplete → Triaged
Tim Gardner (timg-tpi) on 2016-02-04
Changed in linux (Ubuntu Xenial):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Tim Gardner (timg-tpi) wrote :

lpfc: Fix FCF Infinite loop in lpfc_sli4_fcf_rr_next_index_get.
lpfc: Fix the FLOGI discovery logic to comply with T11 standards
lpfc: Fix RegLogin failed error seen on Lancer FC during port bounce
lpfc: Fix driver crash when module parameter lpfc_fcp_io_channel set to 16
lpfc: Fix crash in fcp command completion path.
lpfc: Modularize and cleanup FDMI code in driver
lpfc: Fix RDP Speed reporting.
lpfc: Fix RDP ACC being too long.
lpfc: Make write check error processing more resilient
lpfc: Use new FDMI speed definitions for 10G, 25G and 40G FCoE.
lpfc: Fix mbox reuse in PLOGI completion
lpfc: Fix external loopback failure.
lpfc: Add logging for misconfigured optics.
lpfc: Delete unnecessary checks before the function call "mempool_destroy"
lpfc: Use kzalloc instead of kmalloc
lpfc: Update version to 11.0.0.10 for upstream patch set

Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Andy Whitcroft (apw) on 2016-02-05
description: updated
Andy Whitcroft (apw) on 2016-02-05
description: updated
Andy Whitcroft (apw) on 2016-02-05
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (4.0 KiB)

This bug was fixed in the package linux - 4.4.0-4.19

---------------
linux (4.4.0-4.19) xenial; urgency=low

  * update ZFS and SPL to 0.6.5.4 (LP: #1542296)
    - [Config] update spl/zfs version
    - SAUCE: (noup) Update spl to 0.6.5.4-0ubuntu2, zfs to 0.6.5.4-0ubuntu1
    - [Config] reconstruct -- drop links for zfs userspace components
    - [Config] reconstruct -- drop links for zfs userspace components -- restore spec links

  * recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. (LP: #1540731)
    - Revert "af_unix: Revert 'lock_interruptible' in stream receive code"

  * lxc: ADT exercise test failing with linux-4.4.0-3.17 (LP: #1542049)
    - Revert "UBUNTU: SAUCE: apparmor: fix sleep from invalid context"

  * WARNING: at /build/linux-lts-wily-W0lTWH/linux-lts-wily-4.2.0/net/core/skbuff.c:4174 (Travis IB) (LP: #1541326)
    - SAUCE: IB/IPoIB: Do not set skb truesize since using one linearskb

  * backport Microsoft Precision Touchpad palm rejection patch (LP: #1541671)
    - HID: multitouch: enable palm rejection if device implements confidence usage

  * [Ubuntu 16.04] Update qla2xxx driver for POWER (QLogic) (LP: #1541456)
    - qla2xxx: Remove unavailable firmware files
    - qla2xxx: Enable Extended Logins support
    - qla2xxx: Enable Exchange offload support.
    - qla2xxx: Enable Target counters in DebugFS.
    - qla2xxx: Add FW resource count in DebugFS.
    - qla2xxx: Added interface to send explicit LOGO.
    - qla2xxx: Delete session if initiator is gone from FW
    - qla2xxx: Wait for all conflicts before ack'ing PLOGI
    - qla2xxx: Replace QLA_TGT_STATE_ABORTED with a bit.
    - qla2xxx: Remove dependency on hardware_lock to reduce lock contention.
    - qla2xxx: Add irq affinity notification
    - qla2xxx: Add selective command queuing
    - qla2xxx: Move atioq to a different lock to reduce lock contention
    - qla2xxx: Disable ZIO at start time.
    - qla2xxx: Set all queues to 4k
    - qla2xxx: Check for online flag instead of active reset when transmitting responses
    - scsi: qla2xxxx: avoid type mismatch in comparison

  * [Hyper-V] PCI Passthrough (LP: #1541120)
    - x86/irq: Export functions to allow MSI domains in modules
    - genirq/msi: Export functions to allow MSI domains in modules

  * Update lpfc driver to 11.0.0.10 (LP: #1541592)
    - lpfc: Fix FCF Infinite loop in lpfc_sli4_fcf_rr_next_index_get.
    - lpfc: Fix the FLOGI discovery logic to comply with T11 standards
    - lpfc: Fix RegLogin failed error seen on Lancer FC during port bounce
    - lpfc: Fix driver crash when module parameter lpfc_fcp_io_channel set to 16
    - lpfc: Fix crash in fcp command completion path.
    - lpfc: Modularize and cleanup FDMI code in driver
    - lpfc: Fix RDP Speed reporting.
    - lpfc: Fix RDP ACC being too long.
    - lpfc: Make write check error processing more resilient
    - lpfc: Use new FDMI speed definitions for 10G, 25G and 40G FCoE.
    - lpfc: Fix mbox reuse in PLOGI completion
    - lpfc: Fix external loopback failure.
    - lpfc: Add logging for misconfigured optics.
    - lpfc: Delete unnecessary checks before the function call "mempool_destroy"
    - lpfc: Use kzalloc instead of kmalloc
...

Read more...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers