[Ubuntu 16.04] Update qla2xxx driver for POWER (QLogic)

Bug #1541456 reported by bugproxy on 2016-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Tim Gardner
Xenial
High
Tim Gardner

Bug Description

Hi Canonical Kernel Team,

Please cherry-pick these commits between v4.4 and v4.5-rc2 into Xenial.

Thanks!

$ git log --oneline v4.4..v4.5-rc2 -- drivers/scsi/qla2xxx/
71e4634 Merge branch 'for-next' of git://git.kernel.org/pub/scm/linux/kernel/git/nab/target-pending
fab683e scsi: qla2xxxx: avoid type mismatch in comparison
abaee09 Merge branch 'jejb-scsi' into misc
3bb67df qla2xxx: Check for online flag instead of active reset when transmitting responses
e7b42e3 qla2xxx: Set all queues to 4k
481ce73 qla2xxx: Disable ZIO at start time.
2f424b9 qla2xxx: Move atioq to a different lock to reduce lock contention
fb3269b qla2xxx: Add selective command queuing
cdb898c qla2xxx: Add irq affinity notification
7560151 qla2xxx: Remove dependency on hardware_lock to reduce lock contention.
193b50b qla2xxx: Replace QLA_TGT_STATE_ABORTED with a bit.
b7bd104 qla2xxx: Wait for all conflicts before ack'ing PLOGI
71cdc07 qla2xxx: Delete session if initiator is gone from FW
6eb5471 qla2xxx: Added interface to send explicit LOGO.
03e8c68 qla2xxx: Add FW resource count in DebugFS.
ce1025c qla2xxx: Enable Target counters in DebugFS.
2f56a7f qla2xxx: Enable Exchange offload support.
b0d6cab qla2xxx: Enable Extended Logins support
940a7f0 qla2xxx: Remove unavailable firmware files

bugproxy (bugproxy) on 2016-02-03
tags: added: architecture-ppc64le bugnameltc-132387 severity-high targetmilestone-inin1604
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1541456/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → High
status: New → Triaged
Tim Gardner (timg-tpi) on 2016-02-04
Changed in linux (Ubuntu Xenial):
assignee: Canonical Kernel Team (canonical-kernel-team) → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Tim Gardner (timg-tpi) wrote :

qla2xxx: Remove unavailable firmware files
qla2xxx: Enable Extended Logins support
qla2xxx: Enable Exchange offload support.
qla2xxx: Enable Target counters in DebugFS.
qla2xxx: Add FW resource count in DebugFS.
qla2xxx: Added interface to send explicit LOGO.
qla2xxx: Delete session if initiator is gone from FW
qla2xxx: Wait for all conflicts before ack'ing PLOGI
qla2xxx: Replace QLA_TGT_STATE_ABORTED with a bit.
qla2xxx: Remove dependency on hardware_lock to reduce lock contention.
qla2xxx: Add irq affinity notification
qla2xxx: Add selective command queuing
qla2xxx: Move atioq to a different lock to reduce lock contention
qla2xxx: Disable ZIO at start time.
qla2xxx: Set all queues to 4k
qla2xxx: Check for online flag instead of active reset when transmitting responses
scsi: qla2xxxx: avoid type mismatch in comparison

Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.0 KiB)

This bug was fixed in the package linux - 4.4.0-4.19

---------------
linux (4.4.0-4.19) xenial; urgency=low

  * update ZFS and SPL to 0.6.5.4 (LP: #1542296)
    - [Config] update spl/zfs version
    - SAUCE: (noup) Update spl to 0.6.5.4-0ubuntu2, zfs to 0.6.5.4-0ubuntu1
    - [Config] reconstruct -- drop links for zfs userspace components
    - [Config] reconstruct -- drop links for zfs userspace components -- restore spec links

  * recvmsg() fails SCM_CREDENTIALS request with EOPNOTSUPP. (LP: #1540731)
    - Revert "af_unix: Revert 'lock_interruptible' in stream receive code"

  * lxc: ADT exercise test failing with linux-4.4.0-3.17 (LP: #1542049)
    - Revert "UBUNTU: SAUCE: apparmor: fix sleep from invalid context"

  * WARNING: at /build/linux-lts-wily-W0lTWH/linux-lts-wily-4.2.0/net/core/skbuff.c:4174 (Travis IB) (LP: #1541326)
    - SAUCE: IB/IPoIB: Do not set skb truesize since using one linearskb

  * backport Microsoft Precision Touchpad palm rejection patch (LP: #1541671)
    - HID: multitouch: enable palm rejection if device implements confidence usage

  * [Ubuntu 16.04] Update qla2xxx driver for POWER (QLogic) (LP: #1541456)
    - qla2xxx: Remove unavailable firmware files
    - qla2xxx: Enable Extended Logins support
    - qla2xxx: Enable Exchange offload support.
    - qla2xxx: Enable Target counters in DebugFS.
    - qla2xxx: Add FW resource count in DebugFS.
    - qla2xxx: Added interface to send explicit LOGO.
    - qla2xxx: Delete session if initiator is gone from FW
    - qla2xxx: Wait for all conflicts before ack'ing PLOGI
    - qla2xxx: Replace QLA_TGT_STATE_ABORTED with a bit.
    - qla2xxx: Remove dependency on hardware_lock to reduce lock contention.
    - qla2xxx: Add irq affinity notification
    - qla2xxx: Add selective command queuing
    - qla2xxx: Move atioq to a different lock to reduce lock contention
    - qla2xxx: Disable ZIO at start time.
    - qla2xxx: Set all queues to 4k
    - qla2xxx: Check for online flag instead of active reset when transmitting responses
    - scsi: qla2xxxx: avoid type mismatch in comparison

  * [Hyper-V] PCI Passthrough (LP: #1541120)
    - x86/irq: Export functions to allow MSI domains in modules
    - genirq/msi: Export functions to allow MSI domains in modules

  * Update lpfc driver to 11.0.0.10 (LP: #1541592)
    - lpfc: Fix FCF Infinite loop in lpfc_sli4_fcf_rr_next_index_get.
    - lpfc: Fix the FLOGI discovery logic to comply with T11 standards
    - lpfc: Fix RegLogin failed error seen on Lancer FC during port bounce
    - lpfc: Fix driver crash when module parameter lpfc_fcp_io_channel set to 16
    - lpfc: Fix crash in fcp command completion path.
    - lpfc: Modularize and cleanup FDMI code in driver
    - lpfc: Fix RDP Speed reporting.
    - lpfc: Fix RDP ACC being too long.
    - lpfc: Make write check error processing more resilient
    - lpfc: Use new FDMI speed definitions for 10G, 25G and 40G FCoE.
    - lpfc: Fix mbox reuse in PLOGI completion
    - lpfc: Fix external loopback failure.
    - lpfc: Add logging for misconfigured optics.
    - lpfc: Delete unnecessary checks before the function call "mempool_destroy"
    - lpfc: Use kzalloc instead of kmalloc
...

Read more...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) wrote :

git log --oneline v4.5-rc2..v4.5-rc6 -- drivers/scsi/qla2xxx/
5327c7d qla2xxx: use TARGET_SCF_USE_CPUID flag to indiate CPU Affinity
d7236ac qla2xxx: Use ATIO type to send correct tmr response
cb43285 qla2xxx: Fix stale pointer access.
a07100e qla2xxx: Fix TMR ABORT interaction issue between qla2xxx and TCM
dacb582 qla2xxx: Fix warning reported by static checker

Changed in linux (Ubuntu Xenial):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (20.9 KiB)

This bug was fixed in the package linux - 4.4.0-11.26

---------------
linux (4.4.0-11.26) xenial; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1553391

  * Xenial update to v4.4.4 stable release (LP: #1553179)
    - af_iucv: Validate socket address length in iucv_sock_bind()
    - gro: Make GRO aware of lightweight tunnels.
    - net: dp83640: Fix tx timestamp overflow handling.
    - tunnels: Allow IPv6 UDP checksums to be correctly controlled.
    - lwt: fix rx checksum setting for lwt devices tunneling over ipv6
    - tcp: fix NULL deref in tcp_v4_send_ack()
    - af_unix: fix struct pid memory leak
    - pptp: fix illegal memory access caused by multiple bind()s
    - sctp: allow setting SCTP_SACK_IMMEDIATELY by the application
    - net: dsa: fix mv88e6xxx switches
    - tipc: fix connection abort during subscription cancel
    - inet: frag: Always orphan skbs inside ip_defrag()
    - switchdev: Require RTNL mutex to be held when sending FDB notifications
    - tcp: beware of alignments in tcp_get_info()
    - ipv6: enforce flowi6_oif usage in ip6_dst_lookup_tail()
    - ipv6/udp: use sticky pktinfo egress ifindex on connect()
    - ipv6: addrconf: Fix recursive spin lock call
    - ipv6: fix a lockdep splat
    - unix: correctly track in-flight fds in sending process user_struct
    - tcp: do not drop syn_recv on all icmp reports
    - net:Add sysctl_max_skb_frags
    - tg3: Fix for tg3 transmit queue 0 timed out when too many gso_segs
    - enic: increment devcmd2 result ring in case of timeout
    - sctp: translate network order to host order when users get a hmacid
    - net: Copy inner L3 and L4 headers as unaligned on GRE TEB
    - flow_dissector: Fix unaligned access in __skb_flow_dissector when used by
      eth_get_headlen
    - bpf: fix branch offset adjustment on backjumps after patching ctx expansion
    - bonding: Fix ARP monitor validation
    - ipv4: fix memory leaks in ip_cmsg_send() callers
    - af_unix: Don't set err in unix_stream_read_generic unless there was an error
    - af_unix: Guard against other == sk in unix_dgram_sendmsg
    - tipc: fix premature addition of node to lookup table
    - tcp: md5: release request socket instead of listener
    - qmi_wwan: add "4G LTE usb-modem U901"
    - net/mlx4_en: Count HW buffer overrun only once
    - net/mlx4_en: Avoid changing dev->features directly in run-time
    - l2tp: Fix error creating L2TP tunnels
    - pppoe: fix reference counting in PPPoE proxy
    - net_sched fix: reclassification needs to consider ether protocol changes
    - route: check and remove route cache when we get route
    - tcp/dccp: fix another race at listener dismantle
    - IFF_NO_QUEUE: Fix for drivers not calling ether_setup()
    - rtnl: RTM_GETNETCONF: fix wrong return value
    - tipc: unlock in error path
    - unix_diag: fix incorrect sign extension in unix_lookup_by_ino
    - sctp: Fix port hash table size computation
    - ext4: fix bh->b_state corruption
    - ARM: debug-ll: fix BCM63xx entry for multiplatform
    - arm64: errata: Add -mpc-relative-literal-loads to build flags
    - KVM: s390: fix guest fprs memory leak
    - devm_memremap: Fix error value whe...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers