BUG: soft lockup detected on CPU#0! with cifs

Bug #153855 reported by jcdutton on 2007-10-18
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Critical
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-image-2.6.15-29-server

I get a lock up when using CIFS.
The following output was captured via the console port.
During the lock up, ping works to the box, but sshd or any other higher level service does not work.

[42951888.400000] CIFS VFS: Calculated size 0x27 vs actual length 0x48
[42951888.420000] CIFS VFS: bad smb size detected for Mid=15525
[42951889.400000] CIFS VFS: Calculated size 0x27 vs actual length 0x48
[42951889.420000] CIFS VFS: bad smb size detected for Mid=15625
[42951953.200000] CIFS VFS: Calculated size 0x27 vs actual length 0x48
[42951953.220000] CIFS VFS: bad smb size detected for Mid=21731
[42955494.580000] CIFS VFS: Calculated size 0x27 vs actual length 0x48
[42955494.600000] CIFS VFS: bad smb size detected for Mid=16670
[42955496.100000] CIFS VFS: Calculated size 0x27 vs actual length 0x48
[42955496.120000] CIFS VFS: bad smb size detected for Mid=17181
[42955584.780000] CIFS VFS: Calculated size 0x27 vs actual length 0x48
[42955584.800000] CIFS VFS: bad smb size detected for Mid=48076
[42957738.790000] BUG: soft lockup detected on CPU#0!
[42957738.790000]
[42957738.790000] Pid: 4505, comm: rsync
[42957738.790000] EIP: 0060:[<c017cd3a>] CPU: 0
[42957738.790000] EIP is at generic_fillattr+0x8a/0xb0
[42957738.790000] EFLAGS: 00000202 Not tainted (2.6.15-29-server)
[42957738.790000] EAX: 00000009 EBX: 00320000 ECX: 00000009 EDX: 00000009
[42957738.790000] ESI: 00000000 EDI: dda5e378 EBP: f7541f70 DS: 007b ES: 007b
[42957738.790000] CR0: 8005003b CR2: b7966004 CR3: 1fae1820 CR4: 000006b0
[42957738.790000] [<f8b2c730>] cifs_getattr+0x30/0x40 [cifs]
[42957738.790000] [<c017cf49>] vfs_fstat+0x39/0x50
[42957738.790000] [<c017d618>] sys_fstat64+0x18/0x40
[42957738.790000] [<c01718e6>] do_sys_open+0xd6/0x100
[42957738.790000] [<c0103313>] sysenter_past_esp+0x54/0x75
[42957748.800000] BUG: soft lockup detected on CPU#0!
[42957748.800000]
[42957748.800000] Pid: 4505, comm: rsync
[42957748.800000] EIP: 0060:[<c017cd2a>] CPU: 0
[42957748.800000] EIP is at generic_fillattr+0x7a/0xb0
[42957748.800000] EFLAGS: 00000202 Not tainted (2.6.15-29-server)
[42957748.800000] EAX: 00000009 EBX: 00320000 ECX: 00000009 EDX: 00000001
[42957748.800000] ESI: 00000000 EDI: dda5e378 EBP: f7541f70 DS: 007b ES: 007b
[42957748.800000] CR0: 8005003b CR2: b7966004 CR3: 1fae1820 CR4: 000006b0
[42957748.800000] [<f8b2c730>] cifs_getattr+0x30/0x40 [cifs]
[42957748.800000] [<c017cf49>] vfs_fstat+0x39/0x50
[42957748.800000] [<c017d618>] sys_fstat64+0x18/0x40
[42957748.800000] [<c01718e6>] do_sys_open+0xd6/0x100
[42957748.800000] [<c0103313>] sysenter_past_esp+0x54/0x75
[42957758.810000] BUG: soft lockup detected on CPU#0!
[42957758.810000]
[42957758.810000] Pid: 4505, comm: rsync
[42957758.810000] EIP: 0060:[<c017cd25>] CPU: 0
[42957758.810000] EIP is at generic_fillattr+0x75/0xb0
[42957758.810000] EFLAGS: 00000202 Not tainted (2.6.15-29-server)
[42957758.810000] EAX: 00000009 EBX: 00320000 ECX: 00000009 EDX: 00000001
[42957758.810000] ESI: 00000000 EDI: dda5e378 EBP: f7541f70 DS: 007b ES: 007b
[42957758.810000] CR0: 8005003b CR2: b7966004 CR3: 1fae1820 CR4: 000006b0
[42957758.810000] [<f8b2c730>] cifs_getattr+0x30/0x40 [cifs]
[42957758.810000] [<c017cf49>] vfs_fstat+0x39/0x50
[42957758.810000] [<c017d618>] sys_fstat64+0x18/0x40
[42957758.810000] [<c01718e6>] do_sys_open+0xd6/0x100
[42957758.810000] [<c0103313>] sysenter_past_esp+0x54/0x75
[42957768.820000] BUG: soft lockup detected on CPU#0!
[42957768.820000]
[42957768.820000] Pid: 4505, comm: rsync
[42957768.820000] EIP: 0060:[<c017cd30>] CPU: 0
[42957768.820000] EIP is at generic_fillattr+0x80/0xb0
[42957768.820000] EFLAGS: 00000202 Not tainted (2.6.15-29-server)
[42957768.820000] EAX: 00000009 EBX: 00320000 ECX: 00000009 EDX: 00000001
[42957768.820000] ESI: 00000000 EDI: dda5e378 EBP: f7541f70 DS: 007b ES: 007b
[42957768.820000] CR0: 8005003b CR2: b7966004 CR3: 1fae1820 CR4: 000006b0
[42957768.820000] [<f8b2c730>] cifs_getattr+0x30/0x40 [cifs]
[42957768.820000] [<c017cf49>] vfs_fstat+0x39/0x50
[42957768.820000] [<c017d618>] sys_fstat64+0x18/0x40
[42957768.820000] [<c01718e6>] do_sys_open+0xd6/0x100
[42957768.820000] [<c0103313>] sysenter_past_esp+0x54/0x75

With many more similar reports.

Changed in linux:
status: Unknown → Confirmed

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

Hi jcdutton,

Can you confirm this is still an issue with the most recent Hardy Heron 8.04 LTS release. And subsequently if this is an issue with Hardy, care to test the latest Alpha available for the upcoming Intrepid Ibex 8.10 release? Please let us know your results. Thanks.

Changed in linux:
status: New → Incomplete
jcdutton (james-superbug) wrote :

This CIFS bug was fixed in Linux kernel upstream version 2.6.22. The server that had the problem is now running a custom version of 2.6.22.
So, as Hardy appears to use 2.6.24, I assume that this is fixed.

Thanks for the feedback. Marking this "Fix Released".

Changed in linux:
status: Incomplete → Fix Released
Changed in linux:
status: Confirmed → Fix Released
Changed in linux:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.