Severe performance regression in Infiniband or IPoIB

Bug #1536837 reported by Timothy Pearson on 2016-01-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Unknown
Unknown
linux (Ubuntu)
High
Unassigned

Bug Description

When upgrading to the latest 4.4 test kernel from mainline development, all IPoIB links showed a severe performance regression as compared with kernel 4.2. The bandwidth of each link dropped from around 3Gbps to around 3Mbps (3 orders of magnitude worse!); reverting to the 4.2 kernel immediately fixed this problem.

The 4.3 kernel from Debian does not appear to suffer from this regression. The regression shows up on both IB ports of the Mellanox MT25208 controller. Other hardware has not been tested.

Steve Langasek (vorlon) on 2016-01-22
tags: removed: regression-proposed

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1536837/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Timothy Pearson (kb9vqf) wrote :

I tried to assign the source package but received the same error as when I filed this bug:
"There is no package named 'linux-image-4.4.0-0-generic' published in Ubuntu."

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key xenial
tags: added: needs-bisect

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1536837

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Timothy Pearson (kb9vqf) wrote :

The machine I originally tested the 4.4 kernel on is not available right now; I will retry as time permits. Would the dmesg output from the failed boot help or are you looking for something else in the apport output?

John-Michael (thesaxophonist) wrote :

This appears to be an upstream kernel bug, and not limited to just Ubuntu/Debian. I'm currently running Arch Linux and this regression showed up in the 4.4 kernel. The last known good kernel version was 4.3.3. Kernel versions that have the issue include 4.4.1 and 4.5rc1.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.