Update bnx2x firmware for Linux 4.4 to 7.12.30.0

Bug #1536719 reported by Mike Thompson on 2016-01-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Xenial
Medium
Tim Gardner

Bug Description

Ubuntu 12.04.1 LTS

Mike Thompson (mfthom) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1536719

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Did this issue start happening after an update/upgrade? Was there a prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.4 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily

Changed in linux (Ubuntu):
importance: Undecided → Medium
Mike Thompson (mfthom) wrote :

Cannot run apport-collect 1536719
because the systems can have no internet access.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

The issue has existed for all kernel versions that I've tried.
When I try to install from
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily/, I get a warning
that the lib/firmware/bnx2x/bnx2x-e2-7.12.30.0.fw for module bnx2x is
missing. And the NIC won't come up.
Thanks,
--Mike

On Thu, Jan 21, 2016 at 9:01 AM, Joseph Salisbury <
<email address hidden>> wrote:

> Did this issue start happening after an update/upgrade? Was there a
> prior kernel version where you were not having this particular problem?
>
> Would it be possible for you to test the latest upstream kernel? Refer
> to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
> v4.4 kernel[0].
>
> If this bug is fixed in the mainline kernel, please add the following
> tag 'kernel-fixed-upstream'.
>
> If the mainline kernel does not fix this bug, please add the tag:
> 'kernel-bug-exists-upstream'.
>
> Once testing of the upstream kernel is complete, please mark this bug as
> "Confirmed".
>
>
> Thanks in advance.
>
> [0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4-wily
>
> ** Changed in: linux (Ubuntu)
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1536719
>
> Title:
> Watchdog detected hard LOCKUP watchdog.c:265
>
> Status in linux package in Ubuntu:
> Incomplete
>
> Bug description:
> Ubuntu 12.04.1 LTS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1536719/+subscriptions
>

Mike Thompson, could you please provide the offline apport-collect (untarred/uncompressed) as outlined in https://help.ubuntu.com/community/ReportingBugs ?

Also, t your earliest convenience, could you please test the next latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Tim Gardner (timg-tpi) on 2016-01-21
Changed in linux (Ubuntu Xenial):
assignee: nobody → Tim Gardner (timg-tpi)
status: Incomplete → Fix Committed
Tim Gardner (timg-tpi) on 2016-01-22
summary: - Watchdog detected hard LOCKUP watchdog.c:265
+ Update bnx2x firmware for Linux 4.4 to 7.12.30.0

I'm a bit confused by the summary change. Is the LOCKUP issued addressed?
And pardon my ignorance, but is there any chance the fix could be applied
to the whatever is the latest kernel version that does not require a
compiler with stackprotect when making kernel modules?

On Thu, Jan 21, 2016 at 3:49 PM, Tim Gardner <email address hidden>
wrote:

> ** Also affects: linux (Ubuntu Xenial)
> Importance: Medium
> Status: Incomplete
>
> ** Changed in: linux (Ubuntu Xenial)
> Status: Incomplete => Fix Committed
>
> ** Changed in: linux (Ubuntu Xenial)
> Assignee: (unassigned) => Tim Gardner (timg-tpi)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1536719
>
> Title:
> Watchdog detected hard LOCKUP watchdog.c:265
>
> Status in linux package in Ubuntu:
> Fix Committed
> Status in linux source package in Xenial:
> Fix Committed
>
> Bug description:
> Ubuntu 12.04.1 LTS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1536719/+subscriptions
>

Tim Gardner (timg-tpi) wrote :

Hmm, perhaps I was a bit hasty. I read comment #5 and thought networking was the root of your issue. At least I've fixed your bnx2x networking issue in Xenial. The mainline kernel will not work right wrt bnx2x unless you also have the Xenial linux-firmware package installed.

From your lockup trace, it looks like one CPU is wedged. Does this take awhile ? Do older kernels work ? When did this start happening ?

RE: the LOCKUP: It takes long enough to kill a zookeeper connection, which
hurts. It has always happened, but as I've upped the load, it happens
more. Started with 3.15. I was able to install the very latest kernel by
force-installing the firmware package. But the latest kernel won't let me
make a necessary kernel module because I don't have gcc 4.9, needed for
STACKPROTECT. The latest kernel I've tried is the 3.16.

On Thu, Jan 21, 2016 at 7:29 PM, Tim Gardner <email address hidden>
wrote:

> Hmm, perhaps I was a bit hasty. I read comment #5 and thought networking
> was the root of your issue. At least I've fixed your bnx2x networking
> issue in Xenial. The mainline kernel will not work right wrt bnx2x
> unless you also have the Xenial linux-firmware package installed.
>
> >From your lockup trace, it looks like one CPU is wedged. Does this take
> awhile ? Do older kernels work ? When did this start happening ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1536719
>
> Title:
> Update bnx2x firmware for Linux 4.4 to 7.12.30.0
>
> Status in linux package in Ubuntu:
> Fix Committed
> Status in linux source package in Xenial:
> Fix Committed
>
> Bug description:
> Ubuntu 12.04.1 LTS
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1536719/+subscriptions
>

Launchpad Janitor (janitor) wrote :
Download full text (17.3 KiB)

This bug was fixed in the package linux - 4.4.0-2.16

---------------
linux (4.4.0-2.16) xenial; urgency=low

  [ Andy Whitcroft ]

  * Release Tracking Bug
    - LP: #1539090
  * SAUCE: hv: hv_set_ifconfig -- convert to python3
    - LP: #1506521
  * SAUCE: dm: introduce a target_ioctl op to allow target specific ioctls
    - LP: #1538618

  [ Colin Ian King ]

  * SAUCE: ACPI / tables: Add acpi_force_32bit_fadt_addr option to force 32
    bit FADT addresses (LP: #1529381)
    - LP: #1529381

  [ John Johansen ]

  * SAUCE: (no-up): apparmor: fix for failed mediation of socket that is
    being shutdown
    - LP: #1446906

  [ Mahesh Salgaonkar ]

  * SAUCE: Powernv: Remove the usage of PACAR1 from opal wrappers
    - LP: #1537881
  * SAUCE: powerpc/book3s: Fix TB corruption in guest exit path on HMI
    interrupt.
    - LP: #1537881
  * SAUCE: KVM: PPC: Book3S HV: Fix soft lockups in KVM on HMI for time
    base errors
    - LP: #1537881

  [ Paolo Pisati ]

  * SAUCE: arm64: errata: Add -mpc-relative-literal-loads to erratum
    #843419 build flags
    - LP: #1533009
  * [Config] MFD_TPS65217=y && REGULATOR_TPS65217=y
  * [Config] disable ARCH_ZX (ZTE ZX Soc)

  [ Tim Gardner ]

  * Revert "SAUCE: (noup) cxlflash: a couple off by one bugs"
  * SAUCE: (no-up) Update bnx2x firmware to 7.12.30.0
    - LP: #1536719
  * SAUCE: drop obsolete bnx2x firmware
  * SAUCE: i40e: Silence 'may be used uninitialized' warnings
    - LP: #1536474
  * [Config] CONFIG_ZONE_DMA=y for amd64 lowlatency
    - LP: #1534647
  * [Config] Add pvpanic to virtual flavour
    - LP: #1537923
  * [Config] CONFIG_INTEL_PUNIT_IPC=m, CONFIG_INTEL_TELEMETRY=m
    - LP: #1520457

  [ Upstream Kernel Changes ]

  * i40evf: fix compiler warning of unused variable
    - LP: #1536474
  * intel: i40e: fix confused code
    - LP: #1536474
  * i40e/i40evf: remove unused tunnel parameter
    - LP: #1536474
  * i40e: Change BUG_ON to WARN_ON in service event complete
    - LP: #1536474
  * i40e: remove BUG_ON from feature string building
    - LP: #1536474
  * i40e: remove BUG_ON from FCoE setup
    - LP: #1536474
  * i40e: Workaround fix for mss < 256 issue
    - LP: #1536474
  * i40e/i40evf: Add a stat to track how many times we have to do a force
    WB
    - LP: #1536474
  * i40e: Move the saving of old link info from handle_link_event to
    link_event
    - LP: #1536474
  * i40e/i40evf: Add comment to #endif
    - LP: #1536474
  * i40e/i40evf: clean up error messages
    - LP: #1536474
  * i40evf: handle many MAC filters correctly
    - LP: #1536474
  * i40e: return the number of enabled queues for ETHTOOL_GRXRINGS
    - LP: #1536474
  * i40e: rework the functions to configure RSS with similar parameters
    - LP: #1536474
  * i40e: create a generic configure rss function
    - LP: #1536474
  * i40e: Bump version to 1.4.2
    - LP: #1536474
  * i40e: add new fields to store user configuration
    - LP: #1536474
  * i40e: rename rss_size to alloc_rss_size in i40e_pf
    - LP: #1536474
  * i40e/i40evf: Fix RS bit update in Tx path and disable force WB
    workaround
    - LP: #1536474
  * i40e/i40evf: prefetch skb data on transmit
    - LP: #1536474
  * i40evf: rename VF adapter s...

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers