Re-enable vlan TX acceleration

Bug #1533249 reported by Talat Batheesh on 2016-01-12
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Wily
High
Tim Gardner
Xenial
Undecided
Unassigned

Bug Description

Unable to send TCP/UDP traffic between VLAN on ConnectX4LX, due to vlan TX acceleration is off.

Scenario

       Configure static VLAN on CX4LX and try to run iperf TCP/UDP.
       There are no traffic TCP/UDP even that the ICMP traffic pass (using ping between vlan's)

       #server # iperf -s

      #Client: # iperf -c <Vlan-ip>

Setup info:

OS: Ubuntu14.04.4
Kernel 4.2.0-22

Upstream commits that fix this issue

c44d84d net/mlx5e: Fix inline header size calculation
59fb571 net/mlx5e: Fix LSO vlan insertion
13c5224 net/mlx5e: Re-eanble client vlan TX acceleration

Talat Batheesh (talat-b87) wrote :

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1533249

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tim Gardner (timg-tpi) on 2016-01-12
summary: - Re-enabe vlan TX acceleration
+ Re-enable vlan TX acceleration
Tim Gardner (timg-tpi) on 2016-01-12
Changed in linux (Ubuntu Wily):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Xenial):
status: Incomplete → Fix Released
Talat Batheesh (talat-b87) wrote :

Hi,
Please add this Fix to 14.04.4.

Thanks
Talat

tags: added: trusty
Talat Batheesh (talat-b87) wrote :

Added tarboot file that contain the 3 upstream commits.
0001-net-mlx5e-Re-eanble-client-vlan-TX-acceleration.patch
0002-net-mlx5e-Fix-LSO-vlan-insertion.patch
0003-net-mlx5e-Fix-inline-header-size-calculation.patch

This patches upstream and the fix verified on machine with 14.04.4 and kernel 4.2.8-ckt1+

Thanks,
Talat

Talat Batheesh (talat-b87) wrote :

Thank you Tim,

This Bug affect just Mellanox Drivers and improve the vlan process in the newest Mellanox Devices.
could you please add this bug Fix to Ubuntu 14.04.4 kernel.

Thanks in advance,
Talat

Tim Gardner (timg-tpi) wrote :

These patches will appear in the 14.04.4 kernel in due course.

Kamal Mostafa (kamalmostafa) wrote :

The commits have been applied and are scheduled for release in the next Ubuntu Wily (4.2) kernel.

Changed in linux (Ubuntu Wily):
importance: Undecided → High
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
tags: added: verification-done-wily
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.2.0-27.32

---------------
linux (4.2.0-27.32) wily; urgency=low

  [ Brad Figg ]

  * Release Tracking Bug
    - LP: #1536867

  [ Andy Whitcroft ]

  * SAUCE: (no-up) add compat_uts_machine= kernel command line override
    - LP: #1520627

  [ Colin Ian King ]

  * SAUCE: (no-up) ACPI / tables: Add acpi_force_32bit_fadt_addr option to
    force 32 bit FADT addresses
    - LP: #1529381

  [ Eric Dumazet ]

  * SAUCE: (no-up) udp: properly support MSG_PEEK with truncated buffers
    - LP: #1527902

  [ Guilherme G. Piccoli ]

  * SAUCE: powerpc/eeh: Validate arch in eeh_add_device_early()
    - LP: #1486180

  [ Tim Gardner ]

  * SAUCE: (no-up) Revert "[SCSI] libiscsi: Reduce locking contention in
    fast path"
    - LP: #1517142
  * [Config] Add DRM ast driver to udeb installer image
    - LP: #1514711

  [ Upstream Kernel Changes ]

  * net/mlx5e: Re-eanble client vlan TX acceleration
    - LP: #1533249
  * net/mlx5e: Fix LSO vlan insertion
    - LP: #1533249
  * net/mlx5e: Fix inline header size calculation
    - LP: #1533249
  * net: usb: cdc_ncm: Adding Dell DW5812 LTE Verizon Mobile Broadband Card
    - LP: #1533118
  * net: usb: cdc_ncm: Adding Dell DW5813 LTE AT&T Mobile Broadband Card
    - LP: #1533118
  * powerpc/eeh: Fix recursive fenced PHB on Broadcom shiner adapter
    - LP: #1532942

linux (4.2.0-26.31) wily; urgency=low

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1535795
  * Merged back Ubuntu-4.2.0-25.30

 -- Brad Figg <email address hidden> Thu, 21 Jan 2016 18:44:37 -0800

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches