Lenovo helix 2nd gen does not wake up from suspend

Bug #1530476 reported by Johan Bernhardsson on 2016-01-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Using a fresh install of ubuntu 15.10. When the laptop enters suspend it wont wake up. Not from trigging the lid switch or pressing the power button.

Using Latest kernel 4.2.0-22-generic. Tried with two different bios versions to rule out bios.

The only option is to press and hold and do a new cold start.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: linux-image-4.2.0-22-generic 4.2.0-22.27
ProcVersionSignature: Ubuntu 4.2.0-22.27-generic 4.2.6
Uname: Linux 4.2.0-22-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: jobe 1530 F.... pulseaudio
 /dev/snd/controlC0: jobe 1530 F.... pulseaudio
CurrentDesktop: GNOME
Date: Fri Jan 1 22:09:34 2016
HibernationDevice: RESUME=UUID=bbd6d6cd-2398-4046-ba00-e818132d983a
InstallationDate: Installed on 2015-12-16 (16 days ago)
InstallationMedia: Ubuntu-GNOME 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 20CGCTO1WW
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-22-generic.efi.signed root=/dev/mapper/ubuntu--gnome--vg-root ro noprompt persistent quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-22-generic N/A
 linux-backports-modules-4.2.0-22-generic N/A
 linux-firmware 1.149.3
SourcePackage: linux
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/02/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: N17ET83W (1.83 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20CGCTO1WW
dmi.board.vendor: LENOVO
dmi.board.version: SDK0K11826 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 11
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN17ET83W(1.83):bd12/02/2015:svnLENOVO:pn20CGCTO1WW:pvrThinkPadHelix2nd:rvnLENOVO:rn20CGCTO1WW:rvrSDK0K11826WIN:cvnLENOVO:ct11:cvrNone:
dmi.product.name: 20CGCTO1WW
dmi.product.version: ThinkPad Helix 2nd
dmi.sys.vendor: LENOVO

Johan Bernhardsson (smallone) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Johan Bernhardsson, thank you for reporting this and helping make Ubuntu better.

At your earliest convenience, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-1.83
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Johan Bernhardsson (smallone) wrote :

Tested and added the tags. The bug still exists in 4.4-rc7

kernel-bug-exists-upstream
kernel-bug-exists-upstream-4.4-rc7

When i suspend the laptop it refuses to resume. Only a cold boot works. Lid switch does not respond. Nor does the power button.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.4-rc7
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Johan Bernhardsson (smallone) wrote :

https://bugzilla.kernel.org/show_bug.cgi?id=100171

This looks like the same thing upstream.

Johan Bernhardsson, could you please provide the missing information from https://wiki.ubuntu.com/DebuggingKernelSuspend ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :

so i have tried with pm-suspend, suspend from gnome3 and suspend on inactivity. All results in a laptop that i cant wake up with lid switch or power button.

I attached wakeup and dmesg.txt from the latest attempt. Debugging with pm_trace reset the systems time.

From dmesg.txt

[ 1.718604] Magic number: 1:0:0
[ 1.718666] memory memory48: hash matches
[ 1.718727] rtc_cmos 00:02: setting system clock to 2001-01-01 00:00:19 UTC (978307219)
[ 1.718797] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 1.718797] EDD information not available.
[ 1.718918] PM: Hibernation image not present or could not be loaded.

Johan Bernhardsson, unfortunately, that didn't provide the root cause.

However, a newer mainline kernel has been released (4.4) and the suspend article has been updated.

Hence, could you please test with the latest kernel and provide all items of information?

Johan Bernhardsson (smallone) wrote :

I will try 4.4 right away and see if it helps.

Johan Bernhardsson (smallone) wrote :

I tried 4.4 and the bug is still there. And the debug doesn't reveal anything more than before.

Johan Bernhardsson (smallone) wrote :

I have tested 4.4 and looked around to see if i can find something more usefull. It appears that lenovo carbon x1 might have the same problem (not confirmed yet tho)

Johan Bernhardsson (smallone) wrote :

A did a test to see if freeze would work. And it does work better than suspend. Only snag is that it only works with a keyboard connected as the keyboard is the only way to wake it up. The power button is still not activating anything

Johan Bernhardsson (smallone) wrote :

tried 4.5 rc2 bug is still there

tags: added: kernel-bug-exists-upstream-4.5-rc2 needs-suspend-debug
removed: kernel-bug-exists-upstream-4.4-rc7
Johan Bernhardsson (smallone) wrote :

Using linux 4.5-rc5. same result.

    2.259205] Magic number: 1:0:0
[ 2.259260] memory memory48: hash matches

And pm test gave me that.

Johan Bernhardsson, to advise, that little piece information provided is not terribly helpful.

Despite this, you would to perform a memory test to confirm you don't have bad RAM.

If this test passes, then you would want to review the recently updated suspend debugging article https://wiki.ubuntu.com/DebuggingKernelSuspend to fully confirm which driver module is at fault here.

Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :
Johan Bernhardsson (smallone) wrote :

pm test none failed. The laptop went to sleep and never woke up.

memory48 hash matches when booting up again.

it seems like there is some special thing with lid and power button when it comes to wakeup

Johan Bernhardsson (smallone) wrote :

root@piglet:~# acpitool -w
   Device S-state Status Sysfs node
  ---------------------------------------
  1. LID S4 *enabled platform:PNP0C0D:00
  2. SLPB S3 *enabled platform:PNP0C0E:00
  3. IGBE S4 *disabled
  4. PXSX S4 *disabled
  5. EXP2 S4 *disabled pci:0000:00:1c.1
  6. PXSX S4 *disabled pci:0000:06:00.0
  7. PXSX S4 *disabled
  8. XHCI S3 *enabled pci:0000:00:14.0
  9. EHC1 S3 *disabled
  10. PWRB S0 *enabled platform:PNP0C0C:00

One difference i see is that my samsung laptop has PWRB on S5 and not S0 and that my asus has sleep btn on S4 and not S3.

This laptop doesnt have a sleep button on the chassi nor on the keyboard btw.

Download full text (5.1 KiB)

Johan Bernhardsson, regarding your comment from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1530476/comments/23 :

>"pm test none failed."

Are you saying that none of the pm tests failed?

Despite this, as per https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1530476/+attachment/4578288/+files/devices.txt :
[ 1414.148685] ------------[ cut here ]------------
[ 1414.148720] WARNING: CPU: 2 PID: 3775 at /home/kernel/COD/linux/drivers/gpu/drm/i915/intel_uncore.c:599 hsw_unclaimed_reg_debug+0x69/0x90 [i915]()
[ 1414.148723] Unclaimed register detected after reading register 0x70008
[ 1414.148725] Modules linked in: rfcomm drbg ansi_cprng ctr ccm xt_CHECKSUM iptable_mangle ipt_MASQUERADE nf_nat_masquerade_ipv4 iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ipt_REJECT nf_reject_ipv4 xt_tcpudp bridge stp llc ebtable_filter ebtables ip6table_filter ip6_tables iptable_filter ip_tables x_tables bnep snd_hda_codec_hdmi hid_lenovo cdc_mbim cdc_wdm uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core btusb btrtl btbcm cdc_ncm btintel usbnet videodev snd_usb_audio usbhid cdc_acm snd_usbmidi_lib mii bluetooth media hid_sensor_rotation arc4 hid_sensor_gyro_3d hid_sensor_custom nls_iso8859_1 hid_sensor_incl_3d hid_sensor_accel_3d hid_sensor_als hid_sensor_magn_3d hid_sensor_trigger industrialio_triggered_buffer kfifo_buf industrialio
[ 1414.148774] hid_sensor_iio_common hid_sensor_hub iwlmvm wacom mac80211 acer_wmi sparse_keymap intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp snd_soc_rt286 iwlwifi snd_soc_rl6347a kvm_intel snd_soc_core kvm i915 snd_compress drm_kms_helper cfg80211 ac97_bus drm irqbypass snd_pcm_dmaengine i2c_algo_bit fb_sys_fops syscopyarea sysfillrect sysimgblt crct10dif_pclmul crc32_pclmul ghash_clmulni_intel aesni_intel aes_x86_64 lrw gf128mul glue_helper ablk_helper cryptd joydev input_leds serio_raw intel_pch_thermal lpc_ich snd_hda_intel snd_hda_codec shpchp snd_hda_core snd_hwdep snd_pcm mei_me mei processor_thermal_device intel_soc_dts_iosf thinkpad_acpi nvram mac_hid snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device snd_timer soc_button_array snd soundcore int3402_thermal int3403_thermal
[ 1414.148822] int340x_thermal_zone int3400_thermal dw_dmac 8250_dw snd_soc_sst_acpi snd_soc_sst_match acpi_thermal_rel dw_dmac_core i2c_designware_platform spi_pxa2xx_platform i2c_designware_core parport_pc ppdev lp parport autofs4 psmouse ahci libahci wmi sdhci_acpi video sdhci i2c_hid hid fjes
[ 1414.148842] CPU: 2 PID: 3775 Comm: suspend.sh Not tainted 4.5.0-040500rc5-generic #201602201730
[ 1414.148844] Hardware name: LENOVO 20CGCTO1WW/20CGCTO1WW, BIOS N17ET83W (1.83 ) 12/02/2015
[ 1414.148847] 0000000000000086 000000008ee25057 ffff8801c3ba7a30 ffffffff813dfc93
[ 1414.148852] ffff8801c3ba7a78 ffffffffc0554168 ffff8801c3ba7a68 ffffffff81080e72
[ 1414.148855] ffff88021ef40000 0000000000070008 0000000000000000 0000000000000206
[ 1414.148859] Call Trace:
[ 1414.148865] [<ffffffff813dfc93>] dump_stack+0x63/0x90
[ 1414.148870] [<ffffffff81080e72>] warn_slowpath_common+0x82/0xc0
[ 1414.148873] [<ffffffff81080f0c>] warn_slowpath_fmt+0x5c/0x80
...

Read more...

Richard Trabing (richtrabing) wrote :

Hi, I just wanted to keep this thread alive, as the bug seems still to be present. I recently tried suspend with the Helix 2 and Ubuntu 16.04 and can confirm the same behaviour.
This issue is being tracked on the kernel bugzilla:
https://bugzilla.kernel.org/show_bug.cgi?id=100171
There was a BIOS Update released by Lenovo on the 25th of May which addresses some Suspend issues for Windows 10. I haven't yet checked my BIOS version- will check tonight.
If it is still an issue, I will post logs and DebuggingKernelSuspend results...

tags: added: bios-outdated-1.86
removed: latest-bios-1.83

Richard Trabing, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Richard Trabing (richtrabing) wrote :

Thanks for your quick feedback, Christopher. I'll do what you suggest. Am new to this Bug reporting process, but the documentation looks good.
I am assuming that by submitting a new bug report that I will be getting a new bug number. I'll attach that one to this thread once done.
I checked my BIOS version this morning and I am on the latest - 1.86 (dated 2 May 2016, I think). So, in summary, Ubuntu-Gnome is unable to resume after a normal power button suspend (or lid-close suspend) on the Lenovo Helix 2 with the latest BIOS version.
(By the way, you guys are doing great work. Love the latest Ubuntu-Gnome!)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.