System locks up when Inserting a SD card on a baytrail platform

Bug #1527096 reported by Hui Wang on 2015-12-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Hui Wang
linux (Ubuntu)
High
Hui Wang
Wily
Undecided
Unassigned

Bug Description

[Summary] System hangs when Inserting a SD card

[Reproduce Steps]
1. Boot into system
2. Insert a micro SD card into the card reader.

[Results]
Expected: card can be correctly detected.
Actual: system locks up completely.

[Additional Information]
CID: xxx
Base Image: Ubuntu 15.10 desktop
Product Name: Acer CPF
BIOS Version: v0.06
Kernel Version: 4.2.x
CPU: Intel CHT x5-z8300
GPU: Integrated

This is an issue with (high) fail rate.

This bug is used for tracking only, please do not triage.

Hui Wang (hui.wang) wrote :

Mika@Intel suggested we add this CONFIG_I2C_DESIGNWARE_BAYTRAIL=y to the kernel config

And we have tested this fix, after applied this fix, the problem disappeared.

And to change the CONFIG_I2C_DESIGNWARE_BAYTRAIL=y, we also to change the CONFIG_IOSF_MBI=m to CONFIG_IOSF_MBI=y, since the first config option depends on IOSF_MBI=y.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1527096

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Hui Wang (hui.wang) on 2015-12-21
Changed in hwe-next:
assignee: nobody → Hui Wang (hui.wang)
status: New → Fix Released
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Luis Henriques (henrix) on 2016-01-11
Changed in linux (Ubuntu Wily):
status: New → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-wily' to 'verification-done-wily'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-wily
Hui Wang (hui.wang) on 2016-01-14
tags: added: verification-done-wily
removed: verification-needed-wily
Andy Whitcroft (apw) wrote :

Fix released in 4.2.0-27.32

Changed in linux (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers