read: Value too large for defined data type -- from fanotify interface

Bug #1527039 reported by Seth Arnold on 2015-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Trusty
Medium
Tim Gardner

Bug Description

fatrace is giving me errors because my computer is using large files:

sarnold@hunt:~/trees/linux$ sudo fatrace
[sudo] password for sarnold:
read: Value too large for defined data type
sarnold@hunt:~/trees/linux$ sudo fatrace
squid3(7248): O /var/cache/squid-deb-proxy/06/C7
squid3(7248): C /var/cache/squid-deb-proxy/06/C7
read: Value too large for defined data type
sarnold@hunt:~/trees/linux$ sudo fatrace
read: Value too large for defined data type

A fix is available in http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=1e2ee49f7f1b79f0b14884fe6a602f0411b39552

I'm currently using:
Linux hunt 3.13.0-69-generic #112-Ubuntu SMP Tue Nov 10 16:29:26 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I did't see the above fix in my checkout of the Ubuntu kernel git tree, so this is probably a fair result despite coming from a -proposed kernel. (I'm going to reboot any day now, I promise.)

Thanks
---
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: sarnold 2870 F.... pulseaudio
 /dev/snd/pcmC0D0p: sarnold 2870 F...m pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=81b2976f-2830-4449-9dae-e1d44a43fa78
InstallationDate: Installed on 2012-10-18 (1154 days ago)
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: LENOVO 2359CTO
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-69-generic root=UUID=7b8c2e1b-d2e6-47d9-9030-c078e9701a1d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.13.0-69.112-generic 3.13.11-ckt29
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-69-generic N/A
 linux-backports-modules-3.13.0-69-generic N/A
 linux-firmware 1.127.18
Tags: trusty
Uname: Linux 3.13.0-69-generic x86_64
UpgradeStatus: Upgraded to trusty on 2014-04-12 (614 days ago)
UserGroups: adm cdrom dip libvirtd lpadmin plugdev sambashare sbuild sudo
_MarkForUpload: True
dmi.bios.date: 09/13/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G4ET62WW (2.04 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2359CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG4ET62WW(2.04):bd09/13/2012:svnLENOVO:pn2359CTO:pvrThinkPadT530:rvnLENOVO:rn2359CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2359CTO
dmi.product.version: ThinkPad T530
dmi.sys.vendor: LENOVO

apport information

tags: added: apport-collected trusty
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Seth Arnold (seth-arnold) wrote :

apport information

apport information

apport information

apport information

apport information

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: kernel-da-key
Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in linux (Ubuntu Trusty):
status: New → Triaged
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux (Ubuntu Trusty):
importance: Undecided → Medium
tags: added: cherry-pick
Tim Gardner (timg-tpi) on 2015-12-18
Changed in linux (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → In Progress
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Tim Gardner (timg-tpi) on 2015-12-21
Changed in linux (Ubuntu Trusty):
status: In Progress → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-trusty' to 'verification-done-trusty'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-trusty
Seth Arnold (seth-arnold) wrote :

I've tested fatrace while grepping huge files: before, it'd die. With 3.13.0-75-generic it survives. Thanks!

Linux hunt 3.13.0-75-generic #119-Ubuntu SMP Mon Jan 11 13:49:34 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

tags: added: verification-done-trusty
removed: verification-needed-trusty
Andy Whitcroft (apw) wrote :

Fix released in 3.13.0-77.121

Changed in linux (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers