ASUS ROG G752 TouchPad not detected

Bug #1526393 reported by Zhiqiang Sui on 2015-12-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Laptop Model : ASUS ROG G752VT-DH72
First Appearance : I got two ASUS ROG G752 laptops yesterday afternoon. Installed Ubuntu 14.04.03 with pre-installed Windows 10. Both two laptops can not detect launchpad.
Manufacturer : ASUSwith

*xinput list

xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Sunrex/JME Ghost Key Elimiantion Keyboard id=10 [slave pointer (2)]
⎜ ↳ ASUS Tech Inc. ASUS HID Device id=13 [slave pointer (2)]
⎜ ↳ ASUS Tech Inc. ASUS HID Device id=14 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft 5-Button Mouse with IntelliEye(TM) id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Sleep Button id=8 [slave keyboard (3)]
    ↳ Sunrex/JME Ghost Key Elimiantion Keyboard id=9 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam id=11 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=15 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=16 [slave keyboard (3)]

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.19.0-25-generic 3.19.0-25.26~14.04.1 [modified: boot/vmlinuz-3.19.0-25-generic]
ProcVersionSignature: Ubuntu 3.19.0-25.26~14.04.1-generic 3.19.8-ckt2
Uname: Linux 3.19.0-25-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Dec 15 10:37:27 2015
InstallationDate: Installed on 2015-12-14 (1 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
SourcePackage: linux-lts-vivid
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: logan 1976 F.... pulseaudio
CurrentDesktop: Unity
DistroRelease: Ubuntu 14.04
HibernationDevice: RESUME=UUID=d21349d4-a2e3-4591-8888-a533881af2e8
InstallationDate: Installed on 2015-12-14 (3 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
MachineType: ASUSTeK COMPUTER INC. G752VT
NonfreeKernelModules: nvidia
Package: linux (not installed)
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-39-generic.efi.signed root=UUID=feeb3b62-a26b-486a-bba9-8f4eedd0f6df ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.19.0-39.44~14.04.1-generic 3.19.8-ckt9
RelatedPackageVersions:
 linux-restricted-modules-3.19.0-39-generic N/A
 linux-backports-modules-3.19.0-39-generic N/A
 linux-firmware 1.127.19
Tags: trusty
Uname: Linux 3.19.0-39-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/23/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: G752VT.205
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: G752VT
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG752VT.205:bd09/23/2015:svnASUSTeKCOMPUTERINC.:pnG752VT:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG752VT:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: G752VT
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Zhiqiang Sui (szqsui) wrote :

Zhiqiang Sui, thank you for reporting this and helping make Ubuntu better.

Please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1526393

affects: linux-lts-vivid (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Zhiqiang Sui, at your earliest convenience, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If testing on your main install would be inconvenient, one may:
1) Install Ubuntu to a different partition and then test this there.
2) Backup, or clone the primary install.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, and Y are the first two numbers of the kernel version, and Z is the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-205
Changed in linux (Ubuntu):
importance: Low → Medium
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
@pjf (paul-j-fenwick) wrote :

First time reporting using launchpad, so I'm not yet sure of correct procedures, but I've also got this bug. Different laptop (Gigabyte P57) but same touchpad ( Sunrex/JME Ghost Key Elimiantion Keyboard ), expressing itself under Ubuntu 14.04 with a 4.4.0 kernel.

Using a mainline 4.6.0 kernel does not resolve the issue.

@pjf (paul-j-fenwick) wrote :

Update!

My trackpad works, and I don't know why. ;(

In particular, we're now seeing a ETPS/2 Elantech Touchpad in xinput, which wasn't there when I reported yesterday:

~$ xinput | head -4
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Sunrex/JME Ghost Key Elimiantion Keyboard id=13 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad id=15 [slave pointer (2)]

I'm running a 4.4.0 kernel:

~$ uname -a
Linux qapla 4.4.0-22-generic #40~14.04.1-Ubuntu SMP Fri May 13 17:27:45 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

My suspicion (based upon folks with Elantech touchpads messing with i8042 resets) is that my machine came directly from cold-boot to Linux today, whereas the touchpad yesterday had been after multiple reboots where I wrenched a disk from using legacy BIOS booting to UFI booting.

I shall continue to report as I learn more. :)

@pjf (paul-j-fenwick) wrote :

Further updates!

I can't seem to figure out when the trackpad will and will not be detected, but I found http://askubuntu.com/questions/636350/elantech-touchpad-not-detected-anymore-on-ubuntu-15 which describes an issue with similar hardware, and sure enough adding `i8042.kbdreset=1` to `GRUB_CMDLINE_LINUX_DEFAULT` in /etc/default/grub seems to have things working for now!

Which means I've progressed from "my trackpad is working and I don't know why" to "my trackpad is working and I mostly know why", a huge improvement! :)

@pjf, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers