"ACPI PCC probe failed" message is an error message when it should be debug

Bug #1524930 reported by Colin Ian King
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Colin Ian King
Vivid
Low
Colin Ian King

Bug Description

[SRU Justification][Vivid]

Users of Ubuntu Vivid are seeing a seemingly alarming kernel failure message "ACPI PCC probe failed" when in fact it is just a debug message informing the kernel developers that a probe for an ACPI PCC mailbox was not successful (which is just a debug only message) and not a failure one needs to worry about. This message is asked about frequently on askubuntu.com, so it is alarming quite a few users, c.f. : http://askubuntu.com/questions/708215/1-037533-acpi-pcc-probe-failed.

This fix landed in Wily, and the driver with the alarming message only affects Vivid.

[Fix]
Upstream commit efd756daf4ddae3cec2404c4e0b680b7cfdd6a45 ("ACPI / PCC: Use pr_debug() for debug messages in pcc_init()")

[Testcase]

Boot a machine without the PCC feature, without the fix one sees the error message in the kernel log. With the fix, this error is now a warning. Note: This only affects Vivid.

Changed in linux (Ubuntu):
importance: Undecided → Low
assignee: nobody → Colin Ian King (colin-king)
description: updated
Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1524930

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in linux (Ubuntu):
assignee: Colin Ian King (colin-king) → Max Payne (lopliok-lopliok)
status: In Progress → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Colin Ian King (colin-king) wrote :

@Max Payne, please don't change the bug status on this bug. Thank you.

Changed in linux (Ubuntu):
assignee: Max Payne (lopliok-lopliok) → Colin Ian King (colin-king)
status: Incomplete → In Progress
Luis Henriques (henrix)
Changed in linux (Ubuntu Vivid):
status: New → Fix Committed
Changed in linux (Ubuntu Vivid):
importance: Undecided → Low
assignee: nobody → Colin Ian King (colin-king)
Revision history for this message
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-vivid' to 'verification-done-vivid'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-vivid
Revision history for this message
Colin Ian King (colin-king) wrote :

Before fix (3.19.0-43-generic):

dmesg | grep "ACPI PCC"
[ 0.777442] ACPI PCC probe failed.

With fix: (3.19.0-46-generic)

dmesg | grep "ACPI PCC"

So verified it is now fixed with the -proposed kernel

tags: added: verification-done-vivid
removed: verification-needed-vivid
Revision history for this message
Andy Whitcroft (apw) wrote :

Fix released in 3.19.0-47.53

Changed in linux (Ubuntu Vivid):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Mutlu Can YILMAZ (mtlcnylmz) wrote :

Same problem persists on Trusty.

Revision history for this message
Colin Ian King (colin-king) wrote :

Mutlu, can run:

uname -a

and post the result into the bug report.

Revision history for this message
Mutlu Can YILMAZ (mtlcnylmz) wrote :

Linux golcuk-G31M-ES2L 3.19.0-49-generic #55~14.04.1-Ubuntu SMP Fri Jan 22 11:24:31 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers