Comment 90 for bug 1521173

Luiz (lmfranco) wrote :

Let me tell my history:

I bought a dell inspiron 7000 series with windows 10.

Replaced by ubuntu 18.04

I make some bios upgrades. my actual bios is the newer.

One day i opened my notebook and do a ssd upgrade.

My error was to unplug the battery because one pin twisted.

I noticed in ubuntu that the notebook was not charging until the battery FULL charge, even with less one pin the batery should charge LESS than full design(3684000) and was charging at "full" (3403000).

Ubuntu was showing all the time CHARGING and never completelly charged.

The error pci aer corrected occurs as i could see in dmesg log.

with lspci i described the pci hardware:
00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)

Another problem i noticed is that the bios date was bugged when i restore factory bios settings. One bios upgrade i download the file(bios) from another country my notebook model over. I'm not sure this is the cause rtc bug.

I am not completelly sure how the faithful solution sequence was made by me, so i am only reporting ALL long story happened.

In my opinion it can be TIMER bug. One pci aer dmesg log mention replay timer.

What i made:

1 - Download from LOCAL vendor bios. I download las time i upgrade from another country bios vendor, over proxy.

2- Cleared setup (with blank) password. I cleared my only defined admin password.

3- Restarted and flashed the bios download from my model locale.

4- Reset cmos/nvram to defaults factory.

5 - Adjust time at bios and sync with ubuntu via command: timedatectl set-local-rtc 1 --adjust-system-clock. Using bios hardware time rtc, not NTP from servers. I tryied with no success: hwclock --systohc. Restart. At this point the ubuntu shows full charged message at battery system menu status. Even with not charging my battery full design.

6- I leave my notebook turned on full time until the drain total remaining battery. Unplugged from power.

7 - Plug AC Power and turn on the notebook.

The error still occurs, but not in boot time from dmesg logs. My /etc/default/grub file: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Not using any kernel custom parameter.

Conclusion
Its not Linux bug. In my experience it can be related to: Bios/Time&Date/cmos/nvram. Maybe my battery in short circuit. I Still not tested with battery disconnected. I put my note to function with primary AC use. When i ran a game the error shows up dmesg log, not after boot the system.

The final procedure was to leave my battery drains with notebook switched on.