s390x: xenial master-next needs a different linux-image split and new udebs

Bug #1519833 reported by Dimitri John Ledkov on 2015-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Xenial
Medium
Andy Whitcroft

Bug Description

Currently:

-rw-r--r-- root/root 24590 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_fba_mod.ko
-rw-r--r-- root/root 178446 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_eckd_mod.ko
-rw-r--r-- root/root 190646 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_mod.ko
-rw-r--r-- root/root 21502 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_diag_mod.ko

are present in the linux-image-extra package alone.

Imho, at least:
-rw-r--r-- root/root 24590 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_fba_mod.ko
-rw-r--r-- root/root 178446 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_eckd_mod.ko
-rw-r--r-- root/root 190646 2015-11-25 14:49 ./lib/modules/4.3.0-0-generic/kernel/drivers/s390/block/dasd_mod.ko

should be in linux-image, as they are essential.

Also for installer support onto dasd, dasd-modules-udeb is needed.
In debian, it is split into two:

dasd-modules
-rw-r--r-- root/root 163968 2015-11-10 20:42 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/block/dasd_mod.ko
-rw-r--r-- root/root 24896 2015-11-10 20:42 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/block/dasd_fba_mod.ko
-rw-r--r-- root/root 179880 2015-11-10 20:42 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/block/dasd_eckd_mod.ko

dasd-extra-modules
-rw-r--r-- root/root 21512 2015-11-10 20:42 ./lib/modules/4.2.0-1-s390x/kernel/drivers/s390/block/dasd_diag_mod.ko

the dasd-modules in any udeb are required, and following above splits as per debian is a suggestion.

Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
tags: added: s390x
Andy Whitcroft (apw) on 2015-11-25
summary: - xenial master-next needs a different udeb split for x390x
+ s390x: xenial master-next needs a different linux-image split and new
+ udebs

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1519833

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 4.3.0-1.10

---------------
linux (4.3.0-1.10) xenial; urgency=low

  [ Andy Whitcroft ]

  * [Config] make IBMVETH consistent on powerpc/ppc64el
    - LP: #1521712
  * [Config] follow ibmvscsi name change
    - LP: #1521712
  * [Config] move ibm disk and ethernet drivers to linux-image
    - LP: #1521712
  * [Config] include ibmveth in nic-modules for ppc64el
    - LP: #1521712
  * [Config] s390x -- disable abi/module checks for s390x

  [ Tim Gardner ]

  * [Config] Add spl/zfs provides to generic and powerpc64-smp
  * [Config] Add zfs to d-i fs-core-modules

  [ Upstream Kernel Changes ]

  * KVM: x86: work around infinite loop in microcode when #AC is delivered
  * KVM: svm: unconditionally intercept #DB
  * Btrfs: fix truncation of compressed and inlined extents
  * staging/dgnc: fix info leak in ioctl
  * [media] media/vivid-osd: fix info leak in ioctl
  * crypto: asymmetric_keys - remove always false comparison
  * X.509: Fix the time validation [ver #2]
  * isdn_ppp: Add checks for allocation failure in isdn_ppp_open()
  * ppp, slip: Validate VJ compression slot parameters completely

 -- Andy Whitcroft <email address hidden> Tue, 01 Dec 2015 21:37:13 +0000

Changed in linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers