spl/zfs fails to build on s390x

Bug #1519814 reported by Dimitri John Ledkov on 2015-11-25
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
Xenial
Medium
Andy Whitcroft

Bug Description

make -C /home/xnox/xenial/linux-4.3.0/debian/build/build-generic SUBDIRS=`pwd` O=/home/xnox/xenial/linux-4.3.0/debian/build/build-generic CONFIG_SPL=m modules
make[2]: Entering directory '/home/xnox/xenial/linux-4.3.0/debian/build/build-generic'
  CC [M] /home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/splat/splat-ctl.o
  CC [M] /home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-proc.o
  CC [M] /home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-kmem.o
  CC [M] /home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/splat/splat-kmem.o
  CC [M] /home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-kmem-cache.o
/home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-kmem-cache.c: In function 'spl_kmem_cache_alloc':
/home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-kmem-cache.c:1464:4: error: implicit declaration of function 'prefetchw' [-Werror=implicit-function-declaration]
    prefetchw(obj);
    ^
cc1: some warnings being treated as errors
/home/xnox/xenial/linux-4.3.0/scripts/Makefile.build:258: recipe for target '/home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-kmem-cache.o' failed
make[6]: *** [/home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl/spl-kmem-cache.o] Error 1
/home/xnox/xenial/linux-4.3.0/scripts/Makefile.build:403: recipe for target '/home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl' failed
make[5]: *** [/home/xnox/xenial/linux-4.3.0/debian/build/build-generic/spl/module/spl] Error 2
make[5]: *** Waiting for unfinished jobs....

tags: added: s390x
Dimitri John Ledkov (xnox) wrote :

missing #include <linux/prefetch.h>

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1519814

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Dimitri John Ledkov (xnox) wrote :

Not sure if we want to carry this given https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1519820

tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
summary: - xenial, linux-master FTBFS on s390x
+ spl/zfs fails to build on s390x
Changed in linux (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Tim Gardner (timg-tpi) wrote :

Dimitri - I'm working on rebasing to Linux 4.4-rc2. I'll get this fixed within the next few days.

Changed in linux (Ubuntu Xenial):
assignee: Dimitri John Ledkov (xnox) → Tim Gardner (timg-tpi)
Dimitri John Ledkov (xnox) wrote :

@Tim cool. But looking at spl/zfs upstream - that code is not ported to s390x yet, or is it?

Tim Gardner (timg-tpi) wrote :

Dimitri -Dunno, haven't checked. Right now spl/zfs has some function prototype issues with Linux 4.4 that affect all architectures. I won't tackle s390 problems until I get some solutions from ZFS upstream.

Christian Reis (kiko) wrote :

Adding Richard to see if he has any insight.

Dimitri John Ledkov (xnox) wrote :

Discussing with s390x upstream developers, we should check if zpl/zfs code supports any other 64bit big-endian platforms (e.g. SPARC64) and then check if s390x support can be trivially enabled similarly to e.g. sparc64 port.

Dimitri John Ledkov (xnox) wrote :
Changed in linux (Ubuntu Xenial):
status: Triaged → In Progress
tags: added: patch
Dimitri John Ledkov (xnox) wrote :

# ./debian/tests/kernel-smoke-test
kernel smoke test, create and destroy pool, 2x2 mirror: PASSED
kernel smoke test, create and destroy pool, 4x1 mirror: PASSED
kernel smoke test, create and destroy pool, nested raidz3: PASSED
kernel smoke test, create and destroy pool, raidz1: PASSED
kernel smoke test, create and destroy pool, raidz2: PASSED
kernel smoke test, create and destroy pool, raidz3: PASSED
kernel smoke test, create and destroy pool, striped: PASSED
kernel smoke test, create and destroy ZFS Intent Log: PASSED
kernel smoke test, create and destroy ZFS filesystems: PASSED
kernel smoke test, ZFS snapshot: PASSED
kernel smoke test, ZFS clone: PASSED
kernel smoke test, ZFS send and receive: PASSED
kernel smoke test, corrupt data and clean with a scrub: PASSED

Andy Whitcroft (apw) wrote :

As next week is Beta we are going to apply this on the unstable PPA and get ~cking to kick the tyres with a view to applying it after the freeze lifts.

Changed in linux (Ubuntu Xenial):
assignee: Tim Gardner (timg-tpi) → Andy Whitcroft (apw)
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package linux - 4.4.0-16.32

---------------
linux (4.4.0-16.32) xenial; urgency=low

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1561727

  * fix thermal throttling due to commit "Thermal: initialize thermal zone
    device correctly" (LP: #1561676)
    - Thermal: Ignore invalid trip points

  * Thinkpad T460: Trackpoint mouse buttons instantly generate "release" event
    on press (LP: #1553811)
    - SAUCE: (noup) Input: synaptics - handle spurious release of trackstick
      buttons, again

  * reading /sys/kernel/security/apparmor/profiles requires CAP_MAC_ADMIN
    (LP: #1560583)
    - SAUCE: apparmor: Allow ns_root processes to open profiles file
    - SAUCE: apparmor: Consult sysctl when reading profiles in a user ns

  * linux: sync virtualbox drivers to 5.0.16-dfsg-2 (LP: #1561492)
    - ubuntu: vbox -- update to 5.0.16-dfsg-2

  * s390/kconfig: CONFIG_NUMA without CONFIG_NUMA_EMU does not make any sense on
    s390x (LP: #1557690)
    - [Config] CONFIG_NUMA_BALANCING_DEFAULT_ENABLED=n for s390x

  * spl/zfs fails to build on s390x (LP: #1519814)
    - [Config] s390x -- re-enable zfs
    - [Config] zfs -- disable powerpc until the test failures can be resolved

  * linux: sync to ZFS 0.6.5.6 stable release (LP: #1561483)
    - SAUCE: (noup) Update spl to 0.6.5.6-0ubuntu1, zfs to 0.6.5.6-0ubuntu1

  * zfs: enable zfs for 64bit powerpc kernels (LP: #1558871)
    - [Packaging] zfs -- handle rprovides via dpkg-gencontrol
    - [Config] powerpc -- convert zfs configuration to custom_override

  * Memory arena corruption with FUSE (was Memory allocation failure crashes
    kernel hard, presumably related to FUSE) (LP: #1505948)
    - SAUCE: (noup) fuse: do not use iocb after it may have been freed
    - SAUCE: (noup) fuse: Add reference counting for fuse_io_priv

  * cgroup namespaces: add a 'nsroot=' mountinfo field (LP: #1560489)
    - SAUCE: (noup) cgroup namespaces: add a 'nsroot=' mountinfo field

  * linux packaging: clear remaining redundant delta (LP: #1560445)
    - [Debian] Remove generated intermediate files on clean

  * arm64: guest hangs when ntpd is running (LP: #1549494)
    - Revert "hrtimer: Add support for CLOCK_MONOTONIC_RAW"
    - Revert "hrtimer: Catch illegal clockids"
    - Revert "KVM: arm/arm64: timer: Switch to CLOCK_MONOTONIC_RAW"

  * Need enough contiguous memory to support GICv3 ITS table (LP: #1558828)
    - [Config] CONFIG_FORCE_MAX_ZONEORDER=13 on arm64
    - SAUCE: (no-up) arm64: gicv3: its: Increase FORCE_MAX_ZONEORDER for Cavium
      ThunderX

  * update arcmsr to version v1.30.00.22-20151126 to fix card timeouts
    (LP: #1559609)
    - arcmsr: fixed getting wrong configuration data
    - arcmsr: fixes not release allocated resource
    - arcmsr: make code more readable
    - arcmsr: adds code to support new Areca adapter ARC1203
    - arcmsr: changes driver version number
    - arcmsr: more readability improvements
    - arcmsr: Split dma resource allocation to a new function
    - arcmsr: change driver version to v1.30.00.22-20151126

  * server image has no keyboard, desktop image works (LP: #1559692)
    - [Config] Rework input-modules (d-i) list

  * PMU sup...

Read more...

Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers