hibernation doesn't shutdown the computer

Bug #151546 reported by Boris de Laage on 2007-10-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When I want to suspend the computer with the hibernate option, there's no feedback of what is happening, and the computer stays on.

Hibernation _works_: if I turn the computer off (after some minutes, just to be sure all pages are written on disk) & on again, it resumes correctly.

I've edited /etc/default/acpi-support to make suspend & hibernate work (disabling vbestate & post_video). I've tried to change hibernate_mode from shutdown to platform, but it doesn't change anything.

/var/log/syslog:
Oct 11 12:03:27 clementine kernel: [ 107.887134] ACPI: PCI interrupt for device 0000:01:09.0 disabled
Oct 11 12:06:44 clementine kernel: [ 109.829213] PM: suspend-to-disk mode set to 'platform'
Oct 11 12:06:44 clementine kernel: [ 109.829444] swsusp: Basic memory bitmaps created
Oct 11 12:06:44 clementine kernel: [ 109.829447] Stopping tasks ... done.
Oct 11 12:06:44 clementine kernel: [ 110.244328] Shrinking memory... ^H-^H\^H|^H/^Hdone (31740 pages freed)
Oct 11 12:06:44 clementine kernel: [ 110.652418] Freed 126960 kbytes in 0.40 seconds (317.40 MB/s)
Oct 11 12:06:44 clementine kernel: [ 110.652909] Suspending console(s)
Oct 11 12:06:44 clementine kernel: [ 110.652944] sd 3:0:0:0: [sda] Synchronizing SCSI cache
Oct 11 12:06:44 clementine kernel: [ 110.683105] usb_endpoint usbdev2.2_ep04: PM: suspend 0->1, parent 2-1:1.2 already 2
Oct 11 12:06:44 clementine kernel: [ 110.683109] usb_endpoint usbdev2.2_ep84: PM: suspend 0->1, parent 2-1:1.2 already 2
Oct 11 12:06:44 clementine kernel: [ 110.994469] usb_device usbdev3.1: PM: suspend 0->1, parent usb3 already 2
Oct 11 12:06:44 clementine kernel: [ 110.994472] usb_endpoint usbdev3.1_ep81: PM: suspend 0->1, parent 3-0:1.0 already 2
Oct 11 12:06:44 clementine kernel: [ 110.994475] hub 3-0:1.0: PM: suspend 2->1, parent usb3 already 2
Oct 11 12:06:44 clementine kernel: [ 110.994477] usb_endpoint usbdev3.1_ep00: PM: suspend 0->1, parent usb3 already 2
Oct 11 12:06:44 clementine kernel: [ 110.994926] pnp: Device 00:0b disabled.
Oct 11 12:06:44 clementine kernel: [ 110.995101] pnp: Device 00:0a disabled.
Oct 11 12:06:44 clementine kernel: [ 110.995257] pnp: Device 00:09 disabled.
Oct 11 12:06:44 clementine kernel: [ 110.995287] NVRM: RmPowerManagement: 3
Oct 11 12:06:44 clementine kernel: [ 111.394527] ACPI: PCI interrupt for device 0000:00:06.0 disabled
Oct 11 12:06:44 clementine kernel: [ 111.394618] ACPI: PCI interrupt for device 0000:00:02.2 disabled
Oct 11 12:06:44 clementine kernel: [ 111.410328] ACPI: PCI interrupt for device 0000:00:02.1 disabled
Oct 11 12:06:44 clementine kernel: [ 111.426310] ACPI: PCI interrupt for device 0000:00:02.0 disabled
Oct 11 12:06:44 clementine kernel: [ 111.442358] pci_set_power_state(): 0000:00:00.0: state=3, current state=5
Oct 11 12:06:44 clementine kernel: [ 111.442392] Disabling non-boot CPUs ...
Oct 11 12:06:44 clementine kernel: [ 111.442395] PM: snapshotting memory.
Oct 11 12:06:44 clementine kernel: [ 111.442610] swsusp: critical section:
Oct 11 12:06:44 clementine kernel: [ 111.488902] swsusp: Need to copy 125598 pages
Oct 11 12:06:44 clementine kernel: [ 111.488906] swsusp: Normal pages needed: 118107 + 1024 + 24, available pages: 129030
Oct 11 12:06:44 clementine kernel: [ 63.034879] PM: Image restored successfully.

uname -a:
Linux clementine 2.6.22-14-generic #1 SMP Wed Oct 10 06:00:47 GMT 2007 i686 GNU/Linux

/etc/default/acpi-support:
# Comment the next line to disable ACPI suspend to RAM
ACPI_SLEEP=true

# Comment the next line to disable suspend to disk
ACPI_HIBERNATE=true

# Change the following to "standby" to use ACPI S1 sleep, rather than S3.
# This will save less power, but may work on more machines
ACPI_SLEEP_MODE=mem

# Add modules to this list to have them removed before suspend and reloaded
# on resume. An example would be MODULES="em8300 yenta_socket"
#
# Note that network cards and USB controllers will automatically be unloaded
# unless they're listed in MODULES_WHITELIST
MODULES=""

# Add modules to this list to leave them in the kernel over suspend/resume
MODULES_WHITELIST=""

# Should we save and restore state using the VESA BIOS Extensions?
SAVE_VBE_STATE=false

# The file that we use to save the vbestate
VBESTATE=/var/lib/acpi-support/vbestate

# Should we attempt to warm-boot the video hardware on resume?
POST_VIDEO=false

# Save and restore video state?
# SAVE_VIDEO_PCI_STATE=true

# Should we switch the screen off with DPMS on suspend?
USE_DPMS=true

# Use Radeontool to switch the screen off? Seems to be needed on some machines
# RADEON_LIGHT=true

# Uncomment the next line to switch away from X and back again after resume.
# This is needed for some hardware, but should be unnecessary on most.
DOUBLE_CONSOLE_SWITCH=true

# Set the following to "platform" if you want to use ACPI to shut down
# your machine on hibernation
#HIBERNATE_MODE=shutdown
HIBERNATE_MODE=platform

# Comment this out to disable screen locking on resume
LOCK_SCREEN=true

# Uncomment this line to have DMA disabled before suspend and reenabled
# afterwards
# DISABLE_DMA=true

# Uncomment this line to attempt to reset the drive on resume. This seems
# to be needed for some Sonys
# RESET_DRIVE=true

# Add services to this list to stop them before suspend and restart them in
# the resume process.
STOP_SERVICES=""

# Restart Infra Red services on resume - off by default as it crashes some
# machines
RESTART_IRDA=false

# Switch to laptop-mode on battery power - off by default as it causes odd
# hangs on some machines
ENABLE_LAPTOP_MODE=false

# Spindown time on battery
SPINDOWN_TIME=12

Boris de Laage (bbloup) on 2007-10-11
description: updated
Johan (deberghes-johan) wrote :

Have you a nvidia card, and the nvidia proprietary driver activacted into the restricted manager ? If so, could you deactivate it, and retry to hibernate ?

I confirm the bug on Intrepid on a desktop.
The computer not turn off automatically, I need to turn off it manually...

Peter Belmont (pabelmont2007) wrote :

What I used to get out of HIBERNATE is that the computer does a little quiet thinking and then turns itself OFF.
Upon restarting, it picks up where it left off, and all rather quickly.

NOT ANYMORE (since November?).

Now, when I hit HIBERNATE (DELL VOSTRO 200) (2/24/2009 up-to-date UBUNTU)
it
        >>> quietens and slows down for 35 seconds <<<

and then RESTARTS without EVER turning off its power.

What happens after I turn off the power depends on WHEN I do that. There are 3 cases:

[1] If I turn off the power BEFORE 35 seconds, I must do a full (non-hibernate) STARTUP the next time I turn the power on.

[2] If I turn off the power JUST AS HIBERNATE STARTS ITS RESTART, (at 35-40 seconds ? after the loud fan or disk noise starts up again) then I get a true HIBERNATE, which restarts where I left things.

[3] If I let HIBERNATE's automatic RESTART go too far, and then turn off the power (say at 50 seconds), then when I restart the computer, I get a sort of ERROR-CORRECTING RESTART with slews of error messages.

Jason Oster (parasyte) wrote :

I see the same bug; Vostro 200, Jaunty.

Using defaults in /etc/default/acpi-support is ok, except this "reboot instead of power down" annoyance. Pressing the power button at the DELL POST screen is enough to get what I need.

Changing hibernate_mode to "platform" also did not change anything.

sudo pm-hibernate
and
sudo s2disk

Both exhibit the problem. It's probably kernel ACPI support.

David Pérez (sanete) wrote :

The same happens with 2 laptops I have bought recently:

- Medion Akoya laptop, i3 core based and HD3000 graphis card, and
- an Asus i7 core based with an NVidia 6100 graphics card, and no propiertary graphics driver

I'm using Precise Pangolin 64 bits.

mehmet.nural (zxcq14) wrote :

same problem with asus x54hr-sx084r
i have to turn off manually

mehmet.nural (zxcq14) wrote :

That problem solved for me with linux kernel 3.2.0-32-generic

Changed in ubuntu:
status: Confirmed → Fix Released
affects: ubuntu → linux (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers