Resume after suspend to disk or suspend to ram fails

Bug #151471 reported by Travis Jensen on 2007-10-11
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source-2.6.22

I am seeing what looks like the same behavior on my Latitude D820 with Gutsy. Note that my laptop has an nvidia graphics card and I am using the restricted nvidia new driver.

Linux nefarian 2.6.22-14-generic #1 SMP Wed Oct 10 06:00:47 GMT 2007 i686 GNU/Linux

The attached file contains:

dmesg.log, dmidecode.log, lspci-wnn.log, uname-a.log: outputs previous to suspending
dmesg.log.postsuspend: dmesg output after suspending and booting (as per notes in https://wiki.ubuntu.com/DebuggingKernelSuspend)
kern.log.0: rolled over kern.log (as per notes in https://wiki.ubuntu.com/DebuggingKernelSuspend).

My bug looks very similar to https://bugs.launchpad.net/ubuntu/+bug/131628. Let me know if I can do anything else to help debug this.

tj

Travis Jensen (travis-jensen) wrote :
Nanley Chery (nanoman) on 2007-12-01
Changed in linux-source-2.6.22:
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.22:
assignee: nobody → ubuntu-kernel-acpi
Joe (jaoag) wrote :

I am seeing this problem as well under Gutsy (motherboard: MSI MS-7125 (nforce 4 ultra); processor: AMD 64 4200+). I have tried various modes ( with X running), with X shut down, framebuffer on or off, and for these logs, I have booted the system with no loaded services (vga=0 init=/bin/bash) and followed the directions in the wiki. The system will suspend (apparently) correctly, but it will not restore, the hdd activity light turns on and stays there until the system is reset. According to dmesg it is hanging on a random pseudo terminal (in this log - /dev/ptyy0)

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

*This is an automated response*

This bug report is being closed because we received no response to the previous request for information. Please reopen this if it is still an issue in the actively developed pre-release of Jaunty Jackalope 9.04 - http://cdimage.ubuntu.com/releases/jaunty . To reopen the bug report simply change the Status of the "linux" task back to "New".

Changed in linux:
status: Incomplete → Won't Fix
Dag Rende (dag-s) wrote :

I usually test a suspend to disk after every new ubuntu release. In Jaunty Jackalope 9.04 beta i tries as usual, and at first it seemed to be the old result. After wakeup I got the color arts in the upper screen corner. I went away for a while and heard a beep from the other room. And when I got back there was a screen saver login! I tested a couple of s2disk and resume and it worked even if it took a long time. Tell me if you want some logs etc.
I have a Thinkpad T61 with Nvidia Quadro NVS 140M.

Curtis Hovey (sinzui) on 2012-04-09
Changed in linux-source-2.6.22 (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers