[Dell Inc. Dell Precision M3800] suspend/resume failure

Bug #1514587 reported by Joachim Van der Auwera on 2015-11-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Suspen/Resume is no longer working.
This started a week or two before the release of 15.10 en continues today (with 15.10 installed as soon as it was available).

The system seems to suspend correctly, but does not resume, niether by opening the lid or pressing the power button. I first need to keep de power button depressed for several seconds for the system to completely shut down before the system can be restarted.

ProblemType: KernelOops
DistroRelease: Ubuntu 15.10
Package: linux-image-4.2.0-17-generic 4.2.0-17.21
ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
Uname: Linux 4.2.0-17-generic x86_64
Annotation: This occurred during a previous suspend, and prevented the system from resuming properly.
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: joachim 3653 F.... pulseaudio
 /dev/snd/controlC1: joachim 3653 F.... pulseaudio
Date: Tue Jul 16 12:09:31 2024
DuplicateSignature: suspend/resume:Dell Inc. Dell Precision M3800:A06
ExecutablePath: /usr/share/apport/apportcheckresume
Failure: suspend/resume
HibernationDevice: RESUME=UUID=54174578-7c59-4daf-b39c-279689459ece
InstallationDate: Installed on 2014-10-28 (377 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
InterpreterPath: /usr/bin/python3.4
MachineType: Dell Inc. Dell Precision M3800
ProcCmdline: /usr/bin/python3 /usr/share/apport/apportcheckresume
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-17-generic.efi.signed root=UUID=cf142bff-2edf-421a-b5c9-d3c7af67a34a ro quiet splash vt.handoff=7
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-17-generic N/A
 linux-backports-modules-4.2.0-17-generic N/A
 linux-firmware 1.149.1
SourcePackage: linux
Title: [Dell Inc. Dell Precision M3800] suspend/resume failure
UpgradeStatus: Upgraded to wily on 2015-10-22 (18 days ago)
UserGroups:

dmi.bios.date: 07/16/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: Dell Precision M3800
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/16/2014:svnDellInc.:pnDellPrecisionM3800:pvrA06:rvnDellInc.:rnDellPrecisionM3800:rvrA06:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: Dell Precision M3800
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.

dmesg.txt as captured using "dmesg > dmesg.txt" after doing a suspend using the command
sudo sh -c "sync && echo 1 > /sys/power/pm_trace && pm-suspend"

This could be a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1495043

I already tried installing the latest upstream kernel linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb but that did not help (I uninstalled it again).

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium

Just as a possibility, I'd check if you have any pm-suspend scripts which remove drivers for sleep. It there are scripts in /etc/pm/sleep.d, they are not currently being called. Have a look at what they do, and if they remove modules, try manually removing the modules before suspending, and see if that fixes it.

tags: added: bios-outdated-a10
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Thanks for your help.

I have upgraded the BOIS to version A10, but that does not seem to have made a difference.

I have checked the files in /etc/pm/sleep.d. There are three files there:
10_grub-common
10_unattended-upgrades-hibernate
novatel_3g_suspend

The first doesn't do anything on suspend.
The last seems to not do anything (it is looking for a non-existing directory). I did double check though by calling it directly with the "suspend" parameter, but that did not seem to make a difference.

It does seems that after a suspend/force shutdown/boot cycle, that the network often does not come up. Not sure if that is in any way related.

Joachim Van der Auwera, could you please test the latest upstream kernel available from the very top line at the top of the page from http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for testing, and please do not test the daily folder)? Install instructions are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:
kernel-fixed-upstream
kernel-fixed-upstream-X.Y-rcZ

Where X, Y, and Z are numbers corresponding to the kernel version.

If the mainline kernel does not fix the issue, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-X.Y-rcZ

Please note, an error to install the kernel does not fit the criteria of kernel-bug-exists-upstream.

Once testing of the latest upstream kernel is complete, please mark this report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

tags: added: latest-bios-a10
removed: bios-outdated-a10

Installed the latest kernel from mainline (4.3.0-, but the problem persists.
Is there a way I can provide extra information or additional things I can test?

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-4.3.0-040300
Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Joachim Van der Auwera, the next step is to fully commit bisect from kernel 3.19 to 4.2 in order to identify the last good kernel commit, followed immediately by the first bad one. This will allow for a more expedited analysis of the root cause of your issue. Could you please do this following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions is not fully commit bisecting.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

tags: added: kernel-bug-exists-upstream-4.3 needs-bisect regression-release
removed: kernel-bug-exists-upstream-4.3.0-040300
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Ok. I have tried to search for a working kernel again, but it seems I cannot find one.
I have tried 4.3, 4.2, 4.0.1, 3.19.0.31, 3.16.0.34 and I cannot get resume to work properly on any of them.

That last one is the oldest kernel which was installed on my system. I am pretty sure I was able to get resume to work on of of the older kernels on my system earlier on, but I am not able to reproduce that now.

Should I go further back in time testing older kernels?

Regarding the comment about the files in /etc/pm/sleep.d/ not being called.
If I look at the SleepLog.txt file included in the repot, it seems that they are being called.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

I just tried reinstalling the system to assure the problem is not caused by successive update.
Unfortunately, that did not help either.

Joachim Van der Auwera, could you please provide the missing information following https://wiki.ubuntu.com/DebuggingKernelSuspend ?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Reinstalled 15.10 (keeping my home)
current output for uname -a:

Linux joachim-Dell-Precision-M3800 4.2.0-18-generic #22-Ubuntu SMP Fri Nov 6 18:25:50 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I recaptured the dmesg.txt file and include the wakeup file (sorry I missed that earlier)

I also notice an xsession error log appearing (not sure if this is in any way related)

I also have apport reporting problems which include the following (again, don't know if this is relevant in any way)

PulseList
Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon

Joachim Van der Auwera, as outlined in the article, one should capture the dmesg and wakeup with the latest mainline kernel (not the Ubuntu kernel).

Sorry about that. New version with latest from mainline (4.3 - the 4.4.Rc1 seems empty - only a headers deb)
uname -a

Linux joachim-Dell-Precision-M3800 4.3.0-040300-generic #201511020949 SMP Mon Nov 2 14:50:44 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
?field.comment=Sorry about that. New version with latest from mainline (4.3 - the 4.4.Rc1 seems empty - only a headers deb)
uname -a

Linux joachim-Dell-Precision-M3800 4.3.0-040300-generic #201511020949 SMP Mon Nov 2 14:50:44 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

when the nvidia drivers is enabled, the 4.3.0 kernel from mainline does not boot.
The output above uses the the x.org "nouveau" driver.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: removed: need-duplicate-check

I there something I can do now to help work towards a solution?
I guess it would be good if this could be fixed for the 16.04 LTS release.

Joachim Van der Auwera, testing the latest mainline kernel (4.4) would be helpful here.

Tested using 4.4.0-rc8 (v4.4-rc8-wily is two days more recent than v4.4-wily so I tested rc8).

Linux joachim-Dell-Precision-M3800 4.4.0-040400rc8-generic #201601130531 SMP Wed Jan 13 10:33:09 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

When I try to suspend by closing the lid it seems that the system basically shuts down.
When I use the suspend item from the menu then the behaviour is as before. The system seems to crash on resume and power needs to be held for 10s to force shutdown to allow it to boot again.

Joachim Van der Auwera, to advise, 4.4 is actually more recent than 4.4-rc8. The timestamp is access, not release.

tags: added: kernel-bug-exists-upstream-4.4-rc8
removed: kernel-bug-exists-upstream-4.3

ok, new attempt using 4.4

$ uname -a
Linux joachim-Dell-Precision-M3800 4.4.0-040400-generic #201601101930 SMP Mon Jan 11 00:32:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Behaviour is now the reverse from test with rc8.

- suspend item from menu seems to shutdown the system
- closing the lid seems to crash. The power buttons needs to be held for 10s to force shutdown to allow it to boot again.

Joachim Van der Auwera, in order to upstream, could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-nightly/ and advise to the results?

tried the latest (994), but this causes problems.

during installation it displayed the following warning

W: Possible missing firmware /lib/firmware/i915/skl_guc_ver4.bin for module i915

The system almost instantly crashed after logging in (when trying to open a terminal). My hipchat also crashed.

Joachim Van der Auwera, to clarify https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1514587/comments/25 , did it fail to resume from both methods?

Regarding comment 25, when I close and a little later open the lid the system does come back up but seems to have forgotten all state from the shutdown. The login screen doies not remember the scale factor of the screen and after logging in none of the open applications are still open.

Joachim Van der Auwera, to clarify, I'm asking the following:
1) Does resume from suspend work/not work when initiating it from menu?
2) Does resume from suspend work/not work when initiating it from lid close/open? -> You answered this already.

From the menu, suspend does not work. Screen is turned off, but it is not possible to get it back to life (apart from 10s power to completely shut down the system and then rebooting)

Joachim Van der Auwera, given the inconclusiveness of performing the bisect, it indicates that the root cause may not be it here, or has an additional, to be identified dependency.

With this in mind, the necessary root causing debugging information has been expanded. Hence, could you please provide this with 4.4 via https://wiki.ubuntu.com/DebuggingKernelSuspend ?

tags: added: kernel-bug-exists-upstream-4.4 unable-to-bisect-kernel
removed: kernel-bug-exists-upstream-4.4-rc8 needs-bisect
Changed in linux (Ubuntu):
status: Triaged → Incomplete

uname -a output:

Linux joachim-Dell-Precision-M3800 4.4.0-040400-generic #201601101930 SMP Mon Jan 11 00:32:41 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Followed the "resume-trace" debugging procedure you mentioned, dmesg.txt file attached.

I hope this helps.

In this case the suspend/resume came up but no state was remembered.

Not sure if this is useful, but here is alink to similar problems under Windows
http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/workstation-crashes-sometimes-when-lid-is-closed/2c3c38a7-dee7-4ee8-a233-a5031f59110c?db=5&auth=1
They say that it is all usb related.

In the mean time I had a hardware failure on my machine which resulted in a replaced motherbord.
This gives me good news. It seems the suspend/resume problems are gone with this new motherboard.

Joachim Van der Auwera, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1514587/comments/37 regarding this being due to hardware failure. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
importance: Medium → Undecided
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers