Ubuntu 15.10 freezes occasionally

Bug #1511019 reported by Stasia on 2015-10-28
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

Lenovo G50-30 WIly 15.10 freezes!
More often when I use touchpad, less with a mouse. Always freezes when streaming a video from youtube in the browser or Totem player. Keyboard is inactive after the freeze so nothing helps only reboot. Also happened in 15.04.

After several reboots like that it's impossible to switch off the laptop from OS interface - it hangs on and on and I finally have to press switch-off button.

WORKAROUND: Use kernel boot parameter:
intel_idle.max_cstate=1

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: linux-image-4.2.0-16-generic 4.2.0-16.19 [modified: boot/vmlinuz-4.2.0-16-generic]
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: scani 1445 F.... pulseaudio
CurrentDesktop: Unity
Date: Wed Oct 28 18:16:52 2015
HibernationDevice: RESUME=UUID=a94e1d4b-d122-47cb-86a9-9090d0b0bda4
InstallationDate: Installed on 2015-10-24 (3 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: LENOVO 80G0
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-16-generic.efi.signed root=UUID=8af48aa3-e87a-482f-9e46-6d3ca072423d ro noprompt persistent quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-4.2.0-16-generic N/A
 linux-backports-modules-4.2.0-16-generic N/A
 linux-firmware 1.149
SourcePackage: linux
UdevLog: Error: [Errno 2] Нет такого файла или каталога: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/18/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: A7CN40WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: Lancer 5A6
dmi.board.vendor: LENOVO
dmi.board.version: NANANANANO DPK
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo G50-30
dmi.modalias: dmi:bvnLENOVO:bvrA7CN40WW:bd07/18/2014:svnLENOVO:pn80G0:pvrLenovoG50-30:rvnLENOVO:rnLancer5A6:rvrNANANANANODPK:cvnLENOVO:ct10:cvrLenovoG50-30:
dmi.product.name: 80G0
dmi.product.version: Lenovo G50-30
dmi.sys.vendor: LENOVO

Stasia (scani) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Denis (d-anuschewski) wrote :

I have an ASUS F751M with 64bit Ubuntu 15.10 and I am experiencing a very similar behavior.

Often hangs while scrolling with two fingers on touchpad or streaming videos, very often hangs when using evice document viewer. Worked fine with Ubuntu 15.04

Stasia (scani) wrote :

I installed 4.1.12 kernel and I have no more freezes at all. When will the problem be solved for a current kernel? This is so embarrassing!

Stasia (scani) wrote :

Stasia, thank you for reporting this and helping make Ubuntu better.

As per http://support.lenovo.com/us/en/products/laptops-and-netbooks/lenovo-g-series-laptops/g50-30-notebook-lenovo an update to your computer's buggy and outdated BIOS is available (48). If you update to this following https://help.ubuntu.com/community/BIOSUpdate does it address the issue?

If it doesn't, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

Also, you don't have to create a new bug report.

Once the BIOS is updated, if the problem is still reproducible, and the information above is provided, then please mark this report Status Confirmed. Otherwise, please mark this as Invalid.

Thank you for your understanding.

tags: added: bios-outdated-a7cn48ww
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
sangharsh (sangharshbyss) wrote :

I face the same problem but it seems that my BIOS is updated.
output for - "dmidecode -s bios-version"
A7CN44WW
output for - "sudo dmidecode -s bios-release-date"
10/21/2014

Stasia (scani) wrote :

There is a workaround that worked for me:

You should use the kernel parameter: "intel_idle.max_cstate=1"

do these steps:

1. sudo nano /etc/default/grub
2. There is a line in that: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (like this), replace with: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
Save it (CTRL+O)
3. sudo update-grub
4. sudo reboot

Your CPU will be a little warmer.

description: updated
Dina Chu (baltimore-kyz) wrote :

I have a similar issue on ASUS F555L. It started to freeze after restart about a week ago. Like in OP's case, I have to use a switch off button to turn it off. I found that it boots without freezing if I choose the upstart option upon booting.

sangharsh (sangharshbyss) wrote :

Thanks @Stasia,
May I know how you came to know about this workaround?

Stasia (scani) wrote :

There is a big discussion here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1509723 (see comments 42 and 46)

sangharsh (sangharshbyss) wrote :

Dear Stasia,
Thanks again! this workaround has solved my problems till now!! But still I wonder why they have not found any solution for this bug yet??

Stasia (scani) wrote :

@sangharsh,
This is ridiculous, isn't it? Must've been going for a YEAR now as it was first reported on 2015-01-04 here https://bugs.freedesktop.org/show_bug.cgi?id=88012

sangharsh (sangharshbyss) wrote :

@Stasia,
Its ridiculous. I don't know how we can contribute in correcting this.
Any way I filed a bug report too and you may like to go through the answer by Joseph Salisbury.

sangharsh (sangharshbyss) wrote :

@Stasia,
True its ridiculous. I don't know how we can contribute to correct this.
Any way, I also have filed the bug report and answer by Joseph Salisbury seems interesting. Please have a look. Here is a link -
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1542657

sangharsh (sangharshbyss) wrote :

@Stasia,
Upgrade to Karnel 4.5 solves the issue. My experience till now.
@Dina Chu
it might help you too - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1542657/comments/3

moueza (mouezapeter) wrote :

Affected too with Lenovo g50-30
Hangs arround once a day
I will try your solutions

moueza (mouezapeter) wrote :

With Lenovo g50-30, kernel 4.2.0-27-generic #32-Ubuntu SMP
Affected too
Hangs arround once a day
Drives to unresponsive keyboard, so must press power button

KM (karthikesh) wrote :

Lenovo G50-30 . Upgraded to the kernel to 4.5. And upgraded BIOS too to A7CN48WW.
But it still hangs many times a day.

KM, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

KM (karthikesh) wrote :

Any update on this ? Thanks for your efforts.

sangharsh (sangharshbyss) wrote :

Dear Karthikesh ( @KM ),
Please refer to the work-around suggested by Stasia. That has solved my problem.
Here is link. :
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1511019/comments/8

Lancillotto (antonio-petricca) wrote :

Me too on Dell Latitude E5450.

Lancillotto (antonio-petricca), it will help immensely if you use the computer the problem is reproducible with, and provide necessary debugging logs by filing a new report with Ubuntu via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

Lancillotto (antonio-petricca) wrote :

Christopher, I would accomplish that, but I am running Mint 18.3 (Ubuntu 16.04) and ubuntu-bug report me that it cannot send a report for my (unsupported) distribution.

Can I force it to submit the report?

The freeze scenario is:

- Start docker
- Run gitlab-ce on docker
- Run jenkins on docker
- Run chromium web browser
- Run firefox
- Wait some minutes... at voilà!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.